Sort search results by relevance

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
3 years ago

People

(Reporter: urkle, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Currently when searching for an extension the results are returned alphabetically instead of by the relevance of the terms searched.  Is a full text search engine not being used to search extensions?? If not it should be switched to using one to provide more usable search results. 

Reproducible: Always

Comment 1

13 years ago
Do you have a suggestion for a replacement for WHERE field LIKE '%search%text%' ?
(Reporter)

Comment 2

13 years ago
Using a fulltext engine would allow for results by relavence. For the MySQL database engine by creating a fulltext index on the columns to search. (This would also allow searching multiple columns with one "search")

http://dev.mysql.com/doc/refman/4.1/en/fulltext-search.html

Other database engines also have fulltext engines as well.
(One easy relevance boost might be preferring name hits to description hits.)
Assignee: morgamic → nobody
Target Milestone: 1.0 → ---

Comment 4

13 years ago
The results don't even seem to be alphabetical. The results for the search "adblock" are the following:

1. Adblock Filterset.G Updater
2. Adblock Plus
3. dutchblock
4. Bork Bork Bork!
5. Quick Preference Button
6. Adblock
7. ImgLikeOpera

The direct match Adblock is number 6 in the list! A similar thing happens for other extensions with multiple versions... like Forecastfox.

Comment 5

13 years ago
(In reply to comment #4)
> The results don't even seem to be alphabetical. 
>
Indeed not. The detault sort is now "newest."

Confirming. This should be fixed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Search results need to be sorted by relevance instead of alphabetically → Sort search results by relevance
Version: unspecified → 2.0

Comment 6

12 years ago
*** Bug 345518 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
*** Bug 348485 has been marked as a duplicate of this bug. ***
current status:
Remora sorts the search results by add-on id, so the possibility is high that the first results are not compatible with the use firefox.

Comment 9

12 years ago
They are meanwhile sorted by relevance (and there was a bug for it, but I didn't find it anymore :-/) -- in any case, fixed in Remora.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.