Search algorithm buggy: search for exact extension name doesn't even list that extension

RESOLVED DUPLICATE of bug 327316

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED DUPLICATE of bug 327316
12 years ago
3 years ago

People

(Reporter: Chris Pratt, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

I've had this problem before when searching for other plugins, but I don't remember what all I've search for. Most recently, I searched addons.mozilla.org with the query: "web developer" (without quotes), looking for the Web Developer toolbar. I also tried the queries "web developer toolbar", "webdeveloper", and "webdeveloper toolbar". None of these actually returned the Web Developer Toolbar extension I was looking for. Contrast to Google, where I ran the search "web developer toolbar" and received the exact page on addons.mozilla.org containing the extension as the first result. Logic would dictate that an exact matching title to the search query would return as the first result, but this rarely happens when searching on addons.mozilla.org.

Reproducible: Always

Steps to Reproduce:
1. Search using the query "web developer".
2. Stand back in awe as you get everything but the actual web developer extension :)

Comment 1

12 years ago
https://addons.mozilla.org/search.php?q=web+developer&app=firefox shows the Web devloper toolbar about halfway down the first page for me. These are sorted by last modified, so it could get pushed further down if other developers modify their add-ons They should be sorted by relevance.

If, after looking again, the web developer toolbar doesn't even show up for you, please reopen this bug and we'll see what we can do.

Ps. Please note the significant differences between plugins and extensions in the Mozilla world :)

*** This bug has been marked as a duplicate of 327316 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Component: Add-ons → Public Pages
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Summary: Search algorithm buggy: search for exact plugin name doesn't even list that plugin → Search algorithm buggy: search for exact extension name doesn't even list that extension
Version: unspecified → 2.0
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.