Closed Bug 327744 Opened 14 years ago Closed 14 years ago

[Intel OS X] SVG implementation/support isn't fully functional.

Categories

(Core :: SVG, defect)

1.8 Branch
PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: riscky, Assigned: mark)

References

Details

(Keywords: fixed1.8.1, verified1.8.0.4)

Attachments

(4 files, 1 obsolete file)

Using either Camino 1.0 or home made DeerPark builds fully functional.

Visit http://www.croczilla.com/svg/samples/ and view the sample svg's, some work like arcs1 while others, more complex examples like butterfly fail... while these same example render just fine on PPC builds.
I can reproduce this on an intel mac (OS X 10.4.6) using the universal Deer Park build from the Mac:Intel page of the wiki:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.2) Gecko/20060403 Firefox/1.5.0.2

Things render as expected using the same version, but running on a PPC mac (OS X 10.4.6):
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.2) Gecko/20060403 Firefox/1.5.0.2

Psychedelic colours on the intel when there are gradients happening. Woo!
Flags: blocking1.8.0.3?
Version: Trunk → 1.8 Branch
CC'ing Josh to see if we want/need this for 1.8.0 branch, and whether or not they can put together a patch for it.
Looks like endian nastiness. cc'ing pav since he'll probably know more about where in our rendering chain this happens.
Just a couple examples for folks who aren't on intel macs and want to see what we're talking about.
Flags: blocking1.8.0.3? → blocking1.8.0.3+
Alpha weirdness, maybe?

I don't see this on a trunk x86 build, but I do on the 1.8.0 branch.
...more thinking aloud...branch cairo version?
Both of my guesses were correct.
Assignee: general → mark
Attached patch Patch (obsolete) — Splinter Review
I only intend this for the 1.8 and 1.8.0 branches, unless stuart or vlad or someone has a good reason to need it on the trunk, where the bug is not present.
Attachment #217809 - Flags: superreview?(vladimir)
Attachment #217809 - Flags: review?(pavlov)
Attached patch PatchSplinter Review
Attachment #217809 - Attachment is obsolete: true
Attachment #217810 - Flags: superreview?(vladimir)
Attachment #217810 - Flags: review?(pavlov)
Attachment #217809 - Flags: superreview?(vladimir)
Attachment #217809 - Flags: review?(pavlov)
Comment on attachment 217810 [details] [diff] [review]
Patch

This looks fine to me for 1.8.0 especially; it can go in to 1.8.1, but we're thinking about doing a cairo uplift from the trunk to 1.8.1 as well.
Attachment #217810 - Flags: superreview?(vladimir) → superreview+
Attachment #217810 - Flags: review?(pavlov) → review+
Comment on attachment 217810 [details] [diff] [review]
Patch

If a cairo update on 1.8.1 isn't certain, let's get this on there just to cover all the bases.
Attachment #217810 - Flags: approval1.8.0.3?
Attachment #217810 - Flags: approval-branch-1.8.1?(vladimir)
Comment on attachment 217810 [details] [diff] [review]
Patch

Yeah, I agree about 1.8.1
Attachment #217810 - Flags: approval-branch-1.8.1?(vladimir) → approval-branch-1.8.1+
Checked in on the 1.8 branch.
Status: NEW → RESOLVED
Closed: 14 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
*** Bug 333939 has been marked as a duplicate of this bug. ***
Comment on attachment 217810 [details] [diff] [review]
Patch

approved for 1.8.0 branch, a=dveditz for drivers
Attachment #217810 - Flags: approval1.8.0.3? → approval1.8.0.3+
Checked in, 1_8_0 for 1.8.0.3
Keywords: fixed1.8.0.3
verified fixed on the 1.5.0.4 branch using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.4) Gecko/20060504 Firefox/1.5.0.4. I was running the UB build and the the gradient image, lion image and other images from the croczilla site all look ok. Adding keyword.
*** Bug 336542 has been marked as a duplicate of this bug. ***
*** Bug 339510 has been marked as a duplicate of this bug. ***
With Camino 1.0.1, BonEcho a3, and Firefox 1.5.0.4 nightlies, there are still problems rendering images in the SVG namespace. Have a look at <http://www.croczilla.com/svg/samples/circles2/circles2.xml>. I am re-opening. Let me know if this should be a new bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Also of note is that Camino Version 2006042422 (1.0+) renders the SVG "Butterfly", "Lion", and "Gradients 1" tests correctly, but does not handle "Circles 2" properly.

Camino Version 2006042704 (1.0.1) does *not* render the SVG "Butterfly", "Lion", and "Gradients 1" tests correctly. Nor does it handle "Circles 2" correctly (although the background image is closer to being correct)

My comments refer to running these browsers on an intel mac without using Rosetta.
Amos, I've looked at this a little bit and it seems to be a problem with <svg:image>.  It should be in a new bug.
OK. I've created bug 340028 for the <svg:image> issue. Returning this to resolved -> fixed.

Thanks Mark.
Status: REOPENED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
The current release 1.5.0.4 Today 6/1/06 for OS X intel is "better", the colors render properly but plain old standard black text in SVG does not show now.  It worked before this latest fix.  This is the exact SVG code I'm using:

<text font-family="Verdana" font-size="13" x="48" y="14" style="text-anchor:middle">Sunday</text>

I'm also attaching a png screen capture too.  the top of the columns should be the days of the week "sunday, monday..."
Eric... I'm guessing that since this patch has been commited and the bug closed, the best thing to do would be to file a new one and possibly refer back to this one if you think it is related.

That's what I wound up doing for bug 340028 which seems to be related... or at least appears to be caused by the same sort of endian issue somewhere in the rendering chain.
Eric, I've researched the text problem and have created a new bug 340581. I have attached a test case to that bug.
You need to log in before you can comment on or make changes to this bug.