Closed Bug 327783 Opened 14 years ago Closed 13 years ago

Offer more ways to switch between mail/calendar views

Categories

(Calendar :: Lightning Only, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 371916

People

(Reporter: jminta, Unassigned)

References

Details

Follow from Bug 293192 Comment #10.  We either need to offer more numerous/intuitive ways to switch between calendar and mail views, or else figure out with certainty why additional ways are not necessary.  Hopefully we can get good feedback from 0.1 on this.
The more (unobtrusive) ways, the better. From my suggestion in bug 293192 comment 7, here's a possible solution (a "vertically sliding pane"):

+-----------------+---------------------------------------------------
| *Mail*          |  <--- Current View: Mail
|-----------------|
| Favorite Folders|
|-----------------|
| Account 1       |
|  * Inbox        |
|  * Templates    |
|  * Sent         |
| Local Folders   |
|  * ...          |
|-----------------|
|  Calendar       |  <--- Click to open Calendar (and collapse mail)
+-----------------+---------------------------------------------------

Opening Calendar would result in this:

+-----------------+---------------------------------------------------
|  Mail           |  <--- Click to open Mail (and collapse Calendar)
|-----------------|
| *Calendar*      |  <--- Current View: Calendar
|-----------------|
|  M T W T F S S  |
|  1 2 3 4<5>6 7  |
|  8 9 1011121314 |
|  ...            |
|-----------------|
| ToDo            |
| [x] Sleep more  |
+-----------------+---------------------------------------------------
In comment 1, does proposal just add buttons, or does it also remove the continuously adjustable splitter?

I think it is useful to have both the message pane and calendar list visible at the same time, so that a VEvent attachment from the message can be dragged to a calendar in calendar list.  If the sidebar buttons hide the calendar list when messages are visible, and hide the messages when the calendar list is visible, then a direct drag is not possible.  (If so, the workaround seems inconvenient: double click message to open separate window, click on *Calendar* button in main window to make calendar list visible, drag VEvent from message window attachment pane to calendar in main window calendar list, close message window, click on *Mail* button to go back to reading messages.)
Or (with message pane open) just drag a VEvent-attachment from a message and hover over the Calendar's collapsed pane area. After a second (or so), the pane opens, and the user can drop the VEvent-attachment onto a calendar(event).

And yes, the adjustable splitter would be removed, because my suggestion would already use all available space for the currently selected module (Mail/Calendar).
Christian Jansen's recent work seems to fit this bug.

Recent discussion:
http://groups.google.com/group/mozilla.dev.apps.calendar/browse_thread/thread/9663d69c1e4a303a/ecd55ea3b98c651e#ecd55ea3b98c651e

His JavaScript prototype:
http://cjansen.com/lightning-demo/accordion.htm

Marking blocking-calendar0.5 as a result
Flags: blocking-calendar0.5+
Duplicate of this bug: 337119
Duplicate of this bug: 345605
(In reply to comment #5)
> *** Bug 337119 has been marked as a duplicate of this bug. ***
> 

well, i'm not sure that's a dupe of this bug but fine to continue here.

lightning must accommodate all Tb views, even those (mail.pane_config.dynamic=3) where the message list and message pane do not form a 'box'.  lightning needs to occupy one or the other in this case.  currently, lighting permanently breaks Tb with that view.
Target Milestone: --- → Lightning 0.5
There's no patch here, no one assigned, and we're at the string freeze.  Minusing for 0.5.  Pushing to 0.7.
Flags: blocking-calendar0.5+ → blocking-calendar0.5-
Target Milestone: Lightning 0.5 → Lightning 0.7
Depends on: 371916
Milestone 0.7 Consolidation. Filter on PinkyANDBrain to get rid of bugspam.
Target Milestone: Lightning 0.7 → Sunbird 0.7
Flags: blocking-calendar0.7+
Whiteboard: [roadmap 0.7]
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: blocking-calendar0.7+
Resolution: --- → DUPLICATE
Whiteboard: [roadmap 0.7]
Target Milestone: 0.7 → ---
Duplicate of bug: 371916
Status: RESOLVED → VERIFIED
Flags: blocking-calendar0.5-
You need to log in before you can comment on or make changes to this bug.