Link Outlines (a la Microsoft IE) - pref to disable

VERIFIED WONTFIX

Status

()

P4
enhancement
VERIFIED WONTFIX
19 years ago
16 years ago

People

(Reporter: endah, Assigned: dbaron)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WONTFIX?)

(Reporter)

Description

19 years ago
Ever since the 'link outlines' were introduced into the mozilla browser project
(whereby, on clicking on a link - it is outlined with a dotted line), they have
not functioned properly (as indicated by existing filed bugs).

The original Netscape Browser works beautifully without outlining links.  I
would have thought that such an addition interferes with w3c standardisation.
With all the work put into achieving a consistent interface for Mozilla on any
platform (i.e. making work easy for designers) I would have thought there would
have been a drive to put power into the hands of the designer.  But to enforce a
law of outlining links undoes the usefulness of CSS control over
visited-links... and many other dynamic HTML possibilities.

Surely the designer is crippled?

There was a day recently when I downloaded the latest build of mozilla and it
ran without link outlines... this was a beautiful day.
If you want to suggest that outlines not be drawn, use the CSS rule
:link:focus, :visited:focus { outline: none; }

This is a feature.  Being able to navigate links by the keyboard is a good
thing.  People are working on the outline bugs...
Target Milestone: ---
(Reporter)

Comment 2

19 years ago
I thought that it might be the case that this is intended as a feature - but
shouldn't there be an option to switch it off in general?  I was looking through
the preferences and couldn't find an existing option to disable it - is there
one available in a configuration file somewhere perhaps?

Comment 3

19 years ago
What you are asking for, then, is an enhancement that is non-trivial.
The only way to do this without adding overhead to all event processing
would be to add in, based on a pref, the CSS rule given by 
dbaron@fas.harvard.edu prior to layout, for every page.

Changing Severity to "Enhancement" and passing to the "Style System"
Component.
Assignee: cbegle → pierre
Severity: normal → enhancement
Component: Browser-General → Style System
QA Contact: asadotzler → chrisd
Summary: Link Outlines (a la Microsoft IE) - should be removed → Link Outlines (a la Microsoft IE) - pref to disable

Comment 4

19 years ago
You will be certainly happy to learn that the latest builds don't outline links 
anymore. Problem: I don't know if it is by design or if something got broken in 
the outlines. I checked html.css and :link:focus still shows "outline: 1px dotted 
black".

Reassigned to rods to see if he has an explanation. However, I'm afraid your 
request for a pref to control the outline will be marked "Later".
Assignee: pierre → rods

Comment 5

19 years ago
I broke them on purpose and I am trying to get something working for beta2 
without fully implementing outline.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 6

19 years ago
Actually I didn't break them, I didn't check in what I thought I did. So I don't 
know why they don't work.

Comment 7

19 years ago
mass-move to M16
Target Milestone: --- → M16

Comment 8

19 years ago
non-essential for m16
Target Milestone: M16 → M17

Comment 9

19 years ago
core layout "outline" issues
Assignee: rods → karnaze
Status: ASSIGNED → NEW

Comment 10

19 years ago
Marking remind. This will not make release 1.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → REMIND
Target Milestone: M17 → M20
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
Reopening and moving to Future -- REMIND is deprecated.
Status: RESOLVED → REOPENED
Resolution: REMIND → ---
Whiteboard: [Hixie-PF]
Target Milestone: --- → Future

Comment 13

17 years ago
not a table bug
Assignee: karnaze → dbaron
Status: REOPENED → NEW
Priority: P3 → P4
*** Bug 50288 has been marked as a duplicate of this bug. ***
I'm highly tempted to WONTFIX this. We are already have way too many prefs and
you can already do this using userContent.css.
Whiteboard: [Hixie-PF] → WONTFIX?
Agreed.
Status: NEW → RESOLVED
Last Resolved: 19 years ago17 years ago
Resolution: --- → WONTFIX
VERIFIED WONTFIX
Status: RESOLVED → VERIFIED

Comment 18

17 years ago
See also bug 63962, "Focused appearance prefs are not exposed".

Comment 19

16 years ago
See also bug 190550, "Option to disable link outlines when using mouse".
You need to log in before you can comment on or make changes to this bug.