allow user to turn off borders around clicked links

VERIFIED DUPLICATE of bug 32818

Status

()

Core
Layout
P4
enhancement
VERIFIED DUPLICATE of bug 32818
18 years ago
16 years ago

People

(Reporter: Joakim Recht, Assigned: Kevin McCluskey (gone))

Tracking

({relnote})

Trunk
Future
relnote
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: relnote-user)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test7 i686; en-US; m18) Gecko/20000824
BuildID:    2000082408

A newly added "feature" shows a dotted border around links when you click on
then, like IE does. This looks very irritating, and there should be a way to
turn it off.

Reproducible: Always

Comment 1

18 years ago
*** Bug 50289 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
Reassigning from bdonohoe to hangas
Assignee: bdonohoe → hangas

Comment 3

18 years ago
This was intended as a way for links to show focus (otherwise focus can be 
seemingly 'lost' on a page since there's no visual indication to the user where 
it is).  Do you have any suggestions for more visually-appealing ways?

I don't understand why it's really that annoying (it'll be gone in two seconds 
once the new page loads), but over to Ian, cc rods who implemented the -moz-
outline I think (which is being used here).
Assignee: hangas → clayton
Status: UNCONFIRMED → NEW
Component: User Interface: Design Feedback → HTML Element
Ever confirmed: true
OS: Linux → All
QA Contact: mpt → petersen
Hardware: PC → All

Comment 4

18 years ago
Some links do not open a new page.  They might execute javascript in the current
page for example.

A sample case if you have the Beatnik player installed for either nn4x or IE.
Go to http://www.beatnik.com/emix/index.html and click on one of the artists to
launch a thing called an eMix.

When you get to the eMix page that has the qwerty layout, start clicking on the
buttons.  No outline in nav4 or IE.  But in moz, each click leaves a border
around the clicked image (you'll have to take my word for it since the 4x plugin
doesn't work in moz and the xpcom plugin is still under development).
Is the outline not erasing when the link is no longer focused?

Comment 6

18 years ago
That works fine

Comment 7

18 years ago
With the added exception of your bug 15439

Comment 8

18 years ago
David,
The main problem with outlines not repainting and all the grief we went though. 
was that they were painting on the outside of the 
frame. Now that -moz-outlines are painting on the inside of the frame there 
shouldn't be any problems.
-------------

Also, this feature was extrememly important for Accessability. Having focus on 
links for Accessability far outweighs the uglyness of having it.

In the future went might be able to have pref to turn them off, but at the 
moment we are short on time. futuring
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Assignee)

Comment 9

18 years ago
Dividing up claytons bugs to triage.
Assignee: clayton → kmcclusk
Status: ASSIGNED → NEW

Comment 10

18 years ago
massive update for QA contact.
QA Contact: petersen → lorca

Comment 11

17 years ago
suggestion for more visually-appealing ways of displaying border.
make border color the same as alink color, set the padding of the border to 1 to
give some room betwen the link and the border, set the line type to dotted or
make it thinner.
You can set the outline to be whatever you like, just hack your userContent.css
file. We should relnote that maybe.
Keywords: relnote
Hixie: Do we really want user release notes about hacking .css files? Marking 
relnote-devel for now...

Gerv
Whiteboard: relnote-devel
RELEASE NOTE ITEM:
   To disable borders around links, insert the following into    
   the 'userContent.css' file in your profile's chrome directory 
   (you may have to create this file): 

      :link:focus, :visited:focus { -moz-outline: none ! important; }
Whiteboard: relnote-devel → relnote-user
Does that still work, or do we implement link outlines differently now?
It works (tested).
(Assignee)

Comment 17

17 years ago
Marking fixed since it can be addressed with relnote specified by Ian 'Hixie'
Hickson.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

17 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 18

17 years ago
Reopening because 99.999% of the population will not be incliined to go into 
their user.css files to change something like that.  Myself included.

Comment 19

17 years ago
Perhaps, but 99.999% of users won't care that there are outlines around clicked 
links, and the intersection between that 99.999% and your 99.999% will be very 
high.

Comment 20

17 years ago
Touche.  Interesting point, kinda makes sense...
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 22

17 years ago
qa contact updated.
QA Contact: gerardok → bsharma
(Assignee)

Updated

17 years ago
Severity: normal → enhancement
SPAM. HTML Element component is deprecated, changing to Layout component. See
bug 88132 for details.
Come on Bugzilla, you can do it...
Component: HTML Element → Layout

Updated

16 years ago
QA Contact: bsharma → moied
(Assignee)

Comment 25

16 years ago
Build moving all existing future-P3 bugs to future-P4.
Priority: P3 → P4

*** This bug has been marked as a duplicate of 32818 ***
URL: any
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE
VERIFIED DUPLICATE... good catch :-)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.