Display attachments inline causes incorrect number of attachments to display

RESOLVED DUPLICATE of bug 35587

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 35587
12 years ago
10 years ago

People

(Reporter: Paul Mirowsky, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla Thunderbird version 1.5 (20051201)

An e-mail has 5 files viewed below the Header.
e-mail text with file5.vcf     2
file1.pdf                      1
file2.eml with file4.vcf       2
file3.pdf                      1

3 attachments are described as file1.pdf, file2.eml with file4.vcf and file3.pdf.
Both file4.vcf and file5.vcf are for the same person with the same e-mail address.
The originating e-mail is from the person described in the vcf files.

The folowing matrix is a table of the "Attachments:" displayed and the body of the e-mail text.
"Attachement:" column assumes the name of the file and not it's text.
????.vcf assumes the vcf card icon with name/emailaddress in body and vcf viewer icon in "Attachments:".  

_________________Display Attachment Inline__________________________
__e-mail zone: "Attachments:"______  __e-mail zone: Body text_______
>>Checked<<        >>Unchecked<<     >>Checked<<      >>Unchecked<<
(not displayed)    (not displayed)   e-mail text      e-mail text 
file1.pdf          file1.pdf         (not displayed)  (not displayed)
file2.eml          file2.eml         file2.eml        (not displayed)
file3.pdf          (not displayed)   (not displayed)  (not displayed)
(not displayed)    file4.vcf         file4.vcf        (not displayed)
file5.vcf          (not displayed)   file5.vcf        (not displayed)

Several simultaneous problems are occuring.

1) When "Display Attachments Inline" is checked

   Both file4.vcf and file5.vcf are shown in the body at the end.
   The originating e-mail should show its vcf directly after
   its text and the inline e-mail after it.  It is confusing
   to the viewer as to which vcf file is from which e-mail, the
   original or the attached.

2) When ""Display Attachments Inline" is unchecked
  
   File3.pdf does not display in either the body of the e-mail or
   as an attached file.

   Only one vcf file is displayed in the "Attachments:" area and
   none in the body text.  A vcf file attached to the originating
   e-mail always shows in the body of the orginating e-mail and
   is not logically an attachment despite its status. 
   Which vcf is being displayed in the "Attachments:" zone, the one
   from the original e-mail or the one from the attached e-mail?
   If the attached file2.eml has a vcf file, it should not display
   except when the attachment is open.
	

Reproducible: Always

Steps to Reproduce:
Have not reproduced.

Actual Results:  
See Details

Expected Results:  
See Details

As far as attached multiple vcf files and "Display Attachments Inline" are concerned, when to display in the body is a problem of visual vs logical context.
You make the rules and we will follow as long as there is consistancy.
This is a major bug because it is possible not to see or acknowledge a file attachement with "Display Attachments Inline" unchecked.

Comment 1

12 years ago
have you tried a trunk build? Several problems in this area have been fixed.

Comment 2

12 years ago
It's true, and expected, that the vCards don't show in the attachment panel when they're displayed inline.

I was a little surprised to see that the attached message's PDF attachment doesn't show up in the panel, while the forward's own PDF attachment does.  
This is surprising because bug 35587 is about a better display for the nested 
attachment structure, and I'd thought that all attachments from all levels of nested messages were display at the top level.

However, in the results matrix from comment 0, I cannot reproduce one part of it: when Display Attachments Inline is checked, the report claims that both vCards are shown in the body *and* one is shown in the attachment panel.  I do not see any vCards in the attachment panel, altho both are in the body.
Summary: Display attechments inline causes incorrect number of attachments to display → Display attachments inline causes incorrect number of attachments to display
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)

> However, in the results matrix from comment 0, I cannot reproduce one part of
> it: when Display Attachments Inline is checked, the report claims that both
> vCards are shown in the body *and* one is shown in the attachment panel.  I do
> not see any vCards in the attachment panel, altho both are in the body.
> 

I am truly sorry, I went back to look at the e-mail in question and you are 
correct.  File5.vcf DOES NOT show in "Attachments:" zone when "Display Attachments Inline" is checked.
(Reporter)

Comment 4

12 years ago
(In reply to comment #1)
> have you tried a trunk build? Several problems in this area have been fixed.
> 

I don't quite understand what a trunk build is, but if you have a URL handy that would be great.
(Reporter)

Comment 5

12 years ago
(In reply to comment #0)
Corrected Table
> _________________Display Attachment Inline__________________________
> __e-mail zone: "Attachments:"______  __e-mail zone: Body text_______
> >>Checked<<        >>Unchecked<<     >>Checked<<      >>Unchecked<<
> (not displayed)    (not displayed)   e-mail text      e-mail text 
> file1.pdf          file1.pdf         (not displayed)  (not displayed)
> file2.eml          file2.eml         file2.eml        (not displayed)
> file3.pdf          (not displayed)   (not displayed)  (not displayed)
> (not displayed)    file4.vcf         file4.vcf        (not displayed)
> (not displayed)    (not displayed)   file5.vcf        (not displayed)

Comment 6

12 years ago
(In reply to comment #3)
> I went back to look at the e-mail in question and you are correct.
> File5.vcf DOES NOT show in "Attachments:" zone when "Display
> Attachments Inline" is checked.

OK.  So there are two symptoms: VCF attachments are not shown when the vCard is displayed inline -- this is as designed, so changing this would be an RFE, and I'm not sure how desirable that would be anyway.

And, attachments from nested messages do not show in the attachment pane if the nested messages are not shown inline.  I don't know whether this is as designed or just a side-effect, but I think bug 35587 would provide the best solution to this. 

Trunk builds can be found at
 http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/
Drill down to 'latest-trunk' or pick the -trunk folder for the desired date.
(Reporter)

Comment 7

12 years ago
Hold up a minute.

This may be partly a Microsoft problem.

I have opened a copy of the e-mail in question with Outlook Express 6 (6.00.2800.123) on WinPro2000
and it DOES NOT display the 2nd pdf file in the attachment scroll area.

It also DOES NOT display in the attachment scroll area of Outlook Express 6 (6.00.2900.218) on a Win XP Service Pack 2

Would someone confirm please.

Comment 8

11 years ago
(In reply to comment #7)
> This may be partly a Microsoft problem.

No.  This is an issue of how to display attachments of nested messages.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 35587
No longer blocks: 269826
You need to log in before you can comment on or make changes to this bug.