Closed Bug 328935 Opened 19 years ago Closed 19 years ago

Thunderbird threaded view misses messages

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gopalv82, Assigned: Bienvenu)

References

Details

(Keywords: fixed1.8.1)

Attachments

(4 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060202 CentOS/1.0.7-1.4.3.centos4 Firefox/1.0.7
Build Identifier: Mozilla Thunderbird 1.0.7-1.4.1.centos4 (X11/20051007)

Thunderbird threaded view sort of swallows up a couple of mails in a thread. The mails fail to reappear even when switching back to unthreaded view (which is mainly because it only flattens the tree view from the looks of it).

Reproducible: Always

Steps to Reproduce:
1. Use the attached mbox as a local folder
2. Turn on threaded mode for the folder
3. See bug 

Actual Results:  
Two mails disappear off the threaded view and the thread is marked unread eventhough no unread messages are seen. To get out, switch to grouped view and switch back to unthreaded.


Was having this problem on an IMAP folder, but it is reproducible even after pulling the corresponding headers out and faking an mbox file.
Attached file gzipped fake mbox with the headers (obsolete) —
Duplicate of/related to bug 285880?
(In reply to comment #4)
> Duplicate of/related to bug 285880?
> 

Possibly, but noted several other bits of info.

The bug disappears if the "R[eE]:" in the subjects are removed.

The .msf file dump shows some interesting info about the mails in the mbox

 threadParent = ffffffff
 sender = somebody-1 <nobody@yahoo-inc.com>

 threadParent = ffffffff
 sender = somebody-4 <nobody@yahoo-inc.com>

 threadParent = 6d7
 sender = somebody-3 <somebody@yahoo-inc.com>

 threadParent = 0
 sender = somebody-2 <nobody@yahoo-inc.com>


Here the somebody-4 and somebody-3 are the ones which are displayed in threaded view. 

The relationship basically shows up as 

somebody-3 -> somebody-4 -> ...(missing mail) ... -> somebody-1 -> somebody-2

As in 
(somebody-3)->message-id = 00ba01c62b6c\$db0fdcb0\$1e3891d8
(somebody-4)->references has 3
(somebody-1)->references has 3 & 4 & unknown
(somebody-2)->references has 3 & 4 & 1 & unknown

It is obvious that the threading has got inverted as well - not just missing two mails.

PS: uploading the mbox with 1,2,3,4 numbering
Attachment #213548 - Attachment is obsolete: true
Attachment #213590 - Attachment mime type: application/x-tar → application/x-gzip
Attached patch proposed fixSplinter Review
handle missing messages when checking if a message is the parent of an other message.
Assignee: mscott → bienvenu
Status: UNCONFIRMED → ASSIGNED
Attachment #213669 - Flags: superreview?(mscott)
thx very much for the test case!
Attachment #213669 - Flags: superreview?(mscott) → superreview+
unfortunately, you'll need to remove your .msf file to see the fix working.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: