Download imap messages for offline use immediately

RESOLVED DUPLICATE of bug 436615

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 436615
12 years ago
7 years ago

People

(Reporter: Bart Samwel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

It would be useful to download messages for offline use immediately, when the messages are first noticed. I have an IMAP folder which I have selected for offline use, but I have to explicitly download everything before I go offline. It would be much more useful if the downloading was done right away, so that if I had to quickly unplug, I'd have (most of) the messages with me and I'd simply have to go offline (with no downloading) if I'd want to start reading the messages on the road.

Reproducible: Always

Comment 1

12 years ago
If you're talking about the Inbox, that can be done now - tools - account settings, offline and disk space | make the messages in my inbox available for offline use. That'll make us download message bodies when we see new headers.

If you want the same behaviour to apply to all folders for a server, there's a setting you can set with tools | options | advanced | config editor, mail.server.serverXX.autosync_offline_stores - set this to true for your imap server (probably server01 if you only have one server configured) and we will automatically sync the message bodies of new headers for every folder you open.
(Reporter)

Comment 2

12 years ago
Hmmm, the inbox is not really my problem, it's always empty -- I sort everything automatically. The option was even already on. :-)

About the IMAP solution: it works perfectly, thanks! I did have some trouble finding out that when the setting wasn't there, I could use the context menu to add a new item. I'll file a separate "usability" wishlist item for that, if there isn't one already.

It would probably be nice to have this in the normal config as well. Suggestion: Tools -> Account Settings -> Offline & Disk Space -> "Make all messages available when I am working offline.", just below the already existing option for the inbox. How does that sound?

Comment 3

12 years ago
Thanks for the manual config settings workaround.  I agree that this useful feature should be published in the UI.

Offline & Disk Space...
Make message contents available offline
[X] Inbox
[X] All checked IMAP folders

This lets the user toggle the autosync_offline_states setting, to include Inbox, and/or optionally all of the user's checked IMAP folders as well.  This UI arrangement is also OK for POP: the "All checked IMAP folders" checkbox would simply be grayed out and forced to be cleared, if this account supported only POP.

As for automatically picking up new bodies whenever we check for new message headers:

Ideally, it would be nice to not only check for new message headers every few minutes, but automatically DOWNLOAD the message BODIES also.  This would be great for flaky IMAP servers that are not always accessible 24/7.  Then, I could have Thunderbird automatically keep my messages up to date as best as it can, even when left unattended.  (I hate having to manually initate the download of offline folders!)

How often does the Inbox offline download/synchronization take place?  Is it related to how often new message headers are checked for?  If so, might want to add new checkboxes to the "Server Settings", to let the user choose to also download the bodies, in addition to the headers, when timed checks for new headers occur:

Server Settings....
Automatically check for new messages
[X] At startup
[X] Every _10_ minutes
    [X] Automatically download new message contents for offline use
        [X] Smallest messages first

This rearrangement of checkboxes, making them hierarchial, would clear up the meaning somewhat for the end user.  Child checkboxes get grayed-out when their parent checkbox is cleared.  I also couldn't resist throwing in an additional checkbox for bug 328418 :)
QA Contact: front-end

Comment 4

10 years ago
As far as I know, if your IMAP server supports the IDLE command, then the Inbox offline download/synchronization takes place pretty much immediately for the HEADERS... but as stated above, the BODIES of the messages are not downloaded until I either -manually- click on a message or -manually- click to Download/Sync the messages for Offline mode.

A Sync On Arrival extension takes care of the issue, but has only been released for Thunderbird 1.5 and lower.  I'm anxious to try out this mail.server.serverXX.autosync_offline_stores option and see how it works.

Really, it should work based on the GUI stating something like "download these IMAP folders automatically for OFFLINE use".  Not getting the bodies of a message is not exactly ready at all for OFFLINE use.  I mean, who wants to just see the headers of the messages they can't read?  That just makes them more furious that they can't read them.

Comment 5

10 years ago
I didn't see the .....autosync_offline_stores option in my configuration editor.  I had to go to my profile/prefs.js file and manually add it.

Updated

10 years ago
Duplicate of this bug: 273639

Updated

10 years ago
Duplicate of this bug: 401940

Updated

10 years ago
Assignee: mscott → nobody
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → General
Ever confirmed: true
OS: Windows XP → All
QA Contact: front-end → general
Hardware: PC → All

Updated

10 years ago
Summary: Download messages for offline use immediately → Download imap messages for offline use immediately

Updated

10 years ago
Duplicate of this bug: 407433

Comment 9

10 years ago
Willie => You should be able to add new variables from the config editor.

Is this bug only about UI? I like the autosync feature (I discovered it in the duplicate Bug 401940 I filled) but it only works on opened folders.

There should be a way to have Thunderbird walk all offline folders when it checks for new messages, along with proper UI.

BTW I'm using Thunderbird/IMAP on an exchange server as Outlook is way too slow with the number of emails I keep. So far I'm extremely pleased of it but that feature is missing. Along with lightning this can really make Thunderbird an Outlook competitor... Any chances it blocks 3.0? (BTW I also tried Evolution on Linux and it was a real mess. Thunderbird/IMAP _does_ work!)

Comment 10

10 years ago
Thomas => Thanks for that tip.  I didn't realize that I could add new variables there.

Everyone =>
I can confirm the following (at least in Thunderbird 2.0): Setting mail.server.<serverX>.autosync_offline_stores along with selecting the folder for offline use will download the message headers and bodies *when the folder is selected.*  It will not download the new bodies before you select the folder.  I imagine this is largely due to the way that IMAP works.

[If the IMAP server supports the IDLE command, then Thunderbird will leave the connection open and the server can alert Thunderbird if a new message comes in.  However, IMAP is very much folder based, which means that the server will not alert if there are new messages in some other folder for which you do not have an open connection.]

So, ideally, what we can work for here is some sort of automatic, polled way to do File > Offline > Download/Sync Now.  That command goes through each of your selected offline folders and checks for new messages and downloads them.  It would just be nice to have a timer set to do that every N minutes or so.  Thunderbird has the one timer which says "check for new messages every M minutes," and I'm not quite sure how difficult it might be to set up another timer which calls the Download/Sync Now command.

Perhaps this could be more quickly done as an extension first before being implemented directly into Thunderbird itself.  Any thoughts from anyone?

Comment 11

10 years ago
mail.server.DEFAULT.autosync_offline_stores = TRUE
Also does work just fine, if you are about to create many accounts in fresh install of TB.

Updated

10 years ago
Flags: wanted-thunderbird3?
I agree with Thomas - there should be a background thread whose job it is to poll folders for new messages and download them when available.  There would probably need to be some enlightened balance between hammering the IMAP server and updating often enough to be useful.

I'm constantly on and offline, and trying to move to Thunderbird full-time from AppleMail (which has this behavior and makes working offline easy).

Comment 13

10 years ago
Very related/dupe of bug 385502. 

Comment 14

10 years ago
I'd disagree that it's a duplicate of bug 385502.  They are related in that they both deal with offline IMAP.  I'm afraid just turning on the setting by default still won't fix the base issue that all the selected offline folders need to be polled and downloaded if new messages are found.

I don't mind having that option turned on by default though.

Comment 15

10 years ago
Re. comment #12 - please at least make the background thread optional, if there is one.  For those of us still using dialup, any kind of automatic polling makes all other use of the Net (web access, news, RSS, downloads) unbearably slow.

Updated

9 years ago
Duplicate of this bug: 410745

Comment 17

9 years ago
(In reply to comment #10)
> I can confirm the following (at least in Thunderbird 2.0): Setting
> mail.server.<serverX>.autosync_offline_stores along with selecting the folder
> for offline use will download the message headers and bodies *when the folder
> is selected.*  It will not download the new bodies before you select the
> folder.  I imagine this is largely due to the way that IMAP works.
...
>  However, IMAP is very much folder based, which means that the server will not
> alert if there are new messages in some other folder for which you do not have
> an open connection.]
> 
> So, ideally, what we can work for here is some sort of automatic, polled way to
> do File > Offline > Download/Sync Now.  That command goes through each of your
> selected offline folders and checks for new messages and downloads them.  It
> would just be nice to have a timer set to do that every N minutes or so. 
> Thunderbird has the one timer which says "check for new messages every M
> minutes," and I'm not quite sure how difficult it might be to set up another
> timer which calls the Download/Sync Now command.

You can achieve this today by setting :
mail.imap.use_status_for_biff = false

When this preference is 'false', Thunderbird will SELECT each folder when checking for new messages, and download the new headers.  With autosync, it will also download the message bodies.

Comment 18

9 years ago
So, to recap and get it all in one place:
To have a complete copy of your IMAP folders locally, set the following preferences:
mail.check_all_imap_folders_for_new = true
mail.imap.use_status_for_biff = false
mail.server.serverX.autosync_offline_stores = true

The last line is a configuration line that does not exist by default, so you'll have to add it.  Then click on Get Mail and watch it go!  As far as I can tell, it seems to ignore your offline folder options and just gets all the messages in every subscribed folder.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 436615
Flags: wanted-thunderbird3?
You need to log in before you can comment on or make changes to this bug.