Reimplement Bookmarks/History sidebar in Places

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
13 years ago
9 years ago

People

(Reporter: eugenem, Unassigned)

Tracking

2.0 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060303 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060303 Firefox/1.6a1

Starting with nightly build 20060302 (currently using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060303 Firefox/1.6a1 ID:2006030304), pressing Ctrl-b or Ctrl-h also don't bring up the bookmarks or History sidebars as expected.  Ctrl-h instead opens up the Manage Bookmarks tab.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox nightly build 20060302 or later
2. Press ctrl-b or ctrl-h to bring up bookmarks or history sidebar
3.

Actual Results:  
Nothing happens when pressing ctrl-b.  Bookmarks sidebar never appears.
Pressing ctrl-h brings up the Manage Bookmarks tab instead of the History sidebar

Expected Results:  
Ctrl-b should bring up Bookmarks sidebar
Ctrl-h should bring up History sidebar
(Reporter)

Comment 1

13 years ago
Probably related to bug 329233, but I thought it might be better to submit them separately
Invalid as per bug 329068.
Sidebars have been removed atm in Places-enabled builds, but discussion as to what kind of form (if any) they should take are ongoing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Component: General → Places
Resolution: --- → INVALID
*** Bug 329233 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
*** Bug 330696 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
This is certainly a valid request.
Status: RESOLVED → UNCONFIRMED
OS: Windows 2000 → All
Hardware: PC → All
Resolution: INVALID → ---
Summary: Ctrl-b, Ctrl-h don't open up bookmarks or history sidebar → Reimplement Bookmarks/History sidebar in Places
Version: unspecified → 2.0 Branch

Comment 6

13 years ago
As a workaround, try Pike's Classic Sidebars extension:
http://forums.mozillazine.org/viewtopic.php?t=391625
Blocks: 317881
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: general → places

Comment 7

13 years ago
It looks like "Places" does have the bookmarks functionality. Now all that is needed is to make the places window a dockable widget, and also for Ctrl-B to toggle its visibility, like it does in Firefox 1.5 (or like F9 does in Mozilla Classic)... Instead of toggling the bookmarks sidebar, it could toggle the places sidebar, but select the "bookmarks menu" of places. 

The tree view for choosing which "places" you want to select is a waste of valuable horizontal space. The Mozilla Classic approach allowed you to select the different "places" (bookmarks, history, whatever) as tabs in a tabbed widget.

Updated

13 years ago
Blocks: 330923
We won't be implementing bookmarks sidebars by default, they're not part of the new UE spec: http://wiki.mozilla.org/Places:User_Interface ... however, we do have something planned that will mimic much of the sidebar's ease of access/utility, a new places popup. This will come in fx2a2. Read the UE spec for more info, or track 329180/329179. 
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WONTFIX

Comment 9

13 years ago
I hate popups. I wish it could also be dockable on the side.





Comment 10

13 years ago
Ben, the whole point of this bug was to have a UI that wasn't a popup for main bookmark usage and management. Many of us use the sidebar because it's not a change of window. The new Places UI spec makes us change window focus, and have parts of what we're doing covered up by the places window. It's terribly less usable than the old spec. 

I thought the point was to increase usability.

Comment 11

13 years ago
*** Bug 348634 has been marked as a duplicate of this bug. ***

Comment 12

13 years ago
why it cannot be how IE7 handles it.. i explain it here http://forums.mozillazine.org/viewtopic.php?t=454011&start=30

bacicly they to like that.
its floatin bar but can be side bar with a button http://img244.imageshack.us/my.php?image=ie7places1jpbpe2.jpg next to history there is a button that says "pin to window" or like somehting

than here we go. http://img201.imageshack.us/my.php?image=ie7places2jpblp5.jpg side bar..
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.