Want a Bookmarks Sidebar with Places

RESOLVED DUPLICATE of bug 329236

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 329236
13 years ago
9 years ago

People

(Reporter: Urban A. Haas, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060314 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060314 Firefox/1.6a1

The current Places design takes the bookmarks sidebar away.

The sidebar needs to support Bookmarks, or better yet, Places.

Reproducible: Always

Steps to Reproduce:
1. Download a current nightly.
2. Press CTRL-B

Actual Results:  
A places pop-up window launched.

Expected Results:  
CTRL-B should still open bookmarks or places in the sidebar.

I feel this new functionality is a serious usability regression.
(Reporter)

Updated

13 years ago
Keywords: regression
Version: unspecified → 2.0 Branch

Comment 1

13 years ago
Dup of bug 329964?

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 329964 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
I knew I should have left a comment when I realized this wasn't a dupe of bug 329964 :(

That bug wants back the feature of having a checkbox in the properties of a bookmark, to have the bookmarked URL opened in the sidebar. This bug wants back the feature of opening a list of all bookmarked URLs in the sidebar, to then open them in the main window.
Status: RESOLVED → UNCONFIRMED
Keywords: regression
Resolution: DUPLICATE → ---
Summary: Bookmarks still need to be supported in the sidebar → Want a Bookmarks Sidebar with Places

Comment 4

13 years ago
I changed the summary of bug 329964 in the hope of preventing that from happening, but I guess I wasn't successful :(

This is closer to being a dup of bug 329236 or bug 329068.

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 329236 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

13 years ago
Everyone needs to go to bug <a href=https://bugzilla.mozilla.org/show_bug.cgi?id=329236>329236</a> and vote for that bug. Right now, the whole sidebar feature for bookmarks and history is toast in FF2.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.