Migrate CVS servers to SVN (Subversion) software

RESOLVED INVALID

Status

mozilla.org Graveyard
Server Operations: Projects
--
enhancement
RESOLVED INVALID
12 years ago
3 years ago

People

(Reporter: Andrés G. Aragoneses, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
According to many sources, SVN is a great replacement for CVS because it is meant to have the same features and to fix the most common problems.

This topic has been asked on newsgroups and it seems that the only reason for this not being taken into account yet is the lack of support by the mozilla webtools.

So this can be a META bug where we can link to other bugs about this supposedly desired future enhancement...
--> Server Operations Projects
Assignee: mitchell → nobody
Component: Miscellaneous → Server Operations Projects
QA Contact: miscellaneous → justin

Comment 2

12 years ago
I'm killing this bug. it's not proper process for a random person to demand that mozilla move to a random product (which according to rumors is almost certainly not the one we're going to use).

further, you included a dependency on bug 125283 which has nothing to do with svn, it's just asking for sub-versions!

the tinderbox2 fix (bug 328407) really isn't related to svn deployment in any useful manner, it most certainly wouldn't prevent us from deploying svn (which we almost certainly won't do anyway), especially given that mozilla.org never got around to deploying tb2 (it uses tb1, and it's an open question as to whether we'd move to tb2 or tb3).

the only bug you picked that has any relevance is bug 267090, which doesn't need to be tracked by a misfiled bug. note that there is actually at least one other bug that would need to be filed based on the web tools that we actually deploy that would care about switching to svn, and you neither filed, found, nor mentioned it.

Note: killing=invalid, because of process issues. i'm not and can't say we won't move to svn. I expect that mozilla.org will move to something other than svn. the few features svn offers are already dealt with by mozilla.org process which makes it fairly useless as an upgrade target. that and the fact that svn imports of mozilla.org's cvs failed miserably last i checked - that's not to say svn is particularly special, just about every cvs=>whatever migrator i've heard of that tried to import cvs.mozilla.org failed spectacularly.

if someone is going to try to implement this, it has to be someone who understands the infrastructure involved, the reasons for making the change, the benefits, how to get a consensus (or diktat) among other things.

further note that this is actually a duplicate of a previously wontfixed bug (bug 240450).

lastly. voting for your own bug is generally fairly useless.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
No longer depends on: 125283, 267090, 328407
Resolution: --- → INVALID
Keywords: meta
(Reporter)

Comment 3

12 years ago
Thanks for the info.

If I had read this feedback as a reply to the thread "SVN (Subversion) migration anytime?" posted some weeks ago on mozilla.dev.general, I wouldn't open this bug. I don't pretend to lead mozilla.org plans; I just thought, based on the comments of that thread, that this was a desired thing but freezed because of incompatibilities. I didn't find the duplicate neither. Sorry.

P.S.: Voting for own bugs is nice for tracking a "wishlist".
*** Bug 338619 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

3 years ago
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.