Closed Bug 330090 Opened 15 years ago Closed 15 years ago

Scrollbars on divs with overflow: scroll "show through" absolutely positioned DIVs.

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 187435

People

(Reporter: peter, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

If I create a DIV with CSS style of overflow: scroll and then an absolutely positioned DIV that overlaps the scroll bars, the absolutely positioned DIV appears "above" (in a z-index sense) the other DIV but the scroll bars show through, obscuring part of the absolutely positioned DIV. This is particularly irksome when using DIVs that are hidden and then revealed because the scrollbars muck everything up.

Reproducible: Always

Steps to Reproduce:
Load this HTML:

<html>
  <head>
    <title>Scroll test</title>
    <style type='text/css'>
<!-- 
#foo
{
overflow: scroll;
width: 40%;
height: 30%;
background: #ffeeee;
border: solid thin;
}
#bar
{
position: absolute;
left: 10%;
top: 10%;
right: 50%;
bottom: 60%;
background: #eeffee;
border: solid thin;
}

 -->
    </style>
  </head>
  <body>
    <div id='foo'>Note how the scrollbars show through into the other div. Note how the scrollbars show through into the other div. Note how the scrollbars show through into the other div. Note how the scrollbars show through into the other div. Note how the scrollbars show through into the other div. Note how the scrollbars show through into the other div. Note how the scrollbars show through into the other div. Note how the scrollbars show through into the other div. Note how the scrollbars show through into the other div. Note how the scrollbars show through into the other div.</div>
    <div id='bar'>Note how the scrollbars show through into this div, obscuring the contents. Note how the scrollbars show through into this div, obscuring the contents. Note how the scrollbars show through into this div, obscuring the contents. Note how the scrollbars show through into this div, obscuring the contents. </div>

  </body>
</html>



Actual Results:  
The scroll bars from the red DIV (foo) show through.

Expected Results:  
I expect the green DIV (bar) to completely obscure the red DIV (foo)

This happens in a 1.6a1 I downloaded last week (the one I just downloaded (2006-03-10) won't start.
Duplicate of bug 316508 -> Core bug 187435?
(In reply to comment #2)
> Duplicate of bug 316508 -> Core bug 187435?
> 

Yes.

*** This bug has been marked as a duplicate of 187435 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.