Closed Bug 331075 Opened 14 years ago Closed 14 years ago

Tools > Web Search goes to Google when user has removed the search bar from the toolbar (readd the search dialog)

Categories

(Firefox :: Search, defect)

x86
Windows XP
defect
Not set

Tracking

()

VERIFIED WONTFIX

People

(Reporter: ria.klaassen, Unassigned)

References

Details

When you don't have the search box on your toolbar Firefox offers you a way to use you search engines without the search box: the web search window. Much appreciated.
But now it is broken. Or I don't yet know where to find the replacement.
Trunk is not my default browser anymore, so I discovered it only today.
Regression between 1.9a1_2006031620 and 1.9a1_2006031704.
Keywords: regression
Ben suggested removing it, Gavin and I agreed to remove it.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
Why? It can only cost users. No one will say: "I'm looking for a browser without web search! Ha! That's the new Firefox. Splendid! Now I'm going to use it!
Didn't use it with web search, but now, without, this is what I waited for!":)
The decision not to fix this regression conflicts with bug 317107 comment #0:
> Thoughts in my mind are
> 1. Do not lose any features working in the current version of Firefox.

Why are key features broken so badly in future versions? Or is this a wild experiment?
I'd appreciate any answer. 
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Removing the search bar from the toolbar is hardly a key feature. There are quite a few other ways to do a web search:
- Use the Google page you're taken to.
- Use the Firefox start page: http://www.google.com/firefox
- Select (highlight) any words in a web page. Right-click, and choose "Search Web for [your selected words]" from the context menu.
- Add the search bar back to the toolbar.

See bug 317107 comment 32:
"So, let's not add this search dialog back. It adds a whole lot of additional
complexity most users will never encounter. In addition, the dialog is buggy.
To cover the condition where the user invokes the search command and there is
no search field in the UI, there are two choices that I can think of off the
top of my head:

- disable the command
- find the URL of the default search engine and go to it in the current tab."

Also see bug 317107 comment 34:
"> So, let's not add this search dialog back.
I added a "searchForm" property on nsISearchEngine and made it load the
searchForm for the current engine."
Status: REOPENED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → WONTFIX
Summary: Tools > Web Search goes to Google → Tools > Web Search goes to Google when user has removed the search bar from the toolbar (readd the search dialog)
(In reply to comment #4)
> - Use the Google page you're taken to.
> - Use the Firefox start page: http://www.google.com/firefox
> - Select (highlight) any words in a web page. Right-click, and choose "Search
> Web for [your selected words]" from the context menu.

I don't see the feature to change search engines on the Google page. I don't see how changing a page could change your search engine.
You can't change your search engine on Google's website. You can do that with the search bar if you put it back on your toolbar.

Tools > Web Search focusses the search bar if it's present on your toolbar, and takes you to the homepage of the default search engine (Google in most locales), if it isn't:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/browser/base/content/browser.js&rev=1.479.2.96&mark=2774-2776,2800-2803#2772
(In reply to comment #6)
> You can't change your search engine on Google's website. You can do that with
> the search bar if you put it back on your toolbar.
> 
> Tools > Web Search focusses the search bar if it's present on your toolbar, and
> takes you to the homepage of the default search engine (Google in most
> locales), if it isn't:
> http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/browser/base/content/browser.js&rev=1.479.2.96&mark=2774-2776,2800-2803#2772
> 

Yes, that's why I filed this bug.
Status: RESOLVED → VERIFIED
Keywords: regression
*** Bug 355900 has been marked as a duplicate of this bug. ***
As the reporter of bug 355900 it is sad to see the reasoning behind the intentional removal of an useful working feature and the replacement for a half-baked page (comment #32 of bug 317107).

The searchbox was really nice and great feature for people that don't use the navigation toolbar as a whole, not only people who removed specifically the search bar. I don't like the navigation toolbar taking precious space of my small screen and the previous version way to handle Ctrl+K was a very good solution, you only had to open the dialog when in need of consulting any of your multiple search plugins.

About comment #4, two reasons why the firefox start page with only Google search is worst than the handy searchbox dialog:

1- you have to actually load an entire html page before making the search
2- it has only one search engine option and ignores all my installed search plugins.
Alternatives are:

- Install Custom Buttons extension: http://forums.mozillazine.org/viewtopic.php?t=428688
then click on the link "Search" on this page:     http://custombuttons.phpbbnow.com/viewtopic.php?t=39&sid=efd57b3f5ea62302747a907d1de4edcd

- Optimoz Tweaks extension https://addons.mozilla.org/firefox/368/ has an option to expand a small search bar when you click on it 

- Use "smart keywords" instead (what I do, but it needs a lot of work initially)

None is "as good", but the first option is ingenious and comes very near.
I know this bug is closed WONTFIX, but trying FF-2 today that's one of the features I miss more. As said in comment #9 some people remove the search bar because is taking up space on screen, but still find it useful.

Ctrl+K was a handy shortcut to toggle the search bar visibility, in some sense.

Could we have either the dialog box back or some way to show the search bar with Ctrl+K?
*** Bug 358537 has been marked as a duplicate of this bug. ***
If anybody is interested in my workaround for this WONTFIX, I've found an extension called "Search Sidebar" (at https://addons.mozilla.org/firefox/1271/) which nearly resembles the dialog box functions.

The keyboard shortcut for the sidebar bar is ctrl+shift+k which comes pretty close to the old ctrl+k.

So as I have to live with this bug the above stated extension relieves pretty much of the pain accepting the facts ;)
*** Bug 361952 has been marked as a duplicate of this bug. ***
The removal of the search hotkey capability when the navigation bar is gone really hurts accessibility.  It forces users to have the navigation bar showing at all times.

* Low vision users want to remove the location bar to give more space to large text.
* Blind users (if any are willing to forego IE+Jaws to experiment with firefox) may find the sudden change in behavior a little jarring.  Traditionally ctrl-l and ctrl-k felt exactly the same regardless of other circumstances.  Now a blind person needs to know whether the location-bar is showing or not to get normal functionality.

Thanks for the link to the Search Sidebar.  The best thing about firefox is that it is adaptable enough that you can get the behavior you want, _even if the developers don't want it anymore_.
Actually Autohide 1.1.3 has every single desired behavior.  The location bar or search bar just appear when you call them and disappear immediately afterwards.  This is the behavior firefox always should have had in fullscreen.  It also

* makes firefox remember fullscreen status if you want.
* gives a -fullscreen command line option.

That fixes this bug _and_ the one about firefox not remembering fullscreen on exit (if you call that a bug)!

http://www.krickelkrackel.de/autohide/
Duplicate of this bug: 635136
Duplicate of this bug: 597854
You need to log in before you can comment on or make changes to this bug.