Closed Bug 331136 Opened 19 years ago Closed 19 years ago

MPL compliance: Initial Developers credits

Categories

(mozilla.org :: Governance, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: BenB, Assigned: gerv)

References

Details

(Keywords: fixed1.8.1)

Attachments

(1 file)

See bug 277119.

MPL:
"You must include a prominent statement that the Modification is derived, directly or indirectly, from Original Code provided by the Initial Developer and including the name of the Initial Developer ...
(b) in any notice in an Executable version or related documentation in which You describe the origin or ownership of the Covered Code.
"

I think that Help|About counts as such "description of origin/ownership". Note "any". In any case, mozilla.org is in violation of that, because there's *no* place in the Executable where these are listed.

I think that this bug will be fixed automatically by bug 277119 (fair credits for Mozilla contributors in Firefox/Thunderbird), but Gerv and Frank think they are separate issues, so filing a different bug about it, but marking a dependency.
*** Bug 331597 has been marked as a duplicate of this bug. ***
Attached patch Patch v.1Splinter Review
This should do the trick. This patch is suitable for the trunk and the 1.8 branch, both of which have the new licence file.

Gerv
Assignee: zak → gerv
Status: NEW → ASSIGNED
Fixed on trunk and 1.8 branch.

Checking in toolkit/content/license.html;
/cvsroot/mozilla/toolkit/content/license.html,v  <--  license.html
new revision: 1.3; previous revision: 1.2
done
Checking in xpfe/global/resources/content/license.html;
/cvsroot/mozilla/xpfe/global/resources/content/license.html,v  <--  license.htmlnew revision: 1.3; previous revision: 1.2
done


Checking in toolkit/content/license.html;
/cvsroot/mozilla/toolkit/content/license.html,v  <--  license.html
new revision: 1.1.2.4; previous revision: 1.1.2.3
done
Checking in xpfe/global/resources/content/license.html;
/cvsroot/mozilla/xpfe/global/resources/content/license.html,v  <--  license.htmlnew revision: 1.1.2.4; previous revision: 1.1.2.3
done

Gerv
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Shouldn't this bug (and some others) have the fixed-1.8.1 keyword?
Good call.

Gerv
Keywords: fixed1.8.1
We don't consider localizers to be Initial Developers, right?
This may be different for search engine plugins, though.
No, localisers are not Initial Developers, as they only modify files.

Gerv
Is there also a plan for keeping this list up-to-date?

MPL compliance seems not to be included in the current http://wiki.mozilla.org/User:Gerv/UnifiedLicensingPlan
The Unified Licensing Plan is not related to this problem.

The plan for keeping the list up to date is that I'll rerun the script which generates it every so often, and paste the result into the page.

Gerv
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: