Find bar "breaks" if you switch tabs while it's open

RESOLVED WORKSFORME

Status

()

Toolkit
Find Toolbar
--
minor
RESOLVED WORKSFORME
12 years ago
2 years ago

People

(Reporter: dolphinling, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060320 Firefox/1.6a1

1: Hit / to open the find bar, and search
2: Switch tabs before it closes
3: Switch back to the original tab, and hit / again

The find bar does not open.

If you click in the page, it works again.

Only affects /, not Ctrl+F.
I see this also in Windows. Also in 1.5.0.1, but not in 1.0.8.
OS: Linux → All
(In reply to comment #1)
> but not in 1.0.8.
>
I meant 1.0.7. 

Summary: Tab bar "breaks" if you switch tabs while it's open → Find bar "breaks" if you switch tabs while it's open
Hmm, focus is fun!  can be worked around, marking minor.

The findbar code probably should have an event listener for the tab select event we're adding, and close on tab switch if there's a timeout pending, before the tab switch happens.
Severity: normal → minor
Depends on: 322898
(Reporter)

Comment 4

12 years ago
Oops, thanks for the summary change, Phil... no idea how I messed that up. :)
Does this still happen on the trunk (since bug 288254 landed)?
(Reporter)

Comment 6

11 years ago
Yes, it still happens.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
Duplicate of this bug: 440434
This is not only happening on tab change but also when the browser content changes.

STR:
1. Open any page and search for a word that is not there
2. Go to a different page (by entering an adress in the adress bar/clicking a link/you name it) that contains the word you searched for

Result: find field has "not found" look.
Expected: it should have the normal "found" look and the first hit should be highlighted

This bug affects Instantbird as well: we are encountering it on the logs viewer which has a permanently visible findbar with changing log files. The same problems as mentioned above occur here.
Scratch comment 8, I'm referring to something completely different than initially being reported here. I'm sorry for the bugspam I caused.
See Also: → bug 953951
See Also: bug 953951
8 years later: I can't reproduce this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.