Running PPC profile on the Intel Mac UB causes issues

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
13 years ago
7 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({qawanted})

PowerPC
Mac OS X
qawanted
Bug Flags:
blocking1.8.0.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix?])

Attachments

(2 attachments)

Seen using the unofficial UB from Maya.

STR:

1. Zip up a Tbird PPC profile and place it in the user/Library/ directory on the Intel Mac.
2. Launch the Tbird application

Issues:

1.  I crashed the first time I tried to get mail. After I relaunched I would usually just hang and have to force quit.
2.  I see errors in blog messages when I try to view them.
(Reporter)

Comment 1

13 years ago
I forgot to add that creating a new profile seems to work as expected.  The only thing that looked strange was that newsgroup names were getting cut off.  I can file a separate bug for that issue.
We need to discuss this issue in the release meeting.  As of now, Current users of Thunderbird who migrate from ppc mac to intel mac will not be able to use Thunderbird 1.5.0.2 with their current profile/messages/etc.
Flags: blocking1.8.0.2?

Comment 3

13 years ago
Mark and/or Josh - is this something you can help debug?

Comment 4

13 years ago
what happens if you run under rosetta instead of the PPC version? Does that still work?
(In reply to comment #4)
> what happens if you run under rosetta instead of the PPC version? Does that
> still work?
> 

Testing that now.

thunderbird under rosetta works fine using my ppc-generated profile.  I was ale to read news, and access my stored messages without problems.

Comment 7

13 years ago
I can work on this, but I'm pretty sure I already tested a ppc profile on x86 and didn't find anything obviously out of place.  Marcia, can you give some more specific steps to reproduce from a relatively clean ppc profile?  Which blog messages, what errors?

Comment 8

13 years ago
a screen shot of the errors when viewing blog messages might help too.

Comment 9

13 years ago
Marcia- can you reply to Mark and Scott's comments?
(Reporter)

Comment 10

13 years ago
Created attachment 216437 [details]
Screenshot of newgroup posting

Screenshot of Thunderbird newsgroup message. Thunderbird hangs when I try to move through any of my accounts.  This test is using my pre Tbird 1.0 PPC profile that has been around forever.
(Reporter)

Comment 11

13 years ago
Mark:  In response to your question, let me reiterate my steps:

1.  Zipped up my age old Tbird PPC profile and moved it over to the Intel Mac.
2.  Launch the Tbird UB build (today I am using the TB nightly 2006-03-37-03 build which preed instructed me is the closest thing we have to an official Tbird UB)
3.  I am able to launch Tbird, but it immediately hangs (the hourglass spins) and I can't seem to get to any of my accounts. I am able to get the error shown in the attachment when I was able to mouse down to my newsgroups account.
4. The only way to exit Tbird is to force quit.

Other things to note:

RSS feeds are missing the RSS icon


(In reply to comment #7)
> I can work on this, but I'm pretty sure I already tested a ppc profile on x86
> and didn't find anything obviously out of place.  Marcia, can you give some
> more specific steps to reproduce from a relatively clean ppc profile?  Which
> blog messages, what errors?
> 

Comment 12

13 years ago
Marcia, can you point me to the URL of the build you're using?  I don't think the gonna-be-official-universal-Thunderbird build is working properly yet, I think maya's still the only universal build available.
(Reporter)

Comment 13

13 years ago
Mark: Here is the build I tested today - ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2006-03-27-03-mozilla1.8.0/, which preed pointed to me.  I also tested on the Maya build on Friday and got similar results.

(In reply to comment #12)
> Marcia, can you point me to the URL of the build you're using?  I don't think
> the gonna-be-official-universal-Thunderbird build is working properly yet, I
> think maya's still the only universal build available.
> 

Comment 14

13 years ago
OK, that's not universal.  Easy way to tell: do a Get Info on the app in the Finder.  It will say "Kind: Application (Universal)" if it's universal, otherwise, it'll list the architecture that it was built for.  Another easy way to tell is by dmg size: if it's no larger than a ppc-only dmg, it's not universal!

preed and I will now brainstorm.

Comment 15

13 years ago
If you were running the Thunderbird from the above URL and experienced these problems, then it would seem that this bug occurs under Rosetta - but davel said that Rosetta was OK.  Maybe there's something peculiar to your specific profile?
(Reporter)

Comment 16

13 years ago
Mark: My PPC profile runs fine on a non-Intel Mac. I can create another PPC profile on my Mac and bring it over to the Intel Mac to see what happens.

Also, FYI the "Get Info" for App deal does not work running 10.3.9 - it will show the Universal Binary build only running 10.4.x

(In reply to comment #15)
> If you were running the Thunderbird from the above URL and experienced these
> problems, then it would seem that this bug occurs under Rosetta - but davel
> said that Rosetta was OK.  Maybe there's something peculiar to your specific
> profile?
> 

(Reporter)

Comment 17

13 years ago
I have spent some additional time testing today and tested the following scenarios, since it seems my profile was not running under Rosetta either. For this testing I was using the latest Tbird 1.5.0.2 build in the candidates directory.

(1)  Running a newly created 10.4.5 PPC profile under Rosetta
(2)  Running a newly created 10.3.9 PPC profile under Rosetta
(3)  Running Marcia's old PPC profile created under 10.3.9 under Rosetta

Scenarios 1&2 work fine under Rosetta, but I am still unable to get #3 to run correctly.

When we get an official Tbird UB I would like to try these three different profiles again to see what happens.

Comment 18

13 years ago
That's very interesting.  Since you experience the bug even under Rosetta, and since you experienced it under the we-thought-it-was-universal-but-it-was-really-ppc-only build, it probably has nothing to do with universalness at all.  What happens when you try to use your old ppc profile on the x86 Mac while running a non-universal ppc-only build, like the official fireball build?

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8.0/

What happens when you drag your old ppc profile to a different (10.4.5-equipped?) ppc Mac and use one of those ppc-only builds?
(Reporter)

Comment 19

13 years ago
Here are my results when I run the Tbird UB build (version 1.5.0.2 20060328)with the same three profiles:

(1)  Running a newly created 10.4.5 PPC profile under Rosetta
(2)  Running a newly created 10.3.9 PPC profile under Rosetta
(3)  Running Marcia's old PPC profile created under 10.3.9 under Rosetta

Scenario 3 does not work on the UB either. Might be an issue with my profile. I am going to try to test a few of Mark's suggestions in Comment 18.

Scenario 2 works fine, but the two extensions I have installed, Flashgot and Foxy Tunes, don't work in the build. They show up in the Extension Manager but really don't seem to be installed (for example the Foxytunes UI is missing from the UI, and you can't access the Flashgot preferences). They show as active and not disabled. I will file a separate bug on this issue after I spend some time seeing if this happens with all extensions and whether it happens with a 10.4.5 profile as well.

Scenario 3 works fine.



Comment 20

13 years ago
I think we are ready to punt on UB for Mac in 1.5.0.2.  Can we minus this for 1.5.0.2 and plus it for 1.5.0.3?  We should get this fixed and landed on the trunk.  Then get some community testing with testers that can migrate profiles from PPC to Intel mac.

Comment 21

13 years ago
If Marcia's old profile doesn't work on an x86 Mac running a native build, AND it doesn't work on an x86 Mac running under Rosetta, then it's reasonably safe to say that her old profile just won't work on x86 Macs.  That's not really a reason to not release Tb 1.5.0.2 as universal.  A ppc-only build running on an x86 Mac under Rosetta will have just as much trouble with the old profile as a native build.

This should be verified, of course.  The tests in comment 18 are crucial.
Hi Mark,

I have an old profile that does not work on my x86 mac running Tb native, but *does* work when running Tb under Rosetta. (see comment 6)

Is there any debugging or logging I can turn on that will help you identify what is going on?  I'd rather not share my profile, as it contains personal mail from the past 5 years or so.

If not, then someone (me?  marcia?) will ahve to generate a profile that causes problems, probably by running Tb 1.0.x on a ppc mac, reading mail, news, etc., then running Tb 1.5 on the ppc mac and adding in feeds, more mail, more news, etc., then migrating to an x86 mac and running the 1.5.0.2 build.

But that could take a long time, and there are other tasks we need to complete for the rest of the releases, so I think the debugging/logging route is the better one to take.

I'm open to suggestions . . .

Comment 23

13 years ago
If you aren't seeing the weirdness under Rosetta, then I agree we've got a big problem.  Are the problems anything like Marcia's screenshot?  Marcia, when you see that, where in the window is it?  Does that appear for messages that you already viewed in the past when the profile was still on the ppc system?

If you're crashing, stack traces would be very helpful.

If you're hanging, launch Sampler (/Developer/Applications/Performance Tools, you'll need to install the Developer Tools for this) and attach it to the hung thunderbird-bin process.  Let it run for about ten seconds, and then save the result and attach it here.

Comment 24

13 years ago
I tried removing all of the mail summary files (which use mork) from Marcia's profile and sure enough, things came up just fine and started working. I'm worried that there could be byte ordering issues when we are opening up the summary files causing us to get corrupt information that's causing the db open call to fail, leaving the process in a state where the new mail check never finishes and the thread pane never loads any summary data. 

I wonder if we need to do patches similar to what was done for Bug 328982 for Firefox.

Comment 25

13 years ago
.msf files don't contain binary data, so a byte ordering problem is unlikely. Perhaps the summary files looked out of date for some reason and that caused some weird problems. I had suggested to Marcia that she try removing a couple of the .msf files and see if that allowed her to open a particular folder...
(Reporter)

Comment 26

13 years ago
I realized when looking back at these comments that I was not clear - I meant scenario 1 and 2 work fine. Scenario 3 still does not work running either under Rosetta or using the UB build. Scott was able to get it to run by deleting the mork files. 

(In reply to comment #19)
> Here are my results when I run the Tbird UB build (version 1.5.0.2
> 20060328)with the same three profiles:
> 
> (1)  Running a newly created 10.4.5 PPC profile under Rosetta
> (2)  Running a newly created 10.3.9 PPC profile under Rosetta
> (3)  Running Marcia's old PPC profile created under 10.3.9 under Rosetta
> 
> Scenario 3 does not work on the UB either. Might be an issue with my profile. I
> am going to try to test a few of Mark's suggestions in Comment 18.
> 
> Scenario 2 works fine, but the two extensions I have installed, Flashgot and
> Foxy Tunes, don't work in the build. They show up in the Extension Manager but
> really don't seem to be installed (for example the Foxytunes UI is missing from
> the UI, and you can't access the Flashgot preferences). They show as active and
> not disabled. I will file a separate bug on this issue after I spend some time
> seeing if this happens with all extensions and whether it happens with a 10.4.5
> profile as well.
> 
> Scenario 3 works fine.
> 





(Reporter)

Comment 27

13 years ago
Created attachment 216889 [details]
Apple crash report showing

Attached is the Apple report I received today when I launched my 10.3.9 PPC profile on today's TB UB build under Rosetta.

Comment 28

13 years ago
nsMailDatabase21GetAllOfflineOpsTableEv is suspicious - that makes me wonder if this is related to bug 216874, which is caused when we fail to create a new .msf file for an imap folder.
I'm having difficulty reproducing the hang on my machine.  I restore ~/Library/Thunderbird and ~/Library/Preferences/org.mozilla.thunderbird.plist from my backup, but now thunderbird runs without problems.

Does Tb use ~/Library/Mozilla/Application Registry or ~/Library/Mozilla/pluginreg.dat ?

Comment 30

13 years ago
I'm still having trouble reproducing any trouble too, but that may be because I'm an IMAP user.

bienvenu, the bug you referenced in comment 28 doesn't seem right.

Comment 31

13 years ago
I meant bug 332119 - only because the stacks are similar. I've seen stack traces with GetAllOfflineOpsTable on the stack, and I think the fix for that bug would also fix those crashes.
(Reporter)

Comment 32

13 years ago
Mark: FYI, the profile I have been testing with is primarily and IMAP profile that also contains all other Thunderbird accounts - POP, RSS, and newsgroup.

(In reply to comment #30)
> I'm still having trouble reproducing any trouble too, but that may be because
> I'm an IMAP user.
> 
> bienvenu, the bug you referenced in comment 28 doesn't seem right.
> 

Comment 33

13 years ago
Comment 24 sounds the most plausible to me for now.  What class(es) implement the msf databases?  Looks like there's more than one.  Can we narrow down which msf files need to be trashed in order to work around this bug?
Flags: blocking1.8.0.3?
Flags: blocking1.8.0.3?
Flags: blocking1.8.0.3+
Flags: blocking1.8.0.2?

Comment 34

13 years ago
I'd like it if Tb could go out as uni for the next (1.5.0.4) release.  Any guidance re comment 33?

Comment 35

13 years ago
The current thinking, as I understand it, is that the profile this bug is based on has something very wrong with it, and that profile doesn't work in emulation mode either. So I think we think the uni build is generally ok.
Is this bug still a blocker for 1.8.0.4?
Whiteboard: maybe not a blocker

Comment 37

13 years ago
Adding qawanted - if Marcia's old profile can be written off as a fluke that doesn't work on ppc or x86, does QA feel that moving a profile between ppc<->x86 is OK in Thunderbird?
Keywords: qawanted
(Reporter)

Comment 38

13 years ago
Mark: Just to clarify, my profile works fine on my PPC machine as well as another PPC machine in the QA lab when I run the PPC build.  When I try to run my profile using the UB on a PPC or on an Intel Mac either under Rosetta or natively it doesn't work. On the Intel Mac I see errors in the JS console when I launch - I can attach those in a document.

I don't think my profile is so wacky.  The only difference it may have between ones of other end users is that it has gone back and forth between different versions of Tbird.  I would like to see a little more testing of older profiles before we push the button and release the UBs.

(In reply to comment #37)
> Adding qawanted - if Marcia's old profile can be written off as a fluke that
> doesn't work on ppc or x86, does QA feel that moving a profile between
> ppc<->x86 is OK in Thunderbird?
> 

Comment 39

13 years ago
I tried this on a new dual cpu intel mac laptop - I built a debug 1.5.0.x intel build, and copied Marcia's profile over an empty profile multiple times. One time, running the debug build outside the debugger hung when I tried to scroll the folder pane, and crunched all the .msf files, like I saw happen on Marcia's machine. All the other times (seven or eight times) I ran the build with the newly copied profile, it worked fine. A 1.5.0.4 release build downloaded from ftp.mozilla.org also worked fine. 

So either I'm not reproducing this problem correctly, or it's very difficult to reproduce, dependent both on profile and machine.
Flags: blocking1.8.0.4+ → blocking1.8.0.5?
Will re-nominate if we get feedback from others indicating this is more than a one-time glitch.
Flags: blocking1.8.0.5? → blocking1.8.0.5-

Comment 41

10 years ago
Gary, you have both PPC and Intel?
Assignee: mscott → nobody
Nope, Intel-only.

Comment 43

10 years ago
Marcia, does this fail with both TB 2 and TB3 milestone? http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
smokey could you give this a try if you still have your PPC machine ?
(In reply to comment #44)
> smokey could you give this a try if you still have your PPC machine ?

I could, though I wouldn't be able to get to it for quite a while.  

However, my gut feeling here is that if this were something other than a fluke with Marcia's one old profile, then there would have been some dupes in the past ~3 years (and/or mento and bienvenu would have found something more when they looked into it).

Updated

7 years ago
Whiteboard: maybe not a blocker → [wontfix?]
We stopped supporting PPC long ago, and there's evidence here that it isn't a general issue. Therefore I think we can wontfix this bug.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.