LDAP completely broken in thunderbird 1.5

RESOLVED DUPLICATE of bug 323655

Status

defect
RESOLVED DUPLICATE of bug 323655
13 years ago
11 years ago

People

(Reporter: blaak, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Basically, I want to reopen bug 308293, but don't seem to have the rights to do so.

I have a Windowx XP (Home Version) laptop, talking to an MS Exchange LPDAP server. With thundbird 1.5 I get zero LPAD support. The same setup with thunderbird 1.0.7 works fine.

I have reverted to 1.0.7

Reproducible: Always

Steps to Reproduce:
1. configure LDAP server with valid host name
2. start a new email
3. try to get email adress completion

Actual Results:  
nothing

Expected Results:  
a list of possible completions
LPAD, LDAP or LPAP? I assume you mean LDAP now?
Reporter

Comment 2

13 years ago
Ya, sorry. Fast typing. LDAP of course.
Summary: LPAP complete completely broken in thunderbird 1.5 → LDAP completely broken in thunderbird 1.5

Comment 3

13 years ago
I had LDAP support working and then I got a new computer.  I installed TB and copied the settings exactly and cannot get LDAP (using Exchange as the server) to work in TB 1.5.  I can't remember if I was using TB 1 or TB 1.5 before but it certainly doesn't work for me now in TB 1.5

Comment 4

13 years ago
The point is, the general LDAP settings don't work. But when you choose in your account then LDAP, then it works.

So it's still a bug in my opinion.

Comment 5

13 years ago
(In reply to comment #4)
> The point is, the general LDAP settings don't work. But when you choose in your
> account then LDAP, then it works.

I mean: when you choose in your account the LDAP and don't use the general settings, then it works.

Comment 6

13 years ago
For me, LDAP itself works fine in 1.5, it's just autocomplete that doesn't work (on most installations I tried). We hadn't started implemeting LDAP when 1.0.7 was out, so I don't know whether it used to work back then. 

Comment 7

13 years ago
I'm seeing a related problem.

Trying to auto to an exchange serverr but there's no pref fiend in the LDAP settings to offer alternet auth credentials.

e.g. my IMAP auths with "username@domain" but the LDAP requires "username@domain.com".

Since there's no place to offer alternate BIND credentials, it fails.

Comment 8

13 years ago
> I have a Windowx XP (Home Version) laptop, talking to an MS Exchange LPDAP
> server. With thundbird 1.5 I get zero LPAD support. The same setup with
> thunderbird 1.0.7 works fine.
> 
> I have reverted to 1.0.7
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. configure LDAP server with valid host name
> 2. start a new email
> 3. try to get email adress completion

At my site we are using Thunderbird 1.5.0.7 against an OpenLDAP 2.2 server and autocompletion works perfectly.  After typing a few letters into the address field, Thunderbird offers a list of addresses where the first name, surname, or e-mail address begin with the letters you have typed.  I am guessing that something in your system is misconfigured, but I don't know what.

Comment 9

13 years ago
> At my site we are using Thunderbird 1.5.0.7 against an OpenLDAP 2.2 server and
> autocompletion works perfectly.

I've had the issue explained to me in more detail, and confirmed the following:

From a fresh Thunderbird installation, if I do (on Linux):

Edit -> Preferences -> Composition -> Addressing

to add a directory server, and I leave my per-account setting on "Use my global LDAP server preferences for this account," autocompletion does not work.

If at that point I change the per-account setting to "Use a different LDAP server," and then choose the very same server that I used for the global settings, autocompletion does work.

I agree that this is a bug.

Comment 10

13 years ago
This is a dupe of bug 323655.

Comment 11

11 years ago
I agree, but I'm not sure if this bug is still present in Thunderbird 2.0 (or later).
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 323655
You need to log in before you can comment on or make changes to this bug.