Closed Bug 332696 Opened 15 years ago Closed 13 years ago

Allow user to select "Leave messages on server" when creating a new POP email account

Categories

(Thunderbird :: Preferences, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 112356

People

(Reporter: indexsuxx, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

When you create an account (POP3) it does not ask you to leave messages on server or not. By default when you press finish it downloads your messages and deletes them from the server.

Reproducible: Always

Steps to Reproduce:
1. Create a pop3 acc
2. press finish



Expected Results:  
At least a checkbox (Leave messages on server) turned on.
A warn is not enoguh safe.
Or it could be possible to set preferences too.
Option at Account Creation time: Seamonkey bug 112356
Option set by default: TB Bug 231541 / Seamonkey bug 295611


*** This bug has been marked as a duplicate of 231541 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Summary: POP3 should leve messages on server by default or let me choose what to do → POP3 should leave messages on server by default or let me choose what to do
I'm re-opening this bug, because the suggestion to allow the user to leave the messages on the server is orthogonal to the suggestion to change the default setting for new POP accounts to leave the messages on the server. Whatever the default is, the user may be allowed to change the setting when creating the account. Likewise, whatever options are added to the user interface, the default setting can either stay as it is or change. I've updated the summary to reflect that this bug report covers just changing the user interface, because the changing default is already covered by bug 231541.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: POP3 should leave messages on server by default or let me choose what to do → Allow user to select "Leave messages on server" when creating a new POP email account
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: mscott → nobody
OS: Windows XP → All
Hardware: PC → All
Today I'm setting up my email accounts again (version 3.0a1pre (2007100604)), and I have noticed a few things:

1) On the first email account you create, you have the option of not downloading messages when you create the account. You can then go into the Account Settings and check Leave messages on server, and then download messages. This is a workaround for the first account created.

2) On subsequent email accounts you create, you are not given the option of not downloading messages when you create the account. You must download them manually, so you don't need a workaround for this case. Strangely, when you go into the Account Settings for the subsequent accounts, the defaults are different. You need to manually check Check for new messages at startup and Automatically download new messages.

Anyway, the point of this post is to clarify what the workaround is for this bug (needed only on the first account created), and that there are further problems with the account creation process. I'll look for bug reports on the other issues.
Duping since the account wizard is shared with seamonkey.
Status: NEW → RESOLVED
Closed: 15 years ago13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 112356
You need to log in before you can comment on or make changes to this bug.