No option to leave email messages on server when creating new account

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
17 years ago
8 years ago

People

(Reporter: ec9098, Assigned: ewong)

Tracking

({dataloss})

Trunk
dataloss
Dependency tree / graph
Bug Flags:
wanted1.9.1 ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 4 obsolete attachments)

(Reporter)

Description

17 years ago
When a new user is setting up the mozilla email client for the first time, they
are asked to enter a variety of settings for their email server.  The wizard
does not give the option to leave messages on the server, however.  When the
"finish" button is clicked, the email client connects to the server, and
downloads the email from the server, in the process deleting them from the server.

After this happens, it's possible go back and edit your settings to leave
messages on the server, but at this point it's too late, the damage has already
been done.

Comment 1

17 years ago
Marking nsbeta1 so this is considered for the next release. 

Would the default have the "leave messages on server" option checked or
unchecked in the account wizard? I would say unchecked by default with the
option to check it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsbeta1
(Reporter)

Comment 2

17 years ago
For what it's worth, I agree with this suggested default setting -- most users 
probably don't even understand what it *means* to leave messages on the server, 
and you'd have tons of cases where people's mailboxes got full because they 
didn't know they needed to change a default setting.

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9

Comment 3

17 years ago
Most Wizards include the bare minimum to get the user up and running, and don't 
include items that more advanced users would be interested in. 

Is this something we think enough users would benefit from that it needs to be 
included?

Comment 4

17 years ago
*** Bug 91211 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

17 years ago
I agree that only more advanced users will be affected by this bug, but for 
people like me who manage email across multiple machines with a single master 
archive machine, it's potentially catastrophic.  You could have to deal with 
hundreds of messages being accidentaly removed from the POP server, and no good 
way to get them into your master archive with all the original header 
information intact.

I favor Ninoschka's suggestion to have as an unobtrusive option that defaults 
to the more common scenario of deleting messages from the server.

Comment 6

17 years ago
Devil's Advocate: We don't download new messages for pop accounts until the user 
requests them ("Get Msgs"), so the knowledgeable user can change this setting in 
prefs before they download their messages.

My concern is that average users seeing this pref in the Wizard won't know what 
to do with it. Since POP is the default acct type in the Wizard, the checkbox 
would be enabled (but not checked) by default (vs if IMAP is selected, this 
pref would be disabled).

I'm not opposed to including it in the Wizard, just want to be sure the benefit 
out weighs any confusion for average users we may cause.
(Reporter)

Comment 7

17 years ago
>>Devil's Advocate: We don't download new messages
>>for pop accounts until the user requests them 
>>("Get Msgs"), so the knowledgeable user can change 
>>this setting in prefs before they download their messages

While in general this is true, the point I'm making is that there IS one time 
when we do download messages from the server without asking the user.  That 
time is when the wizard completes it's setup process.

I'm not sure if this is the best way to go or not, but there's another way 
around this bug that doesn't involve adding additional UI components to the 
wizard -- just don't automatically connect to the server when the wizard 
completes.  The risk of this approach is that if people don't see their email 
right away they might become confused.

I think the impact of either solution will probably be low.

Comment 8

17 years ago
Based on Travis's comments above that we download messages after the wizard is
complete. We do not download the messages right after the completion of the
wizard when you create your default pop account.  However, with check new mail
at start up on by default, does check for messages and puts an arrow at the
account level after giving the password.
So at this point we are displaying the password dlg for which the user can
cancel go to accounts and settings and check the pref to leave messages on the
server. 

This is a linux only bug. We should only check for new mail instead of
downloading.  Fixing this bug will indicate a green arrow at the account level
and not download messages.  If this works for Travis then I will change this to
be a pop networking bug and then we can resolve this not to download messages. 
If not this should be changed to an enhancement and can be considered for the
next release if there everyone agrees to put this in the wizard.  
Else I will log a new bug for linux that we should not download messages and
only check for messages. Because windows seems to be doing that not downloading.


Comment 9

17 years ago
Navin, 
I checked this behavior on linux 2001-12-11 build and we are downloading
messages. We should not be. We need to only check for messages and the messages
should be retrieved only after clicking on the get message button.  
(Reporter)

Comment 10

17 years ago
I think Sheela's plan is probably fine.  What does it mean (for the user) to 
check for new messages but not download them?  Do they get a dialog alerting 
them they have new mail?

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1-
Target Milestone: mozilla0.9.9 → Future

Comment 11

17 years ago
adding self to cc list
mass re-assign.
Assignee: racham → sspitzer
Status: ASSIGNED → NEW
This is dataloss. Adding keyword. This also affects firefox and firefox also
asks you if you want to download the message without letting you change the
preference.

A quick way to alleviate the dataloss for this issue would be to change the
preference so "Leave email messages on server" is off by default. It should be
off by default anyway. Bug 231541

I believe 231541 will be a one-line fix.
Keywords: dataloss
Product: Browser → Seamonkey

Comment 14

14 years ago
 The problem originally reported was that Thunderbird defaulted to immediately
attempting to download messages after account creation /and/ defaulted to
removing messages from the POP server, without giving the user a chance to
change these settings.

 I believe that recent Thunderbird releases have a "Download messages now"
checkbox (checked by default) on the final page of the account wizard when
creating POP accounts. I would suggest that the "Download messages now" option
fixes this bug in principle. Or makes it invalid.

Reporter (Travis): Please try account creation with the latest (0.9) release and
close (or modify) this bug as you see fit.

Comment 15

14 years ago
bugzilla@quilty.org: that's nice, but dead wrong. in fact i even filed a bug
about thunderbird's behavior. please don't harm poor little bugs.

Comment 16

14 years ago
Bug 270743 is the bug to which timeless is referring. Bug 270743 makes relying
on the "Download messages now" option in the wizard not a good solution (at
least for now).
bugzilla@quilty.org: Having the option is not even a workaround since they could
manually download the emails after, resulting in the same effect. The other
thing is that a reporter can't mark a bug invalid at this point when there are
already CCs and dupes unless the community agrees to mark it invalid.
In comment #13, I meant that bug 231541 is "Leave messages on server" should be
chosen by default in the wizard. We should give a warning if they leave this
setting as-is that they could fill their mail server and it could start
rejecting messages.

Comment 19

14 years ago
*** Bug 124110 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Assignee: sspitzer → mail

Comment 20

13 years ago
This item is in discussion since 2001-11-28, and maybe somewhere else before.
It is to be found in multiple reported bugs!

Fact is that a lot of things changed. Now access mostly  is over internet. Mailboxes are much larger and mail is accessed from many different places.

So if you ad an account and you don’t know the difference between imap and pop -most don’t and I learned recently- you don’t know the consequences about leave message on server.

I had imap mailboxes and worked fine. At work they got an pop mailbox. When adding this one to thunderbird, all messages from work ended on mine home PC and worse, at work mine mailbox was empty.
I ALMOST GOT FIRED!
I had to explain what happened. They concluded that this was caused because of lack off knowledge of me and a stupid thing from thunderbird. ALL EMPLOYEES ARE TOLD TO NOT USE THUNDERBIRD FOR WORK MAIL! 

So I would strongly recommend that when adding a pop account you must be warned.
Just the first time mail is downloaded, ore your account is accessed, a question has to pop up and ask wether you leave all messages on the server, so you can elsewhere uses all you mails ore turn this option off.

So please take care of this. This is not good for Tthunderbird
OS: Linux → All
QA Contact: nbaca
Hardware: PC → All
Target Milestone: Future → ---
Duplicate of this bug: 332696
QA Contact: account-manager
Whiteboard: (Thunderbird & SeaMonkey)

Comment 22

11 years ago
Wow! This is still under debate? I do not see how it can be alright to 
move/delete important personal and professional information without
allowing the owner of that information a say in the matter. A user must be
consulted,or at the very least clearly warned, about such potentially destructive 
behaviour and be allowed the opportuity to change or aviod it.
Duplicate of this bug: 313270
I'm recommending this as a WONTFIX, there are too many options in the account wizard as it is.  The default behavior needs to be the route of least damage for the users we are concerned won't bother with the options while there exists an escape hatch for advanced users who know the options.

At the last page of the Account Wizard there is an option to "Download Messages Now", a person who wants to change this account settings should be un-checking that box before continuing.  However, a complete change needs to add some information by that checkbox saying that "Messages will be left on the Server" so a person in the know is aware of the account settings.

With bug 231541 nominated for TB3 as well as an additional message added to the last page I think we can have a solution that suites most people well enough.

Latest changes to the account wizard are being put up at this page:
http://wiki.mozilla.org/MailNews:Account_Wizard:Email

If this bug is changed to "Add POP download status message to last page of Account Wizard" then we can make sure to get that fix checked in.  I hope that's a fair change.

Comment 25

11 years ago
(In reply to comment #22)
> A user must be consulted,or at the very least clearly warned, about 
> such potentially destructive behaviour and be allowed the opportuity 
> to change or aviod it.

(In reply to comment #24)
> If this bug is changed to "Add POP download status message to last page of
> Account Wizard" then we can make sure to get that fix checked in.


 There is already a bug filed for a warning in the Account Wizard, Bug 312431.

Updated

11 years ago
Flags: wanted1.9.1?
QA Contact: account-manager
Duplicate of this bug: 452406

Comment 27

10 years ago
This bug is STILL present!! I have downloaded Thunderbird to try it and the default to download and remove files from the server has caused me lots of trouble since the option to leave messages on the server is hidden deep in the preferences set up. The set up wizard does not warn you.
In today's households, there is a computer in different rooms, and if Thunderbird removes all mail from a server every time it is accessed, it must cause LOADS of problems!!!
Surely the default should be to LEAVE mail on the server.
This can be closed when bug 422814 lands as this will be the default option
Depends on: 422814

Comment 29

10 years ago
I am not a programmer, so don't understand a lot of this. I don't understand why the default is allowed to stand where it can cause so much havoc unknown to the user. What benefit is there? Surely as people fill up the server, the option to remove messages can be actioned?
Thunderbird taking all my mails off the server has cuased lots of pfoblems in my household, and it has also messed up how my ISP (Madasafish) can contact me, despite my correcting the remove messages from server option.
Assignee: mail → nobody
QA Contact: mailnews-account

Comment 30

10 years ago
I don't understand how this can still be a bug when it was first raised in 2001, and the potentially catastrophic consequences were already mentioned in that year.

Bug 422814 will not _necessarily_ fix this one. It will only fix it, if it itself is corrected using a particular resolution. Secondly, 422814 is targeted for 3.0b2. This is far too late. Just how hard can it be to change the option used by the wizard? This should be in the next available build. Period.

I don't think just correcting the wizard goes far enough. It is actually possible to do lots of damage by unchecking a rather innocuous checkbox. Unchecking it should result in a prompt detailing the consequences of not leaving messages on the server and asking for user confirmation. This is the standard type of behaviour that I would require whenever a drastic change in data is about to be initiated by an application.
Created attachment 356463 [details]
Screen shot of Opera's "account wizard"

This is screen shot of "Account Wizard" of M2 of Opera 10 Alpha.

Developers of Opera seem to know longstanding Bug 112356 and Bug 221030 well.
> Bug 112356 : No option to leave email messages on server when creating new account 
> Bug 221030 : Unable to set up IMAP over SSL using the New Account Wizard   
Developers of Opera seem to know also dust settles of Bug 231541 very well.
> Bug 231541 : "Leave messages on server" should be chosen by default (dataloss)

Sorry but I don't know which version of Opera introduced such UI for mail account definitipon.

Comment 32

9 years ago
I was about to try migrating from Eudora 6.2.4 (Mac) to Thunderbird, but this bug report has given me pause; IS there a way to set up Thunderbird WITHOUT downloading all your mail ?  The above comments seem to vacillate both ways, and the option to leave the mail on the server seems to require that you know when to quit the Wizard.....

I see that this bug is assigned to "nobody", with an invitation to "take it and work on it"....I might just do that, even though it's been years since I've written any _real_ code!
The new quick account setup in thunderbird3 defaults to leave messages on server (for a while). This bug now only concerns seamonkey users.
Whiteboard: (Thunderbird & SeaMonkey)

Comment 34

9 years ago
This is good news, although Eudora 8.0b7 (which, I thought, was based on Thunderbird3) still has the default of deleting the messages upon retrieval.  I'm just getting my feet wet with Eudora8 (and, therefore, Thunderbird), so I don't know if the behaviour I observed is a Penelope-specific thing or if the "new quick account setup" in Thunderbird is not yet included in the Eudora package.
(Assignee)

Updated

8 years ago
Assignee: nobody → ewong
Status: NEW → ASSIGNED
(Assignee)

Comment 35

8 years ago
Created attachment 528544 [details] [diff] [review]
Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account.
Attachment #528544 - Flags: review?(mnyromyr)
(Assignee)

Updated

8 years ago
Attachment #528544 - Flags: review?(mnyromyr) → review?(iann_bugzilla)

Comment 36

8 years ago
> --- a/suite/locales/en-US/chrome/mailnews/pref/AccountWizard.dtd
> +++ b/suite/locales/en-US/chrome/mailnews/pref/AccountWizard.dtd

Does Thunderbird still use this version of the Account manager? If they still build with this then we need to update their version of AccountWizard.dtd don't we?

Comment 37

8 years ago
Comment on attachment 528544 [details] [diff] [review]
Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account.

>+++ b/mailnews/base/prefs/content/AccountWizard.js
>@@ -364,6 +364,7 @@ function PageDataToAccountData(pageData,
>         var localFoldersAccount = accountManager.FindAccountForServer(localFoldersServer);
>         accountData.pop3.deferredToAccount = localFoldersAccount.key;
>         accountData.pop3.deferGetNewMail = true;
>+        accountData.pop3.leaveMsgsOnServer = true;
Remind me, why is this bit needed?

>@@ -390,13 +391,18 @@ function PageDataToAccountData(pageData,
>         }
>         if (pageData.identity && pageData.identity.smtpServerKey)
>             identity.smtpServerKey = pageData.identity.smtpServerKey.value;
>+
>+        if (pageData.pop3.leaveMessagesOnServer &&
>+            pageData.pop3.leaveMessagesOnServer.value)
>+        {
>+           server["ServerType-pop3"] = pageData.pop3.leaveMessagesOnServer.value;
Are you sure this bit is correct? shouldn't it be server["ServerType-pop3"].leave_on_server = etc, or something similar?

>+++ b/mailnews/base/prefs/content/AccountWizard.xul
>@@ -167,6 +167,14 @@
>                    accesskey="&incomingServerLabel.accesskey;" control="incomingServer"/>
>             <textbox wsm_persist="true" id="incomingServer" flex="1" class="uri-element" oninput="serverPageValidate();"/>
>           </hbox>
>+          <hbox id="leaveMsgsOnSrvrBox" class="indent">
>+            <checkbox id="leave_on_server"
>+                      label="&leaveMsgsOnSrvr.label;"
>+                      accesskey="&leaveMsgsOnSrvr.accesskey;"
>+                      wsm_persist="true"
>+                      oncommand="setLeaveMessagesOnServer();"
>+                      checked="true"/>
>+          </hbox>
As this is for pop3 only, does it getting hidden on other account/server types?

>+++ b/mailnews/base/prefs/content/aw-server.js
>@@ -170,6 +170,7 @@ function serverPageInit() {
>       serverTypeRadioGroup.selectedItem = serverTypeRadioItem;      // Set pop3 server type as default selection
>     }
>     setServerType();
>+    setLeaveMessagesOnServer();
>     setDeferStorage(); // set the initial value correctly
>   }
>   else if (isOtherAccount) {
>@@ -261,4 +262,9 @@ function setDeferStorage()
>   setPageData(pageData, "server", "deferStorage", deferStorage);
> }
> 
>-
>+function setLeaveMessagesOnServer()
>+{
>+  var pageData = parent.GetPageData();
>+  var leaveMsgsOnSrvr = (document.getElementById("leave_on_server")).checked;
>+  setPageData(pageData, "pop3", "leaveMessagesOnServer", leaveMsgsOnSrvr);
>+}
I've never been 100% happy with the setDeferStorage function, and doing this one the same way doesn't help.
The minimum I would like to see for both functions is the passing in of element.checked or this.checked depending on if it is from the JS or the XUL.
Not sure if it is possible to have a more generic function that could replace both functions though.

>+++ b/suite/locales/en-US/chrome/mailnews/pref/AccountWizard.dtd
>@@ -54,6 +54,8 @@
> <!-- LOCALIZATION NOTE (popType.label) : Do not translate "POP" in below line -->
> <!ENTITY popType.label "POP">
> <!ENTITY popType.accesskey "P">
>+<!ENTITY leaveMsgsOnSrvr.label "Leave Messages on server">
>+<!ENTITY leaveMsgsOnSrvr.accesskey "L">
As my esteemed colleague has already asked, does TB still use this account wizard, if so you will also have to patch their AccountWizard.dtd too (you would already need an additional review due to the location of the JS/XUL code anyway).
r- for the moment.

P.S. Don't forget to make sure that help changes are either covered in this patch or a bug created to cover those changes.
Attachment #528544 - Flags: review?(iann_bugzilla) → review-
(Assignee)

Comment 38

8 years ago
(In reply to comment #37)
> Comment on attachment 528544 [details] [diff] [review]
> Added a checkbox that allows the user to leave e-mail messages on server during
> the creating of a new mailnews account.
> 
> >+++ b/mailnews/base/prefs/content/AccountWizard.js
> >@@ -364,6 +364,7 @@ function PageDataToAccountData(pageData,
> >         var localFoldersAccount = accountManager.FindAccountForServer(localFoldersServer);
> >         accountData.pop3.deferredToAccount = localFoldersAccount.key;
> >         accountData.pop3.deferGetNewMail = true;
> >+        accountData.pop3.leaveMsgsOnServer = true;
> Remind me, why is this bit needed?

For the deferred creation of the account, the default leaveMessagesOnServer
is set to true.  Of course, this version above is wrong.  I'll be updating
the patch to right one.
> Are you sure this bit is correct? shouldn't it be
> server["ServerType-pop3"].leave_on_server = etc, or something similar?

It's leaveMessagesOnServer, but it needs to have an intermediate
step. 
> As this is for pop3 only, does it getting hidden on other account/server types?

Fixed with the coming patch.

> I've never been 100% happy with the setDeferStorage function, and doing this
> one the same way doesn't help.
> The minimum I would like to see for both functions is the passing in of
> element.checked or this.checked depending on if it is from the JS or the XUL.
> Not sure if it is possible to have a more generic function that could replace
> both functions though.
> 
> >+++ b/suite/locales/en-US/chrome/mailnews/pref/AccountWizard.dtd
> >@@ -54,6 +54,8 @@
> > <!-- LOCALIZATION NOTE (popType.label) : Do not translate "POP" in below line -->
> > <!ENTITY popType.label "POP">
> > <!ENTITY popType.accesskey "P">
> >+<!ENTITY leaveMsgsOnSrvr.label "Leave Messages on server">
> >+<!ENTITY leaveMsgsOnSrvr.accesskey "L">
> As my esteemed colleague has already asked, does TB still use this account
> wizard, if so you will also have to patch their AccountWizard.dtd too (you
> would already need an additional review due to the location of the JS/XUL code
> anyway).
> r- for the moment.
It's not being used from what I understood from #maildev.  


> 
> P.S. Don't forget to make sure that help changes are either covered in this
> patch or a bug created to cover those changes.

I'll spin off a bug for this.
(Assignee)

Comment 39

8 years ago
Created attachment 529097 [details] [diff] [review]
Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account
Attachment #528544 - Attachment is obsolete: true
Attachment #529097 - Flags: review?(iann_bugzilla)
Comment on attachment 529097 [details] [diff] [review]
Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account

Drive-by nit:

>+<!ENTITY leaveMsgsOnSrvr.label "Leave Messages on server">

Lowercase (or uppercase if it matches the dialog style) _both_ nouns.

Comment 41

8 years ago
All of a sudden over the past few days I've started receiving updates on this bug.
HOW CAN THIS NOT BE FIXED YET?!?
Beyond that simple question, which seriously damages Thunderbird's credibility, I wonder whether you actually perceive the chasm that exists between user comments and technical comments... I AM (or was) a programmer and I am disgusted by the blatant lack of understanding of the user issue: DATA LOSS.
It doesn't matter what function does what. It doesn't matter how tidy the code is. None of your/our technical concepts matter. THE USER MUST NOT LOSE DATA WITHOUT BEING EXPLICITLY, CLEARLY, WARNED. Nor should they lose data through oversight (default behaviour should preserve data).
Just fix that. Afterwards, do whatever you want with your code.
(Assignee)

Comment 42

8 years ago
(In reply to comment #41)
> All of a sudden over the past few days I've started receiving updates on this
> bug.
> HOW CAN THIS NOT BE FIXED YET?!?
> Beyond that simple question, which seriously damages Thunderbird's credibility,

Firstly, were you to read the bug as a whole, you'd find that this isn't a 
Thunderbird bug, but a SeaMonkey bug.  Also, were you to read the
'updates' on this bug, you'd find that this bug IS being attended to.
Of course, I may not be the FASTEST of programmers nor the smartest
of ones, but I am trying my best.  It is afterall a volunteer work.

I do hope to get this bug fixed soon.

Comment 43

8 years ago
Edmund & co, please ignore my rude (drunken) post and thanks for all your volunteer efforts.

Comment 44

8 years ago
Comment on attachment 529097 [details] [diff] [review]
Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account

>+++ b/mailnews/base/prefs/content/AccountWizard.xul
>+          <hbox id="leaveMsgsOnSrvrBox" class="indent">
>+            <checkbox id="leave_on_server"
>+                      label="&leaveMsgsOnSrvr.label;"
>+                      accesskey="&leaveMsgsOnSrvr.accesskey;"
>+                      wsm_persist="true"
>+                      oncommand="setPtagPslot(this, 'pop3', 'leaveMessagesOnServer');"
Urgh, horrible function name, sounds Klingon! setServerSlot or setServerPrefs or something like that perhaps would be better?
I see a number of options here:
1a/ change the id to 'leaveMessagesOnServer' and just pass this (then you can extract this.checked and this.id from it) and 'pop3'
1b/ change the id to 'leaveMessagesOnServer' and pass this.checked, 'pop3' and this.id
2/ leave the id as it is and pass this.checked, 'pop3' and 'leaveMessagesOnServer'

>+++ b/mailnews/base/prefs/content/aw-server.js
>+    var pLeave = document.getElementById("leave_on_server");
>+    var pDefer = document.getElementById("deferStorage");
>     setServerType();
>-    setDeferStorage(); // set the initial value correctly
>+    setPtagPslot(pLeave, 'pop3', 'leaveMessagesOnServer');
>+    setPtagPslot(pDefer, 'server', 'deferStorage');
Using 1a would mean you could inline the variables, otherwise you need better variable names - leaveMessages and deferStorage sound okay.

>-function setDeferStorage()
>+function setPtagPslot(pThis, pTag, pSlot)
variable names should start with an 'a' so aThis and aTag or aChecked, aTag and aSlot depending on the option chosen earlier.
> {
>-  var pageData = parent.GetPageData();
>-  var deferStorage = (document.getElementById("deferStorage")).checked;
>-  setPageData(pageData, "server", "deferStorage", deferStorage);
>+  setPageData(parent.GetPageData(), pTag, pSlot, pThis.checked);
Either aTag, aThis.id, aThis.checked or aTag, aSlot, aChecked depending on the option chosen earlier.

r- for the moment
Attachment #529097 - Flags: review?(iann_bugzilla) → review-
(Assignee)

Comment 45

8 years ago
Created attachment 531629 [details] [diff] [review]
Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account   (v3)
Attachment #529097 - Attachment is obsolete: true
Attachment #531629 - Flags: review?(iann_bugzilla)

Comment 46

8 years ago
Comment on attachment 531629 [details] [diff] [review]
Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account   (v3)

>+    var pop3 = accountData.pop3;

>         accountData.pop3.deferredToAccount = localFoldersAccount.key;
>         accountData.pop3.deferGetNewMail = true;
>+        accountData.pop3.leaveMessagesOnServer = true;
>         server["ServerType-pop3"] = accountData.pop3;
Sorry, I should have pointed this out before, but now you have defined pop3 = accountData.pop3, you should be able to change the above accountData.pop3s to pop3s

>+function setServerPrefs(aThis, aTag)
Just wondering if you should reverse the order of these arguments so it is in a similar order to setPageData.
> {
>+  setPageData(parent.GetPageData(), aTag, aThis.id, aThis.checked);
> }

>+<!ENTITY leaveMsgsOnSrvr.label "Leave Messages on server">
As was said before, messages rather than Messages.

r=me with that fixed, don't forget you will need a second review /super review

Also don't forget to put the help bug you have spun off as being blocked by this bug.
Attachment #531629 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 47

8 years ago
Created attachment 532429 [details] [diff] [review]
Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account (v4)
Attachment #531629 - Attachment is obsolete: true
Attachment #532429 - Flags: superreview?(neil)
Attachment #532429 - Flags: review+
(Assignee)

Updated

8 years ago
Blocks: 657126
Comment on attachment 532429 [details] [diff] [review]
Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account (v4)

>+        pop3.deferredToAccount = localFoldersAccount.key;
>+        pop3.deferGetNewMail = true;
>+        pop3.leaveMessagesOnServer = true;
This block is all about the global inbox, so setting leaveMessagesOnServer here looks wrong.

>+        if (pageData.pop3.leaveMessagesOnServer &&
>+            pageData.pop3.leaveMessagesOnServer.value)
Why does this use pop3? None of the other controls does this.

>+  setPageData(parent.GetPageData(), aTag, aThis.id, aThis.checked);
Instead you should always use "server" as the tag.

>+<!ENTITY leaveMsgsOnSrvr.label "Leave messages on server">
>+<!ENTITY leaveMsgsOnSrvr.accesskey "L">
Thunderbird can still access this dialog (I can't remember exactly where but they do have a menuitem for it) so you'll need to provide entities for them.
Attachment #532429 - Flags: superreview?(neil) → superreview-
(Assignee)

Comment 49

8 years ago
Created attachment 534265 [details] [diff] [review]
Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account (v5) [Checkin: comment 52]
Attachment #532429 - Attachment is obsolete: true
Attachment #534265 - Flags: review+
(Assignee)

Updated

8 years ago
Attachment #534265 - Flags: review?(bwinton)
Comment on attachment 534265 [details] [diff] [review]
Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account (v5) [Checkin: comment 52]

Review of attachment 534265 [details] [diff] [review]:
-----------------------------------------------------------------

The Mail DTD changes seem okay to me.

Thanks,
Blake.
Attachment #534265 - Flags: review?(bwinton) → review+
(Assignee)

Updated

8 years ago
Attachment #534265 - Flags: superreview?(neil)
Attachment #534265 - Flags: superreview?(neil) → superreview+

Comment 51

8 years ago
Edmund, is this ready for check-in?
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
Comment on attachment 534265 [details] [diff] [review]
Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account (v5) [Checkin: comment 52]

http://hg.mozilla.org/comm-central/rev/07a5574693d4
Attachment #534265 - Attachment description: Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account (v5) → Added a checkbox that allows the user to leave e-mail messages on server during the creating of a new mailnews account (v5) [Checkin: comment 52]
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.