Closed Bug 332965 Opened 17 years ago Closed 16 years ago

Show dialog when adding new Live Bookmark

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Firefox 3 alpha3

People

(Reporter: Peter, Assigned: asaf)

References

Details

(Whiteboard: [Fx2-parity] patch on bug 357316)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060404 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060404 Firefox/1.6a1

Ability to define default Subscriptions folder (other than Bookmarks Toolbar)

It seems that new Subscriptions are placed along the Bookmarks Toolbar and cannot be moved. Also, I couldn't find a way to place Subscriptions into another folder.

Reproducible: Always

Steps to Reproduce:
1. Go to a site with a live feed (e.g., http://planet.mozilla.org/) and click on the  "Add Live Bookmark" icon in the URL bar. (the Feed Folder is added to the Bookmarks Toolbar)

2. In Places, try to define another default location for added feeds

3. Try dragging the new Feed folder to another location, either from withing Firefox's main window or within Places.
Actual Results:  
1. Feed is added to the Bookmarks Toolbar.

2. Can't define another default location from Places or Bookmarks menu.

3. Can't drag created Feed folders to anywhere else, neither via Places nor via the Bookmarks Toolbar.

Expected Results:  
1. Feed added to definable default Feed Folder (e.g., Bookmarks / Web Content / My Feeds)

2. (Easily findable) UI to define default Subscriptions folder.

3. Ability to D&D Subscriptions to other locations (optional, as this might break the seeming all-Scubscriptions-are-in-one-location paradigm).

Please fix soon, as my Bookmarks Toolbar is already full! ;-)
We need this for feature complete. 

Should show "add bookmark" dialog as with Firefox 1.x.
Assignee: nobody → joe
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Target Milestone: --- → Firefox 2 alpha2
Indeed.  My current plan is to just have it default to the folder selected last time.
Status: NEW → ASSIGNED
Summary: Ability to define default Subscriptions folder (other than Bookmarks Toolbar) → Show dialog when adding new Live Bookmark
Whiteboard: swag 1
(In reply to comment #2)
> ... default to the folder selected last time.

Does that mean *any* folder the user added *any* bookmark to (feed or not), or the last *feed* bookmark folder the user selected? Neither seems optimal.

Wouldn't it be better to do it like regular bookmarks, which default to "Bookmarks Menu" every time the user selects "Bookmark This Page (CTRL+D)", only with feeds it should default to some default "Feeds folder"?
We actually had "use last folder" around 0.8 or so, it was really useful, but we backed away from that, largely because the implementation was kinda iffy, and people wanted to default to the root.

I think we should take another crack at it, since when it worked it was a huge win, it was just slightly unpredictable.
I'm a bit confused about the new Places way of handling feeds (sorry, Subscriptions). It's listed as a *separate* item in the left pane:

History
Bookmarks Menu
Bookmarks Toolbar
Subscriptions

So, if we default to the last used folder, and the user had previously added a bookmark to a subfolder under the "Bookmarks Menu", will the feed dialog offer that folder? Will he be offered the last used Subscriptions folder? Wouldn't the be assuming he always only adds "political" feeds or only one type of feed[1]? How are Bookmarks and Subscriptions managed with these "separate" items? Can/will a Subscription exist in both places? Simultaneously? Can the user only get to his feeds via the Places window (because there is no "Subscriptins" folder in the Bookmarks Menu)?

Subscriptions
  Computers
    Mozilla
  Political
  Humorous

I'm either not getting something, or Places is still going to change/evolve radically somehow, or there is something wrong with the current Places implementation (and nobody is noticing it). :-\
*** Bug 333708 has been marked as a duplicate of this bug. ***
*** Bug 346303 has been marked as a duplicate of this bug. ***
Assignee: mozilla → mano
Blocks: 370099
Status: ASSIGNED → NEW
Depends on: 357316
OS: Windows XP → All
Priority: P3 → P2
Hardware: PC → All
Whiteboard: swag 1 → [Fx2-parity] patch on bug 357316
Target Milestone: Firefox 2 alpha2 → Firefox 3 alpha3
Status: NEW → ASSIGNED
Fixed by bug 357316.
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.