Closed Bug 334867 Opened 15 years ago Closed 13 years ago

Find toolbar opens on its own

Categories

(Toolkit :: Find Toolbar, defect)

1.8.0 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dball, Unassigned)

References

Details

(Whiteboard: CLOSEME 08/16)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

After using the find toolbar at the bottom of the page in one window (instance of Firefox), when you do input in another window, the other window opens the find toolbar instead of taking the input. After a couple seconds it goes to the first instance of the text on the page and closes the toolbar. It does this until you close all instances of Firefox. 

This started when I upgraded to Firefox 1.5.0.2. I think I was on 1.5.0.1 before, but it was definately a 1.5 version.

Reproducible: Always

Steps to Reproduce:
1. Open your first instance of firefox and Go to http://www.booksnbytes.com/

2. On the left, where it says "author indexes", click on the first entry which is titled "Index of all Authors".

3. Use Ctrl-f to open the search toolbar and start typing a name on the list. After the first few characters, type garbage so it finds nothing. Hit escape to close the toolbar. Leave this instance of Firefox open

4. Open a second instance of firefox and go to an Amazon.com search page I have bookmarked http://www.amazon.com/exec/obidos/ats-query-page/ref=b_tn_bo/002-8223462-4627436

5. In the same instance as 4, open a second tab and open a bookmarked Amazon.co.uk book search http://www.amazon.co.uk/exec/obidos/ats-query-page/ref=b_all_nb_sr/

6. Open a third instance of the browser. In my case it was opened by the BOINC manager program being told to edit preferences for one of the BOINC (Berkley Open Infrastructure for Network Computing) projects. Edit your default preferences. The numeric field at the top has your existing preference filled in. You can backspace over them, but once you enter any number, it opens the find toolbar, searches for what you've already typed (usually 1 or 2 and possibly a decimal point) and highlights the first instance of it on the page, then closes the find toolbar. You have to close all instances of Firefox before you can enter data into a form. I had opened a 4th instance of Firefox to enter the bug and found that I had to close them all and then open a new instance of Firefox before I could enter data input into bugzilla, so it's not just entering numeric data or input fields that are pre-filled with default values.



Actual Results:  
Search opens every time you enter input.

Expected Results:  
Should have accepted the input into the form field.

WinXP Pro with SP2 and ALL updates including those released this month (April 2006)

BOINC 5.2.13 is running climateprediction (hadcm3lb 5.08) in the background.

eMachines D2386 with Celeron 2.3 Ghz and 768 MB RAM (was 512 but I upgraded months ago). Intel 845G based motherboard.

Extensions: 
   DOM Inspector 1.8.0.2
   talkback 1.5.0.2
   Google Toolbar for Firefox 1.0.20051122
   Sage 1.3.6

I'm still using the default theme.

After all instances of Firefox are closes, you can open one and you're able to enter input into forms again. I had to do that to filll out this bug report.

I discovered this while working on the database for my website so Access2000 SP3 plus thunderbird 1.5 (including a window to search the inbox that pending book reviews are in) and notepad are running as well. The system is very responsive and doesn't appear to be swapping anything to disk.

IIRC, there's some option for making Firefox keep some stuff loaded all the time so it will start faster. I don't use that.
Blocks: findgrabs
Summary: Find toolbar opens on it's own → Find toolbar opens on its own
Version: unspecified → 1.5.0.x Branch
I have experienced similar problems. I usually notice it when opening a new instance of firefox to perform a Google search. Input to the Google form is impossible, but the google search engine shortcut in the toolbar does work. The text editing in that box, however, is somewhat altered as I can no longer use the arrow keys to move the cursor.

Minimizing and restoring that instance of the browser solves the issue for me (both the input problem as well as the text-editing-on-toolbar-shortcut problem).
I also hit this frequently and it is 100% reproducible.  Comment#1 exactly describes the steps required to reproduce.

I started to see this in release 1.5 and it has been present in every bugfix release since.
The following are all duplicates of this bug: bug#338778, bug#339158, bug#343448, bug#345924
Andrew, we've decided to just use bug 320465 as a tracking bug for bugs like this instead of marking bugs as duplicates.
David - can you make this happen on the 3rd window without opening the second tab?  How are you opening new firefox windows? Can you reproduce this bug when making new windows with ctrl+n ?
Can this be reproduced with the latest versions of Firefox?
Whiteboard: CLOSEME 08/16
no response since over 6 months - and Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9pre) Gecko/2008033105 Minefield/3.0pre -> wfm
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.