Closed Bug 335423 Opened 15 years ago Closed 11 years ago

Profile folder's Chrome sub-folder not created by default

Categories

(Thunderbird :: Preferences, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dylananglada, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

I have tried installing Thunderbird twice, and it will not create the chrome sub-folder in the Profile folder, in the Application Data folder.

Reproducible: Always

Steps to Reproduce:
1. Uninstall any existing Thunderbird, and delete Program Files Thunderbird folder and the Thunderbird folder in the Application data
2. Install Thunder 1.5.0.2
3. Check the Thunderbird folder in the Application data

Actual Results:  
The only folders in there were extensions and Mail.

Expected Results:  
Chrome sub-folder should be there, along with userContent-example.txt, etc.
Installing a theme will create the "chrome" folder, but the userChrome-example.txt and the userContent-example.txt files are not in there. In fact, nothing is. I know that the userChrome.css and userContent.css aren't supposed to be there, but the examples ARE. I believe that you don't usually have to install anything but Thunderbird to get them, though.
Version: unspecified → 1.5
Thunderbird version 1.5.0.4 (20060530); Mac OS 10.3.9

 I can confirm this on the Mac.

 This bug is problematic because it invalidates some of the assumptions and instructions on the MozillaZine Knowledge Base and the Customizing Mozilla <http://www.mozilla.org/unix/customizing.html> page regarding editing the userChrome.css and userContent.css files.
This bug also affects new profiles created with the profile manager.

Cross-ref: Bug 270132 which reports an earlier problem with the *-example.css files not being present by default in the chrome folder. A fix to this bug might also fix Bug 270132.
 I also see this with profiles created by recent trunk builds (e.g. 3 alpha 1 (20060912)). Confirming and making the reasonable assumption that this affects all platforms on trunk. Seems to me to be a Preferences issue rather than an Installer issue.
Status: UNCONFIRMED → NEW
Component: Installer → Preferences
Ever confirmed: true
OS: Windows XP → All
QA Contact: installer → preferences
Hardware: PC → All
Summary: Installer for 1.5.0.2 will not create chrome sub-folder in Profile folder. → Profile folder's Chrome sub-folder not created by default
Version: 1.5 → Trunk
Assignee: mscott → nobody
Duplicate of this bug: 438248
still reproduces in v3.1
Blocks: 270132
wontfix per standard8
"The chrome folder isn't going to be used by the vast majority of users, unless they come across one of the hacks that require the folder and files - at which point I'm sure the hacks will explain. "

(not a dup of bug 270132)
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
See Also: → 270132
You need to log in before you can comment on or make changes to this bug.