Last Comment Bug 336244 - Clean up/remove extensions/xmlextras/base
: Clean up/remove extensions/xmlextras/base
Status: RESOLVED FIXED
[need testcase]
: fixed1.8.1.8
Product: Core
Classification: Components
Component: XML (show other bugs)
: Trunk
: All All
: P4 minor (vote)
: mozilla1.9alpha1
Assigned To: Peter Van der Beken [:peterv]
: Ashish Bhatt
: Andrew Overholt [:overholt]
Mentors:
: 336821 (view as bug list)
Depends on: 324865 378533
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-02 05:56 PDT by Frank Wein [:mcsmurf]
Modified: 2007-10-05 03:29 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (16.21 KB, patch)
2006-05-08 08:53 PDT, Peter Van der Beken [:peterv]
jonas: review+
jonas: superreview+
dveditz: approval1.8.1.8+
Details | Diff | Splinter Review
Removes xmlextras.xpt from project and converts it to Xcode 1.x (35.11 KB, patch)
2006-05-24 23:14 PDT, Smokey Ardisson (offline for a while; not following bugs - do not email)
no flags Details | Diff | Splinter Review
unbitrotten version of attachment 223263, as checked in on MOZILLA_1_8_BRANCH (17.47 KB, patch)
2007-10-03 16:19 PDT, Matthew (lilmatt) Willis
no flags Details | Diff | Splinter Review

Description Frank Wein [:mcsmurf] 2006-05-02 05:56:39 PDT
It looks like extensions/xmlextras/base can be cvs removed (since Bug 324865 was fixed), it's not used anymore. Also the references to the old Makefiles in allmakefiles.sh should be removed.
Comment 1 Peter Van der Beken [:peterv] 2006-05-05 16:29:07 PDT
*** Bug 336821 has been marked as a duplicate of this bug. ***
Comment 2 Peter Van der Beken [:peterv] 2006-05-08 08:53:57 PDT
Created attachment 221306 [details] [diff] [review]
v1
Comment 3 Jonas Sicking (:sicking) No longer reading bugmail consistently 2006-05-08 13:55:10 PDT
Comment on attachment 221306 [details] [diff] [review]
v1

r+sr=me
Comment 4 Peter Van der Beken [:peterv] 2006-05-21 14:06:02 PDT
Looking for some help removing xmlextras.xpt from mozilla/embedding/tests/cocoaEmbed/CocoaEmbed.pbproj/project.pbxproj. I don't have the right version of XCode.
Comment 5 Smokey Ardisson (offline for a while; not following bugs - do not email) 2006-05-24 23:14:43 PDT
Created attachment 223263 [details] [diff] [review]
Removes xmlextras.xpt from project and converts it to Xcode 1.x

Håkan asked me to do this since I've been kicking the Camino project file for checkins lately.

Note, however, that the CocoaEmbed.pbproj file was still a 10.2 Project Builder file, so in addition to removing the file, this patch also upgrades it to Xcode 1.x format (10.3.9/Xcode 1.5 is the minimum requirement for the trunk now, anyway).  Untested.
Comment 6 David Baron :dbaron: ⌚️UTC-8 2006-09-13 14:03:33 PDT
Hrm.  I should have landed this on the 1.8 branch when I landed bug 324865, shouldn't I?
Comment 7 Steffen Wilberg 2007-05-01 08:27:49 PDT
(In reply to comment #6)
> Hrm.  I should have landed this on the 1.8 branch when I landed bug 324865,
> shouldn't I?
Is it too late to do so? Firefox currently has xmlextras.xpt listed in both packages-static and removed-files.in on the 1.8 branch now...
Compare:
http://mxr.mozilla.org/mozilla1.8/search?string=xmlextras.xpt
http://mxr.mozilla.org/mozilla/search?string=xmlextras.xpt
Also see bug 378533 comment 0.
Comment 8 Matthew (lilmatt) Willis 2007-08-06 19:29:40 PDT
Comment on attachment 221306 [details] [diff] [review]
v1

I'd like to see this on the 1.8 branch.  It's valid cleanup, cuts down on error spew in tinderbox logs and stats, and it would reduce the number of merges I have to keep track of.

-> a1817?
Comment 9 Daniel Veditz [:dveditz] 2007-08-29 15:33:24 PDT
Comment on attachment 221306 [details] [diff] [review]
v1

approved for 1.8.1.7, a=dveditz for release-drivers
Comment 10 Daniel Veditz [:dveditz] 2007-10-03 10:28:20 PDT
Comment on attachment 221306 [details] [diff] [review]
v1

Removing month-old approval, we're hitting the release code-freeze.
Comment 11 Matthew (lilmatt) Willis 2007-10-03 16:19:54 PDT
Created attachment 283459 [details] [diff] [review]
unbitrotten version of attachment 223263 [details] [diff] [review], as checked in on MOZILLA_1_8_BRANCH
Comment 12 Daniel Veditz [:dveditz] 2007-10-03 20:00:51 PDT
Comment on attachment 221306 [details] [diff] [review]
v1

Check-in buddy found before the actual freeze, this is OK to land.
Comment 13 Tony Chung [:tchung] 2007-10-05 03:29:53 PDT
Can we get a testcase for this to verify?  if this is code cleanup only, can the reporter please verify it and mark the keyword to verified1.8.1.8?   Thanks.

Note You need to log in before you can comment on or make changes to this bug.