Infobar not tall enough

RESOLVED FIXED in mozilla1.8.1beta1

Status

()

RESOLVED FIXED
13 years ago
7 years ago

People

(Reporter: bzbarsky, Assigned: enndeakin)

Tracking

({fixed1.8.1})

Trunk
mozilla1.8.1beta1
x86
Linux
fixed1.8.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

[putting in General because I have no idea where this should go; triage help wanted]

BUILD: MOZ_CO_DATE="Tue May 2 14:01:07 CDT 2006" Linux Firefox trunk build

STEPS TO REPRODUCE:

1)  Make sure mozdev.org is no in the XPI whitelist
2)  Load http://adblockplus.mozdev.org/installation.html
3)  Click the "Install Adblock Plus 0.7" link.
4)  Watch the yellow infobar appear

EXPECTED RESULTS: infobar is tall enough for its text.

ACTUAL RESULTS: infobar text is cut off at the bottom.

Screenshot coming up.
I'd really like to see this fixed for the Gecko alpha...
Flags: blocking1.9a1?
*** Bug 335215 has been marked as a duplicate of this bug. ***
I think Rob Strong's Toolkit: XUL Widgets for bug 335215 was a reasonable choice.

I can't quite manage to reproduce this, since Ubuntu doesn't ship with a Gnome theme that has short enough buttons: it looks like the bar gets its height from the button height, so the worst I can get is part of the descenders on a second line cut off. However, cross-platform, with a small enough window to wrap to three lines the bottom one gets cut off.
Component: General → XUL Widgets
Product: Firefox → Toolkit
QA Contact: general → xul.widgets
I guess toolkit's right if this thing lives in the tabbrowser binding.  Not sure where it's defined.
Oh, sorry: it's probably a regression from bug 268590, so the patch there will tell you where it lives.
Flags: blocking-firefox2?

Updated

13 years ago
Assignee: nobody → enndeakin
Flags: blocking-firefox2? → blocking-firefox2+
Target Milestone: --- → mozilla1.8.1beta1
(Assignee)

Comment 7

12 years ago
Created attachment 222029 [details] [diff] [review]
Move overflow from stack to notification
Attachment #222029 - Flags: first-review?(mconnor)

Updated

12 years ago
Attachment #222029 - Flags: first-review?(mconnor)
Attachment #222029 - Flags: first-review+
Attachment #222029 - Flags: approval-branch-1.8.1+
(Assignee)

Comment 8

12 years ago
Checked into trunk

Comment 9

12 years ago
should this be marked fixed now?

Updated

12 years ago
Whiteboard: [needs branch landing]
Neil, can you land this on the branch ASAP?
(Assignee)

Comment 11

12 years ago
Fixed for 1.9 and 1.8
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Sparky is showing a clear 50ms increase in Ts due to this patch.

http://build-graphs.mozilla.org/graph/query.cgi?testname=startup&units=ms&tbox=sparky.office.mozilla.org_MOZILLA_1_8_BRANCH&autoscale=1&days=7&avg=1&showpoint=2006:06:09:09:08:08,2543
Keywords: fixed1.8.1
Whiteboard: [needs branch landing]
Flags: blocking1.9a1?

Updated

7 years ago
Depends on: 668500
You need to log in before you can comment on or make changes to this bug.