Closed Bug 338254 Opened 16 years ago Closed 15 years ago

When closing tabs, the close buttons don't always come back (per min clip width pref)

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 2 beta2

People

(Reporter: chriszs, Assigned: mano)

References

Details

(Keywords: fixed1.8.1, polish, Whiteboard: see bug 343585)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a2) Gecko/20060512 BonEcho/2.0a2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a2) Gecko/20060512 BonEcho/2.0a2

When opening many tabs 2.0 Alpha 2 changes the tab close button to be the current tab only. The problem is that this switchover starts for me when I open 8 tabs, but doesn't change back to all tabs until 6 tabs. The behavior should be consistent, it should switch to currently selected tabs at 8 and all tabs at 7.

Reproducible: Always

Steps to Reproduce:
1. Open 7 tabs. Note that tab close buttons are on every tab.
2. Open 1 more tab. Note that tab close button is only on currently selected tab.
3. Close 1 tab. Note that tab close button is still only on currently selected tab, despite now having the same number of tabs as in step 1.
4. Close 1 more tab. Note that tab close buttons are now on every tab.
Actual Results:  
The point at which the close button is on every tab varies. Before opening 8 it is 7, after it is 6.

Expected Results:  
The point at which the close button is on every tab should always be the same. If I open 8 tabs it should make the switchover at 8 and go back at 7.

I quote specific numbers of tabs here, but it is very possible this varies based on screen size/resolution. When reproducing try seeing where this hand off occurs for you, instead of taking my numbers as gospel.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060516 Minefield/3.0a1
I see that, too, but only if the selected tab is not the first.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This might be fixed by bug 337514.
Depends on: 337514
(In reply to comment #2)
> 
That's an easy one to try out, but no, it does not fix it.
Thanks for testing.
No longer depends on: 337514
(In reply to comment #1)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060516
> Minefield/3.0a1
> I see that, too, but only if the selected tab is not the first.
> 

For 2.0 Alpha 2 it occurs regardless of which tab is selected.
Just downloaded the latest trunk nightly and got the same behavior.
*** Bug 344193 has been marked as a duplicate of this bug. ***
Assignee: nobody → sspitzer
Flags: blocking-firefox2?
Summary: at 8 tabs close button changes to current tab only, changes back to all at 6 → When closing tabs, the close buttons don't always come back (per min clip width pref)
Target Milestone: --- → Firefox 2 beta2
*** Bug 344460 has been marked as a duplicate of this bug. ***
I don't think this is worth blocking on - it's a nice polish thing to get right, though, so if we get a small, safe, baked patch please nominate for approval1.8.1
Flags: blocking-firefox2? → blocking-firefox2-
Keywords: polish
My patch for bug 343585 is going to fix this, i think.
Assignee: sspitzer → bugs.mano
Whiteboard: see bug 343585
Fixed in bug 343585.
Status: NEW → RESOLVED
Closed: 15 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.