Unusable Message compose window stays open after sending message when Cygwin X-Server is running

RESOLVED DUPLICATE of bug 347693

Status

RESOLVED DUPLICATE of bug 347693
13 years ago
9 years ago

People

(Reporter: moali, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Firefox version 1.5.0.2 (20060308)

An unusable (Window appears in the taskbar but cannot be closed and does not react on clicks with the right mouse button or any other action; the window cannot be displayed) Compose window keeps open after sending a message with Thunderbird for windows when the Cygwin [1] X-Server XWin.exe (with option -multiwindow) is running when opening the compose window.

Running the Hummingbird Exceed X-Server or Cygwins XWin without the "-multiwiondow" option does not result in malfunction.

The compose window is fully functional, the only malfunction is, that the window keeps present in the Windows taskbar.

The unusable compose window is closed when shutting down Thunderbird.

Operating System in use: Windows NT 4.0 SP6

[1] http://cygwin.com

Reproducible: Always

Steps to Reproduce:
1. start Cygwin X-Server with "XWin -multiwindow"
2. launch Thunderbird
3. compose and send a message
Actual Results:  
unusable compose window keeps present in the taskbar. See bug description

Expected Results:  
window should have closed after the message was sent.
(Reporter)

Comment 1

13 years ago
Sorry, the Thunderbird version did not appear in the bug report:

Thunderbird for windows version 1.5.0.2 (20060308)

Comment 2

13 years ago
xref bug 130572, bug 338331.
When the window's button is still visible in the task bar, does it have any 
text or icon?
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> xref bug 130572, bug 338331.
> When the window's button is still visible in the task bar, does it have any 
> text or icon?

Yes. Icon and text stay the same as they were when composing the message.

e.g.:
The icon with the pen and the sheet of paper, beside this the text "Compose: (no subject)"

While trying around a little bit, I figured out, that the problem seems only to appear when sending messages with the primary account.
(Reporter)

Comment 4

13 years ago
(In reply to comment #2)
> xref bug 130572, bug 338331.

While it seems, that the reporters of that bugs do not have X-Servers in use, for me this problem started appearing when switching from Hummingbird Exceed to Cygwins XWin. I did not encounter this problem before (Exceed or no X11 era).

But in common with the reporters I have Win NT 4.0 OS.

I can provide some additional version numbers:
Cygwin uses now x.org 6.8.2
Exceed 6.1

When shutting down the X-Server after the zombie windows has been created, X reports 0 connected clients and shuts down but the zombie window keeps alive.
Closing Thunderbird kills this window, too.
(Reporter)

Comment 5

13 years ago
I've figured our additional news.

(In reply to comment #2)
> xref bug 130572, bug 338331.
> When the window's button is still visible in the task bar, does it have any 
> text or icon?

The zombie window always shows the text "Compose: (no subject)", no matter what the subject of the actual message was.

When composing the message, the button in the taskbar shows the entered subject, but after having sent the message and the zombie window having appeared it shows (no subject)


In
Comment #3 From moali@sbox.tugraz.at  2006-05-23 22:51 PDT
I wrote, that it seems only to appear for the primary accont. As my current investigations brought up, this statment seems to be wrong.
By now it looks like that the window appears when sending the _second_ message. No matter with which account; Even mixing (first message with account 1 and second with account 2) seems to produce that window.

Sorry for the wrong information.

Comment 6

12 years ago
*** Bug 358644 has been marked as a duplicate of this bug. ***
suggest you try trunk build from http://www.mozilla.org/developer/#builds and report back
QA Contact: message-compose
(In reply to comment #5)
> The zombie window always shows the text "Compose: (no subject)",
> no matter what the subject of the actual message was.

Same phenomenon as Bug 347693 and bugs listed in Dependency tree for Bug 347693 (Most frequent case seems to be Bug 380275.)
And, if compose window is minimized or hidden after send request, and if problem of
zombie compose window occurs, I think that phenomena becomes no window display on desktop and the zombie window at task bar only.
reporter em address is dead.
duping to bug 347693
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 347693
You need to log in before you can comment on or make changes to this bug.