Can't unsubscribe from RSS feed (due to unescaped urls).

RESOLVED FIXED in Thunderbird 13.0

Status

MailNews Core
Feed Reader
P4
major
RESOLVED FIXED
11 years ago
10 months ago

People

(Reporter: Nebu Pookins, Unassigned)

Tracking

Trunk
Thunderbird 13.0
Bug Flags:
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 705504/bug 709247/bug 711173])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla Thunderbird 1.5.0.2 (20060308)

I have this RSS feed that I can't unsubscribe to. If I right click on my RSS folders and choose "Manage Subscriptions...", locate the feed, and click "Remove", it disappears from that window. I then click on the "X" in the top right corner to close the window. I then right click on the RSS folders and choose "Manage Subscriptions..." again, the feed is there again.

Reproducible: Always

Steps to Reproduce:
See details above.
Actual Results:  
See details above.

Expected Results:  
I expected the feed to actually be removed. Perhaps if there was an "OK" button or something to click to confirm that my changes will be saved, instead of clicking the X, I'd be less confused.
(Reporter)

Comment 1

11 years ago
I just updated to version 1.5.0.4 (20060516) and the bug is still present. I'm currently subscribed the feed URL is "http://www.gizmodo.com/index.xml" and the name is "(null)". No matter how many times I remove the feed, it always reappears.

Comment 2

11 years ago
I have the same behaviour using 1.5.0.4 on Windows 2000.

Manage subscriptions->Click on RSS feed->Click Remove.
RSS feed disappears, close window.

Manage subscriptions->RSS feed is back, but "Title" field is missing. Location field is still as before.

If I restart Thunderbird the feed is back with Title/Location fields back to normal.

Comment 3

11 years ago
I have had unescaped chars in RSS URLs causing this problem.
e.g. unescaped '|' in URL 'splits' the URL into two feeds, neither
of which will go away unless I delete them AND the RSS folder.

Reproducable:
Enter following URL as RSS feed...
http://www.friday-ad.co.uk/RssID/2508200611194241/Editions/E|Hastings|A,C,B,D,L/SArea/surrounding/Keywords/nipper+double/Web/rssFeeds.rss
Generates 3 'feeds', seeming split on the '|' char.


Repeatable: Every time.

Comment 4

11 years ago
i can confirm this behavior for thunderbird version 1.5.0.8 (20061203) on AMD64

slashdot recently changed their rss feed url from 
http://slashdot.org/rss/index.rss
to
http://rss.slashdot.org/Slashdot/slashdot

i have tried unsubscribing from the feed via the "manage subscriptions" window.  as a result, the latter of those feed urls appears in my feeds.rdf file, while the former does not.  but every time i close and open the "manage subscriptions" window, both links are listed.

possible causes that i can think of: 
* there are still items in my feeditems.rdf file which correspond to the old feed url
* there is one line in Slashdot.msf that contains both urls: 
<(CAE7=8251)(DADF=261f)(DAE0=c93817)(DADB=452d481b)(CAFC
    =http://slashdot.org/rss/index.rss|http://rss.slashdot.org/Slashdot/slashd\
ot)(DAB4=Wed Oct 11 10:33:29 2006)>

please reply if you know whether manually editing Slashdot.msf (to remove the old feed url) will screw things up.  

Comment 5

11 years ago
I'm confirming this based on comment 3; that URL still produces the problem.  Comment 1 seems to be a similar situation, but I can't get into that state using the given feed URL.

I suspect comment 4 is a different bug.  I can't reproduce that either, perhaps because there are no items being served now from the old feed.

Ian, if you haven't already fixed this, I would try deleting all the old feed items, compacting the folder, then deleting the .MSF file (or, if you're using 2b1/3a1, using Rebuild Index from the folder's Properties dialog).  I'd like to know if that change allows you then to unsubscribe successfully.  If not, then manually editing feeditems.rdf might be necessary.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [STR in comment 3]
Version: unspecified → Trunk

Comment 6

11 years ago
(In reply to comment #5)
> Ian, if you haven't already fixed this, I would try deleting all the old feed
> items, compacting the folder, then deleting the .MSF file (or, if you're using
> 2b1/3a1, using Rebuild Index from the folder's Properties dialog).  I'd like
> to know if that change allows you then to unsubscribe successfully.

Actually, you don't have to; I just checked this.  Rebuild Index in fact doesn't remove the feed info from the , but deleting the MSF and having it rebuild does.  Conversely, if you delete an MSF for a file that *has* a feed, you lose the feed data.

Comment 7

11 years ago
I also have similar problem for Thunderbird version 2.0.0.0 (20070326).
Symptoms:
1) I opened "News and blogs" -> "Manage subscriptions"
2) Chose folder with RSS feed I wanted to unsubscribe and expanded it
3) Selected RSS feed and clicked "Remove"
4) Answered "Yes" in the confirmation dialog
5) RSS feed was still presented in the list

Just after I closed "RSS subscriptions" window and opened it again I found feeds to be removed.

Comment 8

11 years ago
Is this a complete inability to remove/delete/unsubscribe from RSS feeds in Thunderbird? I experienced this behaviour with Thunderbird 1.5.0.x

Comment 9

10 years ago
I would guess that the Thunderbird 2 issue (comment 7), which I am experiencing and can reproduce 100%, is not the same as the original report in this bug. I've filed bug 380406 for it.

Comment 10

10 years ago
xref bug 375745, which has been fixed on trunk and for the next TB 2.0.x release.  That problem may address some of the problems reported here.

I confirmed this bug based on comment 3, which provided as an example a feed URL with a very specific issue; that URL is no longer valid, so I can't say whether it still applies.

Comment 11

9 years ago
This issue still occurs for me on OS X latest nightly.
Setting wanted, this looks like a simple unescape/escape fix.
Flags: wanted-thunderbird3+
Priority: -- → P4
Summary: Can't unsubscribe from RSS feed. → Can't unsubscribe from RSS feed (due to unescaped urls).
Target Milestone: --- → Thunderbird 3.0rc1
Assignee: mscott → nobody

Comment 13

9 years ago
I can't unsubscribe from RSS feed (feed URL is without special chars - Location: 'http://www.aaaaaa.aa/rss/rss-aaaa.php')

After I remove the feed, then close and open RSS window again, removed feed is in the list again, but without title.
After restarting Thunderbird, title of the removed feed goes back.

The bug is still present in Thunderbird version: 2.0.0.17.

How can I remove feed manually (e.g. from some configuration file) until the problem will be solved?

Updated

8 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core

Updated

8 years ago
Duplicate of this bug: 533863

Comment 15

8 years ago
I am also suffering from this issue. It has been there since TB2 and TB3 still has it.

Whenever I try to delete a RSS subscription,
a) the link is removed, but reappears when I restart TB
b) the link won't go away despite pressing remove several times

The feed is still flooding my inbox, and I would like to get some help.

Thank you all for your dedicated support!

Comment 16

7 years ago
I am also having this problem on Thunderbird 3.0.6 running Ubuntu.  The RSS URL I am having trouble with has no special characters: http://www.smbc-comics.com/rss.php

In addition to the above mentioned removal attempts, I have tried editing feeds.rdf and feeditems.rdf to remove all mention of this URL.  This also seems to have no effect.

Thanks.

Comment 17

7 years ago
I'm running Thunderbird 3.1.6 on Windows Xp and also without any special characters - simply can't remove a url from my feeds.

(In reply to comment #16)
> I am also having this problem on Thunderbird 3.0.6 running Ubuntu.  The RSS URL
> I am having trouble with has no special characters:
> http://www.smbc-comics.com/rss.php
> 
> In addition to the above mentioned removal attempts, I have tried editing
> feeds.rdf and feeditems.rdf to remove all mention of this URL.  This also seems
> to have no effect.
> 
> Thanks.

Comment 18

7 years ago
I have some RSS feeds I have been unable to remove. I get the following message in my error console when I try to remove one of them:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIRDFDataSource.Unassert]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger-newsblog/content/utils.js :: deleteFeed :: line 127"  data: no]

I'm currently using Thunderbird 3.1.6 on Windows 7, but the problem isn't new.

Comment 19

6 years ago
Same here on TBird 7.0.1 Can't believe this bug has been present for so long…

Hope it gets fixed soon though.

Comment 20

6 years ago
there are a number of paths to getting the 'unremovable feed' in the Subscribe dialog.  they are fixed by bug 705504/bug 709247/bug 711173.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Duplicate of this bug: 340913

Updated

6 years ago
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: [STR in comment 3] → [fixed by bug 705504/bug 709247/bug 711173]
Target Milestone: Thunderbird 3.0rc1 → Thunderbird 13.0

Comment 22

6 years ago
This is quite bad - I'm thinking about complete reinstall of Thunderbird as I can't resolve this...

Comment 23

4 years ago
Well I "HAD" the same Issue as you guys,
Every time I deleted the feed, and emptied the trash, it would return the next time Thunderbird was launched.

The Steps I took Below Removed the Feed.

a) Close Thunderbird

b) Go To:

C:\Users\XXXX\AppData\Roaming\Thunderbird\Profiles\enlzudmi.default\Mail\Feeds

(XXXX = Your Username.)

c) Once in the Feeds Folder, Delete the Feed there.

It's Now Gone for Good !!

NOTE:
If you Can't Get to this Folder:
You need to Change your Windows Setup to Show Hidden Files and Folders.

Go to Control Panel and click on (Folder Options)
Click View - Click SHOW Hidden Folders and Drives.

Then Follow the Steps Above.

St0ney

Comment 24

2 years ago
The above solution from St0ney worked for me because I had the same issue, Every time I tried to deleted the feed, it would reload the next time Thunderbird was launched and I it send me to my main page http://carownerstips.co.uk/

I applied the suggestions and it worked for me.
Comment hidden (spam)

Comment 26

10 months ago
Again I have experienced the same issue with our new site. We tried to create a new feed for the site and since it's a kind of one page site, the feed does not work fine. Once I reload it it would send me back to the home page http://carfinancebees.co.uk/

This time the solution is not working, could anyone help me out here?
You need to log in before you can comment on or make changes to this bug.