Safebrowsing: 'Get me out of here' should go to the default home page

VERIFIED FIXED in Firefox 2

Status

()

Toolkit
Safe Browsing
P1
enhancement
VERIFIED FIXED
12 years ago
4 years ago

People

(Reporter: u88484, Assigned: Gavin)

Tracking

({verified1.8.1})

2.0 Branch
Firefox 2
verified1.8.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
When you come upon a phishy site, the 'Get me out of here' link should do something different. Throwing out some ideas here:

- Take you to www.google.com or www.mozilla.com if only one tab open
- close the tab and focus on tab you came from if more then one tab open
- Take you back as if the back button was hit
   - if you didn't come from anywhere (ex opened the link in a new tab) close the tab
     - if that was the only tab open then load google.com or www.mozilla.com
- Would say load the homepage but for people that have multiple that would open a few tabs which would be annoying. (currently something like this happens but only the first tab is loaded with the same text as in the tools->options->general->'location(s)' shows)

Hmm too many ifs. Guess you should just be taken to google.com or mozilla.com
Why are google.com or mozilla.com more relevant than your homepage?

I do think it would be a good idea to just close the tab if the load was in a new tab and there is no session history.
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Why are google.com or mozilla.com more relevant than your homepage?
> 

Was just throwing out ideas based on thats what happens now but with a bug with people with multiple homepages.

> I do think it would be a good idea to just close the tab if the load was in a
> new tab and there is no session history.
> 
Thats what I would like to see but figured it'd make things too complicated with coding for :
- What if only one tab open?
- What if more then one tab open? Focus tab you came from, tab on left? 
- What if no session history?

Comment 3

12 years ago
I'm not sure how loading the homepage is useful when you hit a phishing site. Why not (1) close tabs with the phishing site being the only entry (as Gavin suggested, but making sure that at least a blank tab remains in the window) and (2) navigate back in history otherwise (where you came from, probably the most relevant page, and you won't risk any dataloss through a closed tab)?

Alternatives coming to mind:
* Just blank the page (replacing the page with about:blank)
* Reword "Get me out of here" to "Close this tab" (though a rewording would probably be in order anyway)
(Reporter)

Comment 4

12 years ago
I think a blank tab would leave the user with a blank stare at the screen. Also, 'Get me out of here' sounds great, no need to change that.
It should really take the user to the localized Firefox Start page.
(Reporter)

Comment 6

12 years ago
Mike, I believe your bug will take care of this so marking this one as the dupe.

*** This bug has been marked as a duplicate of 343084 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Actually, it doesn't, but it still should. We can make that change after beta1.
Status: RESOLVED → REOPENED
Flags: blocking-firefox2+
Resolution: DUPLICATE → ---
Target Milestone: --- → Firefox 2 beta2
(Reporter)

Comment 8

12 years ago
(In reply to comment #7)
> Actually, it doesn't, but it still should. We can make that change after beta1.
> 

ah ok, I thought that the "point to mozilla.com anti-phishing FAQ pages" part of the bug was covering this. sorry about that
(In reply to comment #3)
> I'm not sure how loading the homepage is useful when you hit a phishing site.
> Why not (1) close tabs with the phishing site being the only entry (as Gavin
> suggested, but making sure that at least a blank tab remains in the window) and
> (2) navigate back in history otherwise (where you came from, probably the most
> relevant page, and you won't risk any dataloss through a closed tab)?
> 
> Alternatives coming to mind:
> * Just blank the page (replacing the page with about:blank)
> * Reword "Get me out of here" to "Close this tab" (though a rewording would
> probably be in order anyway)
> 

good choices but order is incorrect.

Navigate back if possible should be the first choice.

Then comes what to do if the back history is empty.  If multiple tabs/windows are open then a close seems correct.  Then the case for a single window with a single tab open and no back history becomes the only condition for which something arbitrary needs to be done.

Updated

12 years ago
Blocks: 344029

Comment 10

12 years ago
(In reply to comment #5)
> It should really take the user to the localized Firefox Start page.
> 

Actually, it should just throw up a message like "This will close the window (or tab) you are in and restart the browser with the remaining tabs open." and then do that. 
beltzner, what are we doing with this?
Assignee: nobody → beltzner
Status: REOPENED → NEW
Whiteboard: [at risk]
It should go to Firefox Start.
Firefox Start? or your homepage?
Keywords: uiwanted
Whiteboard: [at risk]
Sorry, I'll be clearer:

 - if there's back history, go back one page
 - if not, then
     - if there's no other tabs open, go to Firefox Start
     - if there are other tabs open, close the offending tab

But if all that's too complicated or adds too many cases for us to be QAing at this late stage, then just always go to Firefox Start and be done with it.
Assignee: beltzner → nobody
Keywords: uiwanted
Moving out to Fx3
Flags: blocking-firefox2+ → blocking-firefox2-

Comment 16

12 years ago
I agree with Mike Beltzer. However, if you're going to push this back to Firefox 3, you still can't keep the current behaviour because it is bugged. See: https://bugzilla.mozilla.org/show_bug.cgi?id=344029

Comment 17

12 years ago
I would go for the "Take you back as if the back button was hit
   - if you didn't come from anywhere (ex opened the link in a new tab) close
the tab"
After talking with Gavin, and despite feeling that some optimizations could exist for this behaviour based on the premise that the vast majority of phishing links come from email links out of web or desktop apps, we both feel that a single, dependable, always predictable outcome is the best option here.

So "Get me out of here" ---> Firefox Start
Created attachment 235446 [details] [diff] [review]
patch

Go to the default home page (which is Firefox Start for builds with official branding), per comment 18.
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #235446 - Flags: review?(mconnor)
Priority: -- → P1
Hardware: PC → All
Summary: Safebrowsing: 'Get me out of here' should do something different → Safebrowsing: 'Get me out of here' should go to the default home page
Target Milestone: Firefox 2 beta2 → Firefox 2
Version: unspecified → 2.0 Branch
Whiteboard: [patch-r?]
Comment on attachment 235446 [details] [diff] [review]
patch

shazam!
Attachment #235446 - Flags: review?(mconnor) → review+
Whiteboard: [patch-r?] → [checkin needed]
Attachment #235446 - Flags: approval1.8.1?
Whiteboard: [checkin needed] → [checkin needed] [a?]
browser/components/safebrowsing/content/phishing-afterload-displayer.js 1.13
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed] [a?] → [a?]

Updated

12 years ago
Whiteboard: [a?] → [schrep-181approval pending]

Comment 22

12 years ago
Comment on attachment 235446 [details] [diff] [review]
patch

a=schrep/beltnzer for drivers.
Attachment #235446 - Flags: approval1.8.1? → approval1.8.1+
mozilla/browser/components/safebrowsing/content/phishing-afterload-displayer.js 	1.1.2.12
Keywords: fixed1.8.1
Whiteboard: [schrep-181approval pending]
Verified during Testruns on 1.8.1.1 on Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1 → verified1.8.1
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.