Closed Bug 339106 Opened 16 years ago Closed 15 years ago

integrate spellcheck into libxul

Categories

(Core :: Spelling checker, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: benjamin, Assigned: benjamin)

References

Details

Attachments

(1 file, 2 obsolete files)

Make spellcheck use frozen linkage, for ff+xr builds.
Depends on: 339144
Please don't freeze the current spellcheck API. The interface really really, um,  leaves things to be desired. 
Brett, frozen linkage has nothing to do with freezing APIs.
Sorry, I just came across this bug and got very worried :)
Or, now that all our major clients are using spellcheck, we should integrate it into libxul.
Summary: Make spellcheck use frozen linkage → integrate spellcheck into libxul
Attachment #230178 - Flags: review?(mark)
Attachment #230178 - Attachment is obsolete: true
Attachment #230179 - Flags: review?(mark)
Attachment #230178 - Flags: review?(mark)
Blocks: 345517
Comment on attachment 230179 [details] [diff] [review]
Oops, this is the right patch, rev. 1

Formerly, we'd build in extensions/spellcheck when it was in the MOZ_EXTENSIONS list.  I don't see where we build in extensions/spellcheck at all with this patch.
Yeah, there was an additional change to Makefile.in... I can't get to that machine right now from OSCON, but the change was of the form:

ifdef MOZ_SPELLCHECK
tier_50_dirs += extensions/spellcheck
endif
Comment on attachment 230179 [details] [diff] [review]
Oops, this is the right patch, rev. 1

Two module EPs in one module - while linking libspellchecker.dylib:

mozSpellCheckerFactory.o definition of _NSGetModule in section (__TEXT,__text)
mozMySpellFactory.o definition of _NSGetModule in section (__TEXT,__text)
Attachment #230179 - Flags: review?(mark) → review-
Attachment #230179 - Attachment is obsolete: true
Attachment #231414 - Flags: review?(mark)
Comment on attachment 231414 [details] [diff] [review]
extensions/spellcheck into libxul, rev. 2

Looks like you can cvs remove mozMySpellFactory too.
Attachment #231414 - Flags: review?(mark) → review+
Fixed on trunk
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Benjamin, do you plan to do this (or some part of it) for 1.8.1?  Right now, libmyspell/libspellchecker are among the only nonstatic components in a static build (the only other one is libxpinstall).
No, don't need/want to do this for 1.8.1
Duplicate of this bug: 224623
You need to log in before you can comment on or make changes to this bug.