Thunderbird assigns wrong To:/From:/Cc: headers when replying to email sent by me

RESOLVED DUPLICATE of bug 85296

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 85296
11 years ago
11 years ago

People

(Reporter: Trent Mick, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla Thunderbird version 1.5.0.2 (20060308)

Say you previously sent this email:

    To: friend@example.com
    From: me@example.com
    Subject: Here are some pics from my weekend

And, of course, you forgot to attach the pics. So you reply to your own email. In mutt and gmail when you reply to that email you get:

    To: friend@example.com
    From: me@example.com
    Subject: Re: Here are some pics from my weekend

In Thunderbird, when you “Reply All” you get these headers:

    To: me@example.com
    Cc: friend@example.com
    Subject: Re: Here are some pics from my weekend

That is just wrong. Even worse is when you just hit “Reply”:

    To: me@example.com
    Subject: Re: Here are some pics from my weekend


Reproducible: Always

Steps to Reproduce:
1. Do "Reply" or "Reply All" to an email that you sent yourself.



Expected Results:  
The headers as per mutt and gmail.
fixed for 2.0

*** This bug has been marked as a duplicate of 85296 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.