The default bug view has changed. See this FAQ.

Create mozilla.dev.mdc.es

RESOLVED FIXED

Status

mozilla.org
Discussion Forums
--
major
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Nukeador, Assigned: justdave)

Tracking

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.0.3) Gecko/20060523 Ubuntu/dapper Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.0.3) Gecko/20060523 Ubuntu/dapper Firefox/1.5.0.3

As the result of a volunteer request in the spanish mozilla community, we have more editors than before, so it would be nice to have a mail group in mozilla groups to organize ourselves better. We have too much to do to use only a discussion page to comment all the problems.

Reproducible: Always
Component: Infrastructure → Newsgroups
Product: Mozilla Developer Center → mozilla.org
Version: unspecified → other
QA Contact: infrastructure → server-ops
This has been outstanding for quite a while now, I'll try the server-ops queue to get some eyes on it.
Assignee: nobody → server-ops
Severity: minor → major
Component: Newsgroups → Server Operations
QA Contact: server-ops → justin
Foundation hasn't signed off on it yet, nothing for server-ops to do.
Assignee: server-ops → gerv
Component: Server Operations → Newsgroups
QA Contact: justin → justdave
Foundation approves new MDC-related mailing lists and groups?  I am excited to learn that!

Gerv: what do we have to do to get this moving along?
I guess we do have a hierarchy for mozilla.mdc, even though it's just two newsgroups. :)  It would make much sense to me to let the mdc folks manage that hierarchy (decision wise).  Say the word, Gerv, and I'll put it on record.
Mike: I think Dave just means that I have a sort of de facto control of the hierarchy, having driven the new newsgroup process. I don't think he's asserting that the Foundation is taking a micro-management approach to MDC.

To fit in with the existing hierarchy feel, how about:
mozilla.mdc.l10n.es ? That fits with the mozilla.dev.l10n.xx, but shows it's about l10n of mdc.

Gerv
(In reply to comment #5)
> Mike: I think Dave just means that I have a sort of de facto control of the
> hierarchy, having driven the new newsgroup process. I don't think he's
> asserting that the Foundation is taking a micro-management approach to MDC.

I had understood otherwise from conversations in IRC, but as long as whoever is responsible for approving the creation of needed groups is responsive, they can be as micro as they'd like! :)

> To fit in with the existing hierarchy feel, how about:
> mozilla.mdc.l10n.es ? That fits with the mozilla.dev.l10n.xx, but shows it's
> about l10n of mdc.

I was thinking that it would be mozilla.mdc.es, since the primary aspect is "discussion in Spanish about MDC" and not "discussion about the Spanish localization of MDC", but Deb's preference is my guide in such things.
OK, I've found the bug with the discussion - it's bug 331730.

Currently, we are due to create:
mozilla.languages.it.general
- i.e. we decided to give every language group their own hierarchy under mozilla.languages, to prevent namespace conflicts.

So that would suggest that the right name for this group would be:
mozilla.languages.es.mdc

Whatever we do, I want to do it consistently. So if mozilla.languages.es.mdc doesn't work for someone, it would help if they explained what consistent naming system they would use to accommodate future requests for language-specific versions of particular groups.

Gerv
I'd prefer something whereby the language-specialized groups sorted next to their English "parents" (assume a lexicographic sort).  I think that will make it more likely that people will find the group for their language, especially if they are not extremely strong in English.

mozilla.dev.mdc.espanol?  (We'd been omitting the "dev" part in previous examples, which we should return.)  I don't think we're especially likely to hit collisions between real language names and hypothetical subgroups like "IT" (though if we had a .dev.it group for information technology development discussions, I would probably look for a secluded bridge -- but that's another story!).
The mozilla.languages.* hierarchy seems like exactly the reverse way to effectively sort these groups.  If a group needs a non-English version, that non-English version should be easily found within the regular sort order of the groups.  So rather than mozilla.language.espanol.dev.mdc (to which the English mate should be mozilla.language.english.dev.mdc), the groups would be mozilla.dev.mdc and mozilla.dev.mdc.espanol (or mozilla.dev.mdc.es).  That way if someone is looking at mozilla.dev.mdc it's likely that they will notice the mozilla.dev.mdc.es, rather than having to sift through the mozilla.languages.espanol.* part of the hierarchy to see if there's an mdc-related group there.
Well, if both of you think that mozilla.languages is a bad idea, then it's not (quite) too late to reverse that decision. We've only created one group, and that was 24 hours ago in bug 331730.

Then we just have to decide whether we are going to use anglicised versions of language names, or ISO codes. Espanol is a fairly close approximation, but how do you do Chinese? ".jongguo"? I'd go for ISO codes; if foreign language speakers know any ASCII, it'll be the code for their country.

If deb and shaver want to confirm they'd prefer the other sort of hierarchy, let's create mozilla.dev.mdc.es and I'll go and sort out the mess in the other bug.

Gerv
Yeah, I just checked with Deb and we're both fine with mozilla.dev.mdc.es -- you're totally right about the language thing, and I forgot that we were really stuck with ASCII, because I'm not very smart.

I'll ass-u-me that we should just create other language subgroups as we see the need arise, following this model?

Thanks!
If we've agreed this is the model, then yes, let's create immediate language-specific subgroups throughout the tree as necessary.

However, we should try and keep proliferation down by starting with a single group in each "area" (e.g. development, l10n, mdc). So if some French people want to talk about DOM hacking, we start with mozilla.dev.general.fr rather than mozilla.dev.tech.dom.fr - and only fork if the traffic gets too high.

Shaver's the expert at getting newsgroup bugs resolved fast, but I'll start by assigning it to Dave. :-)

Gerv
Assignee: gerv → justdave
Summary: MDC-es in mozilla groups request → Create mozilla.dev.mdc.es
Mailing list has been created, and the admin password has been mailed to Deb.  Might be a good idea to get someone that's part of the Spanish localization to take over moderating it, feel free to pass the hat. :)  The mailing list will stay hidden until the newsgroup has been created.

Newgroup request has been sent to Giganews and Google.
Status: NEW → ASSIGNED
Whiteboard: waiting on Giganews/Google
This newsgroup now exists on both Giganews and Google now.  The mailing list has been made visible to the public.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Whiteboard: waiting on Giganews/Google
You need to log in before you can comment on or make changes to this bug.