Closed Bug 340752 Opened 18 years ago Closed 16 years ago

Undefined variable error in Makefile

Categories

(Calendar :: Build Config, defect)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mattwillis, Assigned: philor)

References

Details

(Keywords: fixed1.8.1.15)

Attachments

(1 file)

As a result of checkins from bug 334417 building Sunbird now gives the following error:

Unknown variable:calendar/sunbird/app/Makefile:293:     sed -e "s/@APP_VERSION@/$(APP_VERSION)/" -e "s/@APP_NAME@/$(APP_NAME)/" -e "s/@MAC_CREATOR_CODE@/$(MAC_CREATOR_CODE)/" $(srcdir)/macbuild/Contents/Info.plist.in > $(DIST)/$(APP_NAME).app/Contents/Info.plist

We need to define APP_VERSION in the makefile as SUNBIRD_VERSION
Not going to make the 0.3 train.
Target Milestone: Sunbird 0.3 → Sunbird 0.4
Nor 0.5
Target Milestone: Sunbird 0.5 → Future
Target Milestone: Future → Sunbird 0.7
Component: General → Build Config
QA Contact: general → build
Target Milestone: 0.7 → ---
Version: Trunk → unspecified
Assignee: lilmatt → nobody
the error still exists in 0.8pre but doesn't have too much impact. looks like the whole replacement line is no longer needed.
maybe someone with some understanding for mac OSX should comment on it...
I'm not sure what error you are still seeing (the only one I see is a failure to find and copy shlibsign and mangle during the Intel half of the build), but it shouldn't be this, which was fixed by bug 334417. If you were still seeing this, then rather than right-click, Get Info on the app bundle showing "Sunbird 0.8pre © 1998-2008 Contributors" in the version field, it would probably be "Sunbird @APP_VERSION@ © 1998-2008 Contributors" (or worse, depend on how badly it was blowing up).
i had a closer look now:
the error is caused by using autoconf-like variables for plaintext replacement. maybe someone intended to do the replacement in calendar/sunbird/app/macbuild/Contents/Info.plist.in as part of configure.
now there are these variable like strings left in Info.plist.in and Makefile.in and cause this error at configure time (btw., nothing is broken because of that...).
proposed fix to get rid of the error is to replace the according strings in Makefile.in and Info.plist.in
@SOME_VAR@ -> xxxSOME_VARxxx
or similar...
Oh, bug 383099. Comment 0 threw me off, making it sound like sed was failing to replace (which it probably was, too, but isn't now).
Blocks: 383099
Just a wild guess... but would a solution like in bug 414530 work?
Attached patch Fix v.1 — — Splinter Review
Oh, sort of approximately bug 414530, in that that's another bug where I said "you need to do the same thing as in bug 383099."
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #318551 - Flags: review?(lilmatt)
Comment on attachment 318551 [details] [diff] [review]
Fix v.1

r=lilmatt
Attachment #318551 - Flags: review?(lilmatt) → review+
calendar/sunbird/app/Makefile.in 1.60
calendar/sunbird/app/macbuild/Contents/Info.plist.in 1.14
calendar/sunbird/app/macbuild/Contents/Resources/English.lproj/InfoPlist.strings.in 1.4
calendar/sunbird/app/Makefile.in 1.21.2.23
calendar/sunbird/app/macbuild/Contents/Info.plist.in 1.5.2.9
calendar/sunbird/app/macbuild/Contents/Resources/English.lproj/InfoPlist.strings.in 1.1.2.4
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Keywords: fixed1.8.1.15
Resolution: --- → FIXED
Target Milestone: --- → 0.9
Comparing the 2008-05-02-19 build log file <http://tinderbox.mozilla.org/showlog.cgi?log=Sunbird-Mozilla1.8/1209782640.1209785873.7706.gz&fulltext=1> with the 2008-05-04-19 build log file <http://tinderbox.mozilla.org/showlog.cgi?log=Sunbird-Mozilla1.8/1209954540.1209957746.12754.gz&fulltext=1> I can verify that the error is gone. But I can't verify that the correct values have been written to the builds due to the lack of a mac system.
checked the replacements on the tinderbox. looks correct to me.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: