MailNews does not expand accounts anymore when double-clicking in the white space right of the account name

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: mcsmurf, Assigned: neil)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
To reproduce:
1. Fetch a trunk build of SeaMonkey (possibly Thunderbird works, too)
2. Open MailNews
3. Try expanding a account by double-clicking in the white space right of the account name in the left pane. If you don't have any closed tree/account, then click on the - to get a closed one to test.

Actual results:
MailNews seems to get a signal that the account expanded (for NNTP accounts you see "Checking newsgroup x of y on news.example.com" in the statusbar), but the tree (account with the folders/newsgroups) itself remains closed.

Expected results:
Expand the tree (account).

This worked fine with a build from 2006-06-06-10, but is broken with a build from 2006-06-07-09. This could be a fall-out from Bug 296040.
(Reporter)

Comment 1

12 years ago
Something else i also noticed: When clicking on a folder in MailNews, the whole row is now marked as selected (so the blue background expands over the white space up to where the pane ends on the right). With a build from the 6th only the background directly behind the name of the folder was marked with a blue background color when the folder was selected. I can file a new bug for this if you want to.

Comment 2

12 years ago
The problem is that the row doesn't get selected in "text" selection mode.
I think the double click handler in tree.xml should be reworked to count with it.
Status: NEW → ASSIGNED

Comment 3

12 years ago
Created attachment 224858 [details] [diff] [review]
patch
Attachment #224858 - Flags: superreview?(neil)
Attachment #224858 - Flags: review?(enndeakin)
(Reporter)

Updated

12 years ago
Blocks: 296040
Attachment #224858 - Flags: review?(enndeakin) → review+
(Assignee)

Comment 4

12 years ago
Comment on attachment 224858 [details] [diff] [review]
patch

You realise this regresses bug 130477, right?

Comment 5

12 years ago
thanks Neil, I'll try to solve it w/o regressing that bug

Updated

12 years ago
Attachment #224858 - Flags: superreview?(neil)

Comment 6

12 years ago
Is there any progress being made on this? It's been suggested that this bug is the preventing all keyboard access to the folderpane, until after a mouse click is done. See bug 343636, which still exists as of the Aug 9 nightly SeaMonkey build. :-(

Comment 7

12 years ago
Jan, are you able to give any attention to this major usability issue? It affects several other bugs.
Severity: normal → major
4 months with this regression; it really sucks that we don't chase these things down like we used to.
(Reporter)

Updated

12 years ago
OS: Windows 2000 → All

Comment 9

12 years ago
Neil in comment #4)
> (From update of attachment 224858 [details] [diff] [review] [edit])
> You realise this regresses bug 130477, right?

is it possible to land this and deal with regression of 130477 (which is the lesser of two evils) as a separate patch in due course?

Component: XP Toolkit/Widgets: Trees → XUL Widgets
Flags: review+
Product: Core → Toolkit
(Assignee)

Comment 10

11 years ago
Created attachment 275265 [details] [diff] [review]
Proposed patch

This patch is in two parts.
The first part is mailnews-specific and makes clicking in the folder pane select the row. This fixes the bug except when clicking under the columnpicker.
The second part makes it so that double-clicking in the space under the columnpicker toggles the open state as if it was on a non-cycler column.
Assignee: Jan.Varga → neil
Attachment #275265 - Flags: review?(mnyromyr)
Attachment #275265 - Flags: review?(enndeakin)
Neil, that patch surely works for me!  Thanks!
Attachment #275265 - Flags: review?(enndeakin) → review+

Comment 12

11 years ago
Comment on attachment 275265 [details] [diff] [review]
Proposed patch

But what about the visual *row* selection? I still think that just marking the text is not sufficient.
Attachment #275265 - Flags: review?(mnyromyr) → review+

Comment 13

11 years ago
(In reply to comment #12)
> (From update of attachment 275265 [details] [diff] [review])
> But what about the visual *row* selection? I still think that just marking the
> text is not sufficient. 
> 

That can be fixed in the theme iirc (yay, I thought it was just me with my mac that wanted it).
(Assignee)

Comment 14

11 years ago
Created attachment 275335 [details] [diff] [review]
Row selection (checked in)
Attachment #275335 - Flags: review?(mnyromyr)

Comment 15

11 years ago
Comment on attachment 275335 [details] [diff] [review]
Row selection (checked in)

This fixes the row selection issue - yay!
This leaves us with just bug 343636: the folderpane does not have the focus on MailNews start-up...
Attachment #275335 - Flags: review?(mnyromyr) → review+
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8pre) Gecko/200708060303 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

(In reply to comment #10)
> Created an attachment (id=275265) [details]
> Proposed patch
> 
> This patch is in two parts.
> The second part makes it so that double-clicking in the space under the
> columnpicker toggles the open state as if it was on a non-cycler column.

The first part was fixed by the "Row Selection" patch.

This second part was not.
In SM v1.0.9/v1.1.4, the space under the columnpicker did nothing on single/double click.
In the (new) current build, single clicking in that space selects the row.
Is the plan to add the double-clicking behaviour too, or let it be as it is now ?

Comment 17

11 years ago
> In SM v1.0.9/v1.1.4, the space under the columnpicker did nothing on
> single/double click.

That's not quite true: on branch, doubleclicking a folder row under the columnpicker opens a new mailnews main window.
Right, and it seems this behaviour did not regressed, then is still there.

I should have given more details:
*on a _folder_ line, double-clicking (anywhere) opens a new window, and does not (yet) toggle the open state.
*on an _account_ line, under the columnpicker, double-clicking (now) behaves like a single click.
(Assignee)

Comment 19

11 years ago
I've decided to fix the second part in a different way in bug 306990 instead.
I'm running the trunk (a few days old) with this bug's patches and LOVING it.
Thanks Neil.

Comment 21

11 years ago
Neil, thanks for taking this on.

Is this bug, and bug 340867, being looked at as strictly about suite?  Is a separate bug needed for Thunderbird?  Because 
- 340867 is definitely not fixed in thunderbird (should it be?), and 
- this patch affects thunderbird, but differently, oddly, compared to suite.

Thunderbird whitespace behavior
- account whitespace, click or double click - broken, only works if account is already selected (is this what you're attempting to fix in bug 306990?)
- folder whitespace 
  - single click - broken, does not select folder (14 months of ouch)
  - double click - collapses account (unexpected but like that behavior, but ...)
    - double click in any whitespace/any account - expands prior account
    - double click in any whitespace/any account - collapses prior account
(Assignee)

Comment 22

11 years ago
(In reply to comment #21)
>Is this bug, and bug 340867, being looked at as strictly about suite?
As far as I'm concerned yes, but 306990 will affect both products.

>Is a separate bug needed for Thunderbird?  Because 
>- 340867 is definitely not fixed in thunderbird (should it be?), and 
>- this patch affects thunderbird, but differently, oddly, compared to suite.
Which patch? The one I checked in was attachment 275335 [details] [diff] [review].
Attachment 275265 [details] [diff] would affect Thunderbird, but then so would bug 306990.

Comment 23

11 years ago
(In reply to comment #22)
> (In reply to comment #21)
> >Is this bug, and bug 340867, being looked at as strictly about suite?
> As far as I'm concerned yes, but 306990 will affect both products.
> 
> >Is a separate bug needed for Thunderbird?  Because 
> >- 340867 is definitely not fixed in thunderbird (should it be?), and 
> >- this patch affects thunderbird, but differently, oddly, compared to suite.
> Which patch? The one I checked in was attachment 275335 [details] [diff] [review].
> Attachment 275265 [details] [diff] would affect Thunderbird, but then so would bug 306990.

the broken behavior I see is from attachment 275265 [details] [diff] [review] checkin to folderpane on 08-05 - I see it  in thunderbird starting 08-06 nightly. As it only partly backs out varga's changes (afaict) it leaves thunderbird folder row selection still broken.


> Thunderbird whitespace behavior
> - account whitespace, click or double click - broken, only works if account is
> already selected (is this what you're attempting to fix in bug 306990?)
> - folder whitespace 
>   - single click - broken, does not select folder (14 months of ouch)
>   - double click - collapses account (unexpected but like that behavior, but
> ...)
>     - double click in any whitespace/any account - expands prior account
>     - double click in any whitespace/any account - collapses prior account

note - last two items only happen to the account that is currently selected
(Assignee)

Comment 24

11 years ago
(In reply to comment #23)
>the broken behavior I see is from attachment 275265 [details] [diff] [review]
But I didn't check that patch in...
(Assignee)

Comment 26

11 years ago
(In reply to comment #25)
>sorry, attachment 275335 [details] [diff] [review]
That's a SeaMonkey-only patch.

Updated

11 years ago
Flags: blocking1.9? → blocking-thunderbird3?

Comment 27

11 years ago
I filed bug 393711 for the thunderbird part.
If it will be fixed here, feel free to dupe it.
If not, let me know and I'll move the block flag to the new bug.
Blocks: 393711

Comment 28

11 years ago
Comment on attachment 275335 [details] [diff] [review]
Row selection (checked in)

This was checked in on 2007-08-05, so the actual bug here is fixed...
Attachment #275335 - Attachment description: Row selection → Row selection (checked in)
(In reply to comment #19)
> I've decided to fix the second part in a different way in bug 306990 instead.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8pre) Gecko/2007082302 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8pre) Gecko/2007082402 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

Confirming that bug 306990 comment 41 checkin fixed what I described here in comment 18.

Comment 30

11 years ago
WFM current trunk TB and SM : Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041201 SeaMonkey/2.0a1pre
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Flags: blocking-thunderbird3?
You need to log in before you can comment on or make changes to this bug.