Last Comment Bug 340827 - New ATK: Implement nsIAccessibleTable for all nsHTMLTableAccesible
: New ATK: Implement nsIAccessibleTable for all nsHTMLTableAccesible
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Mike Gao
:
Mentors:
Depends on: 340822
Blocks: newatk
  Show dependency treegraph
 
Reported: 2006-06-08 07:30 PDT by Aaron Leventhal
Modified: 2006-06-27 08:42 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch of this bug. (39.55 KB, patch)
2006-06-27 02:40 PDT, Mike Gao
aaronlev: review+
Details | Diff | Splinter Review
I think this patch is also necessary (2.43 KB, patch)
2006-06-27 03:03 PDT, Mike Gao
aaronlev: review+
Details | Diff | Splinter Review

Description Aaron Leventhal 2006-06-08 07:30:50 PDT
Remove the atk/nsHTMLTableAccessibleWrap code and move it to html/nsHTMLTableAccessible where all platforms can benefit from nsIAccessibleTable.
Comment 1 Mike Gao 2006-06-26 05:42:36 PDT
Will we remove all the codes in atk/nsHTMLTableAccessibleWrap.cpp and .h and remove the files also? 

I did so and is testing the code.
Comment 2 Aaron Leventhal 2006-06-26 05:55:07 PDT
(In reply to comment #1)
> Will we remove all the codes in atk/nsHTMLTableAccessibleWrap.cpp and .h and
> remove the files also? 
Those files will go away, and the code will move into the html directory as part of the nsHTMLTableAccssible class which already exists. The Wrap class will no longer be necessary.
Comment 3 Mike Gao 2006-06-26 09:19:09 PDT
I kept the wrap class just now. Will change the code again. 

how about class nsHTMLTableCellAccessibleWrap and nsHTMLTableHeadAccessible? remove nsHTMLTableCellAccessibleWrap and use nsHTMLTableCellAccessible instead when we need it?  nsHTMLTableHeadAccessible has many methods defined, should we keep this class?
Comment 4 Aaron Leventhal 2006-06-26 09:31:51 PDT
(In reply to comment #3)
> I kept the wrap class just now. Will change the code again. 
> 
> how about class nsHTMLTableCellAccessibleWrap and nsHTMLTableHeadAccessible?
> remove nsHTMLTableCellAccessibleWrap and use nsHTMLTableCellAccessible instead
> when we need it?  nsHTMLTableHeadAccessible has many methods defined, should we
> keep this class?
> 

We don't want any of the table-related Wrap classes anymore. All of the code should move to cross-platform classes. If there is already a cross platform class for that kind of table element, then merge the code. If there isn't a cross platform class then just move the class into the html directory but make sure it doesn't have "Wrap" in the name.

The idea is that we're going to use all of this stuff for all platforms, not just ATK. Originally we had it in Wrap classes in ATK because we only needed it there.
Comment 5 Mike Gao 2006-06-27 02:40:51 PDT
Created attachment 227211 [details] [diff] [review]
patch of this bug.
Comment 6 Mike Gao 2006-06-27 03:03:35 PDT
Created attachment 227213 [details] [diff] [review]
I think this patch is also necessary
Comment 7 Aaron Leventhal 2006-06-27 08:41:17 PDT
Comment on attachment 227211 [details] [diff] [review]
patch of this bug.

I added some tweaks to the patch:
1) Make Table accessible inherit from nsAccessibleWrap (it's not a hyper text, it can't have direct text children)
2) Don't create accessibles for thead/tbody/tfoot in ATK. At some point we'll need to create those for nsIAccessible, but trim them out in the final ATK tree.

Note You need to log in before you can comment on or make changes to this bug.