The default bug view has changed. See this FAQ.

Sidebar component throws exceptions and leaks install directory

RESOLVED FIXED

Status

SeaMonkey
Sidebar
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: dveditz, Assigned: dveditz)

Tracking

({fixed-seamonkey1.1a, fixed1.8.0.5})

1.8 Branch
fixed-seamonkey1.1a, fixed1.8.0.5
Bug Flags:
blocking-seamonkey1.0.3 +
blocking-seamonkey1.1a +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-seamonkey1.0.3)

Attachments

(1 attachment)

1023 bytes, patch
dveditz
: review+
dveditz
: superreview+
Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com]
: approval-seamonkey1.1a+
Details | Diff | Splinter Review
(Assignee)

Description

11 years ago
This bug is a placeholder for the Suite version of bug 268370, the only known instance of bug 267645 (leaking install directory via component exceptions). The Suite version of the Secunia advisory is http://secunia.com/advisories/20256/

The patch in attachment 224811 [details] [diff] [review] looks like it would apply to the xpfe/components/sidebar/src/nsSidebar.js copy without change.
(Assignee)

Comment 1

11 years ago
Presuming this should block the next SeaMonkey release
Flags: blocking-seamonkey1.0.3+
(Assignee)

Updated

11 years ago
Flags: blocking-seamonkey1.1a+
(Assignee)

Comment 2

11 years ago
Created attachment 226396 [details] [diff] [review]
merged firefox patch from bug 268370

Carrying over reviews and approval from Firefox equivalent bug, requesting approval for the SeaMonkey-only version.

I assume you guys might prefer this simple version on the 1.8 branch and trunk rather than Gavin's full "localize sidebar" patch from bug 338989 (which might not match the SeaMonkey sidebar), but if you want that instead--and have someone to do it--go ahead and deny approval for seamonkey1.1
Attachment #226396 - Flags: superreview+
Attachment #226396 - Flags: review+
Attachment #226396 - Flags: approval1.8.0.5+
Attachment #226396 - Flags: approval-seamonkey1.1a?
Attachment #226396 - Flags: approval-seamonkey1.0.3?

Comment 3

11 years ago
Comment on attachment 226396 [details] [diff] [review]
merged firefox patch from bug 268370

first a=me for 1.0.3

Comment 4

11 years ago
Comment on attachment 226396 [details] [diff] [review]
merged firefox patch from bug 268370

We sure want this version on 1.8.0 branch, need to discuss about 1.8 and trunk with other devs though...
Attachment #226396 - Flags: approval-seamonkey1.0.3? → approval-seamonkey1.0.3+
(Assignee)

Updated

11 years ago
Depends on: 268370
(Assignee)

Comment 5

11 years ago
Fix checked in to the 1.8.0 branch
Status: NEW → ASSIGNED
Keywords: fixed1.8.0.5
Whiteboard: fixed-seamonkey1.0.3
(Assignee)

Updated

11 years ago
Flags: blocking-seamonkey1.1a+ → blocking-seamonkey1.1a?
Comment on attachment 226396 [details] [diff] [review]
merged firefox patch from bug 268370

a=me for 1.1a
Attachment #226396 - Flags: approval-seamonkey1.1a? → approval-seamonkey1.1a+

Comment 7

11 years ago
Has this landed anywhere else then 1.8.0 branch?

If not, it probably should land on both trunk and 1.8 branch, so that the problem is fixed, we can always go and port a better solution later, if wanted/needed, right?
(Assignee)

Comment 8

11 years ago
This didn't land anywhere else pending some kind of decision on the 1.8/trunk fix and the fact that my default queries weren't looking for seamonkey-approved patches (sorry about that). I agree it's probably better to go ahead and land this rather than wait for something better to come along.

Comment 9

11 years ago
Dan, it's your patch, so could you please go ahead and check it in on both trunk and 1.1 branch?
We really want to have this fixed in upcoming releases.
Flags: blocking-seamonkey1.1a? → blocking-seamonkey1.1a+
(Assignee)

Comment 10

11 years ago
Fixed on 1.8 branch and trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed-seamonkey1.1a
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.