Problem Logging In and Resetting Password

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
13 years ago
3 years ago

People

(Reporter: bobk4653-tech, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Hi,

I was registering at http://addons.mozilla.org/ to comment about how much I like PwdHash.  Ironically, my PwdHash password was registered but I failed to logon.  What's interesting is the system accepted the password vDzmu1+w during registration and even sent it in an activation message to verify the account. So, I know the password is stored properly.  But, when I used that password to logon it fails.But, when I used that password to logon it fails. To duplicate this problem: 

1) Visit https://addons.mozilla.org/firefox/1033/

2) Click add your own comments 

3) Click create an account 

4) Enter the email address bobk4653-acct@yahoo.com and other contact data

5) Paste the following password twice: vDzmu1+w  

6) Check your email for an activation email from Mozilla 

7) Click the link to activate your account 

9) Try to logon, if it fails, that's the first piece of evidence. 


Reproducible: Always

Steps to Reproduce:
However, since, you can not duplicate the above after you've created the account, do the following to reset the password. 

10) Logout

11) Visit https://addons.mozilla.org/firefox/1033/ 

12) Click add your own comments 

13) Logon using your email address and another password to cause the logon to fail unless you already did this in step 9.

14) Click recover it

15) Enter your email address 

16) click the Recover Password button

17) Check your email and click the recovery link in the message

18) Paste the following password twice: vDzmu1+w  

19) Click Login to Mozilla Addons
Actual Results:  
Steps 11 to 19 a consistently fail to achieve logon. So far, only fails on the password vDzmu1+w using bobk4653-acct@yahoo.com.  If I create another one with a similar pattern it succeeds.  But, if I reset it using vDzmu1+w for bobk4653-acct@yahoo.com I can not logon.

Expected Results:  
Successful registration, logon, and resetting of password. 

For now, my work around is to user another password. 

Cheers, 
Bob K.
Group: security
Component: *.mozilla.org → Public Pages
Product: Websites → Update
QA Contact: other-mozilla-org → web-ui

Comment 1

13 years ago
Possibly related to or a dupe of Bug 332834?
I'm marking this invalid, since it was never confirmed.  Regardless, this should be fixed in the new site.  If you still have trouble with passwords or logging in, please open a new bug.  Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

12 years ago
I stopped using PwdHash to avoid this issue.
(Reporter)

Comment 4

12 years ago
I tested it again resetting the password with vDzmu1+w and it works now.
Resolution: INVALID → WORKSFORME
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.