Closed Bug 342564 Opened 15 years ago Closed 11 years ago

Cmd+Left and Cmd+Right behave inconsistently in designMode

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 289384

People

(Reporter: uriber, Unassigned)

References

()

Details

(Keywords: dataloss)

In design mode, the result of pressing Cmd+Left depends on whether there is a page to go back to (i.e., the "back" button is enabled):
- If there is a page to go back to, Cmd+Left navigates back in history (as on "normal" pages).
- Otherwise, Cmd+Left moves the caret to the beginning of the line (as in textareas and Editor).

Similarly, the behaviour of Cmd+Right depends on the availability of a forward history.

To reproduce:

- Click the link in the URL field of this bug so that it will open in the current tab/window.
- (optionally) Move the caret using the right-arrow key
- Press Cmd+Left, and notice you're back at this page.
- Now Cmd+Click the same link to open it in a new tab
- Move the caret using the right-arrow key
- Press Cmd+Left: The caret is moved to the beginning of the line; no navigation occures.
This affects SeaMonkey as well.
Component: Keyboard Navigation → Keyboard: Navigation
Product: Firefox → Core
QA Contact: keyboard.navigation → keyboard.navigation
No longer blocks: 341886
Blocks: 424615
Duplicate of this bug: 432119
Blocks: 405503
Duplicate of this bug: 434373
Duplicate of this bug: 443192
I just hit this five time in a row while trying to edit my WordPress theme :(
Keywords: dataloss
Duplicate of this bug: 511755
Duplicate of this bug: 553848
Every now and then this bug gets a dupe. 


I'd like to see the Cmd + Arrow actions configurable (like browser.backspace_action).
Well, due to a serious bug in Snow Leopard that left me with no wifi I just went back to Windows and life is good again.

Still, would definitely be nice if we could have a user-centered cycle like Ubuntu once tried with Gnome. So that we would not only get a brand spanking new JS engine that beats everyone else on the block in JS tests, but see a few UI glitches resolved too :-)
This only seems to occur inside certain text areas, GMail is a good example. In the text box I'm typing this, Cmd-Left/Cmd-Right work as expected on the Mac (moves cursor to start and end of line respectively).

When in Gmail however, Cmd-Left/Cmd-Right seems to have no effect at all, which is annoying because this is how Mac users move to the start/end of a line (equivalent of Home/End keys on PC).
Note that this bug does not just affect Power PC Macs, but any Mac running Firefox. For what it's worth, I have written a summary of this bug and its implications here: http://www.rhoderick.org/2010/05/firefox-bug-342564/
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 289384
This is not resolved on the latest Firefox Beta 4.0b4 for mac! It's easy to replicate (and very frustrating);

1. Use latest Firefox beta on Mac.
2. Open gmail and compose new email.
3. Try to use the __standard__ mac OS X shortcut keys, Cmd-Left Arrow, Cmd-Right arrow to move to end of line / start of line.

Simply does not work.
Cmd+Left and Cmd+Right work properly at 
http://www.squarefree.com/contenteditable.html.

Gmail must be doing something weird, perhaps in an attempt to work around a bug in Firefox that doesn't exist any more.  See bug 405503.
I can confirm that this problem also happens in the JCE editor (for Joomla). Surely they aren't both working around a Firefox bug on the Mac build!?

This bug causes data loss. Firefox takes you to the previous page and whatever text you've entered into the editor is gone. Really looks like this is a Firefox bug (on the Mac build).
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.