[Mac] Default favicon and close button look similar and make tabs look cluttered

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
RESOLVED INVALID
12 years ago
9 years ago

People

(Reporter: asa, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

12 years ago
Tabs on Mac look pretty horrible in the bon echo builds. There are three issues that leap out at me. 

1. with the addition of the tab close button, the tab now has two very similar icons when loading an empty page or a page without a favicon. The grayed out close button and the default globe favicon give the tab a cluttered appearance and confusing target for selecting/closing. 

2. the blue border for selected tabs often doesn't match the actual tab dimensions and looks very bad. 

3. with the new tab scrolling behavior, a tab can be cut off by the scroll button. Tabs should not be truncated like this. We should either show the whole tab, or move it out of view and resize up the remaining tabs. 

Screenshots coming.
(Reporter)

Comment 1

12 years ago
Created attachment 228178 [details]
favicon and close button confusion
(Reporter)

Comment 2

12 years ago
Created attachment 228179 [details]
tab border doesn't match tab width
(Reporter)

Comment 3

12 years ago
Created attachment 228180 [details]
scrolling shouldn't crop tabs
asa, for comparison of your first screen shot, can you attach a screen shot of safari?
(Reporter)

Comment 5

12 years ago
Created attachment 228191 [details]
safari doesn't use favicons
The second issue is bug 333514. The third issue is a XP bug and should therefor get filed separately (please cc sspitzer and me).
(Reporter)

Comment 7

12 years ago
Asaf, the second issue will most likely be fixed if you can fix 333514, but it's not quite the same thing. The issue I reported is about the border being somewhat larger than the tab itself. Still, moving the border to the label would negate this issue and I'd be happy :-)

I'll file the third bug anew as cross platform. This bug, then, can focus on whether or not we think the favicon next to close circle is OK.
(Reporter)

Comment 8

12 years ago
scrolling tabs crops tabs bug filed as bug 343681

Updated

12 years ago
Summary: tab ugliness on Mac → [Mac] Default favicon and close button look similar and make tabs look cluttered
*** Bug 344554 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

12 years ago
If we're just following Safari's close button location, I think we're making a mistake. Better to have the close button on the right since we have favicons. I'll bet that if they added favicons to tabs, they'd have put their button on the right side too.

Comment 11

12 years ago
Looks like the issue of the close buttons being too close to the favicons (on the left side of the tabs) was fixed by bug 345466 (assuming they don't back it out/change it).
(Reporter)

Comment 12

12 years ago
yeah. this is now invalid. 
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Comment 13

12 years ago
(In reply to comment #10)
> If we're just following Safari's close button location, I think we're making a
> mistake. Better to have the close button on the right since we have favicons.
> I'll bet that if they added favicons to tabs, they'd have put their button on
> the right side too.
> 

Having it on the far right increases mouse clicks and movement.  

Let's say you want to close tabs 2, 4 and 6.  You have to click on tab 2, move to the far right and click on close, move to tab 4, click on it and move to the far right and click on close, move to tab 6, click on it and move to the far right and click on close.

Having close buttons in the tabs requires shorter movement of the mouse and just 3 clicks.
You need to log in before you can comment on or make changes to this bug.