mailnews.max_header_display_length is now obsolete

RESOLVED FIXED in Thunderbird2.0

Status

Thunderbird
General
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

({fixed1.8.1})

Thunderbird2.0
x86
Windows XP
fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

7.42 KB, patch
neil@parkwaycc.co.uk
: review+
Scott MacGregor
: approval-thunderbird2+
Details | Diff | Splinter Review
(Assignee)

Description

12 years ago
With the new code for displaying multiple e-mail address headers, we no longer use the pref:

mailnews.max_header_display_length

We can remove that. And while we are at it, there was some code in mailWidgets.xml for the header widgets called getTextAttribute / setTextAttribute, I don't know why those exist, we can call setAttribute / getAttribute directly.
(Assignee)

Comment 1

12 years ago
Created attachment 230354 [details] [diff] [review]
the fix

Removes an obsolete pref from seamonkey and thunderbird now that we have your new header display code. Removes get/setTextAttribute.
Attachment #230354 - Flags: review?(neil)

Updated

12 years ago
Attachment #230354 - Flags: review?(neil) → review+
(Assignee)

Updated

12 years ago
Attachment #230354 - Flags: approval-thunderbird2+
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
(Assignee)

Comment 2

12 years ago
*** Bug 345818 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

12 years ago
This just went into the branch this morning. I had to wait until we spun out the alpha builds.

Updated

12 years ago
Blocks: 346211

Comment 4

12 years ago
(In reply to comment #3)
> This just went into the branch this morning. I had to wait until we spun out
> the alpha builds.

It looks like the patch for mail/base/content/msgHdrViewOverlay.js was accidentally applied to mailnews/base/resources/content/msgHdrViewOverlay.js in CVS.  As a result, the check for AddExtraAddressProcessing on line 882 was removed, which breaks the mail header view pane in SeaMonkey on the branch.  This is the error that appears on the Error Console:

Error: AddExtraAddressProcessing is not defined
Source File: chrome://messenger/content/msgHdrViewOverlay.js
Line: 879
(Assignee)

Comment 5

12 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > This just went into the branch this morning. I had to wait until we spun out
> > the alpha builds.
> 
> It looks like the patch for mail/base/content/msgHdrViewOverlay.js was
> accidentally applied to mailnews/base/resources/content/msgHdrViewOverlay.js in
> CVS.  As a result, the check for AddExtraAddressProcessing on line 882 was
> removed, which breaks the mail header view pane in SeaMonkey on the branch. 
> This is the error that appears on the Error Console:
> 
> Error: AddExtraAddressProcessing is not defined
> Source File: chrome://messenger/content/msgHdrViewOverlay.js
> Line: 879
> 

good catch. I cvs joined the mail version into the mailnews version by mistake. I just fixed this on the 1.8 branch for seamonkey users. Trunk was ok. Thanks!

(Assignee)

Comment 6

12 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > This just went into the branch this morning. I had to wait until we spun out
> > > the alpha builds.
> > 
> > It looks like the patch for mail/base/content/msgHdrViewOverlay.js was
> > accidentally applied to mailnews/base/resources/content/msgHdrViewOverlay.js in
> > CVS.  As a result, the check for AddExtraAddressProcessing on line 882 was
> > removed, which breaks the mail header view pane in SeaMonkey on the branch. 
> > This is the error that appears on the Error Console:
> > 
> > Error: AddExtraAddressProcessing is not defined
> > Source File: chrome://messenger/content/msgHdrViewOverlay.js
> > Line: 879
> > 
> 
> good catch. I cvs joined the mail version into the mailnews version by mistake.
> I just fixed this on the 1.8 branch for seamonkey users. Trunk was ok. Thanks!

I meant to say I made a bad merge. Not my day today. 

(Assignee)

Comment 7

12 years ago
*** Bug 347094 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.