[NECKO][DOGFOOD] Stop button is not functional

VERIFIED FIXED in M12

Status

P2
normal
VERIFIED FIXED
20 years ago
3 years ago

People

(Reporter: rubydoo123, Assigned: rpotts)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

20 years ago
using 3/4 build
all platforms tested

select a URI to load
during load process, select stop
page load does not stop

bug already filed for linux -- 3398 & 3288

Updated

20 years ago
Assignee: don → gagan

Comment 1

20 years ago
Re-assigned to gagan@netscape.com.

Gagan, is this a netlib or a DOM problem?

Updated

20 years ago
Target Milestone: M3

Comment 2

20 years ago
Setting Target Milestone to M3.

Comment 3

20 years ago
gagan, got anything on this, or do we need to wait for N2.

Comment 4

20 years ago
I am looking at this right now...

Updated

20 years ago
Target Milestone: M3 → M4

Comment 5

20 years ago
moving to m4.  gagan finds it working on all but the fast sites,
but if the site is fast why stop its loading?

needs a good reproducable test case.

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 6

20 years ago
For most cases, this seems to be working ok. I have however noticed a couple of
times where an OnStopBinding event doesnt get fired. While I am trying to
investigate this, it will greatly help if had a reliably reproducible test case.
So far I have been using slow sites as a measure, which seem to be working just
fine. Either way, I am setting this to M4.

Updated

20 years ago
QA Contact: 3853 → 4130

Comment 7

20 years ago
setting QA Contact to claudius.  Will release note that this sometime does not
work for M3.

Updated

20 years ago
Target Milestone: M4 → M6

Comment 8

20 years ago
Marking till Necko lands...

Comment 9

20 years ago
*** Bug 4659 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Hardware: PC → All

Comment 10

20 years ago
www.macosrumors.com seems like a good enough site to test this on...at least on
linux anyway. The current behavior as outlined from bug4938 is to appear to stop
the loading of the page but the throbber and notification bar remain active.
Changing platform field to all since it happens on the Mac as well.

Comment 11

20 years ago
*** Bug 4938 has been marked as a duplicate of this bug. ***

Comment 12

20 years ago
Worksforme on 4/13 build on Win 95.

Comment 13

20 years ago
Per DP's suggestion marking these till M8. Though Necko lands with M7, we will
be able to verify it for M8.

Comment 14

20 years ago
Moving all Apprunner bugs past and present to Other component temporarily whilst
don and I set correct component.  Apprunner component will be deleted/retired
shortly.

Comment 15

20 years ago
I'm moving this to target M9, Necko will be enabled somewhere during late M8 or
early M9.  We will need to get on this and it cannot be postponed past the M9
milestone.

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
Summary: stop button is not functional → NECKO:stop button is not functional

Comment 16

20 years ago
Fixed with Necko. Pl. verify.

Comment 17

20 years ago
this seems fixed but its hard to check, the pages load so dang fast ;-).
I'll try some slow machine.
Gagan:
To clarify, if i click stop before the page is
grabbed (before it begins to layout) everything should stop cold, but if I click
stop why a page is laying out what then?

Comment 18

20 years ago
Well I am not aware of how threaded the layout model is, so perhaps someone from
that group can comment on it. But the expected behaviour should be similar to
that of 4.* I guess. And for a slow site try reaching my alma mater in India-
http://www.iitk.ernet.in/ Its about as far on this globe as you can
geographically get. Once proxies start working you can route any request thru a
slow proxy or once we have our servers set up on Mars, you'd have a better
choice. Or you could try the world's smallest server running on a microchip the
size of a matchstick head at http://eternity.cs.umass.edu:9080/index0.html Have
fun! :)

Comment 19

20 years ago
*** Bug 6284 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 20

20 years ago
OK I've satisfied myself that this works now. marking VERIFIED for 1999081609 builds.

Comment 21

20 years ago
*** Bug 16007 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Status: VERIFIED → REOPENED

Comment 22

20 years ago
The bug is still present on Linux build 1999100814. Try to load www.mozilla.org
on a slow dialup line , and press stop after 2 seconds ... the page continues to
load .

  Or .... try to load a page,that times out , using a proxy, after waiting
some seconds, load another page .. after a couple of minutes, the error page
generated by the proxy apears .

Updated

20 years ago
Blocks: 7922
Resolution: FIXED → ---
Whiteboard: [PDT+]

Comment 23

20 years ago
Putting on [PDT+]radar.
Clearing FIXED resolution due to reopen.

Updated

20 years ago
Target Milestone: M9 → M11

Updated

20 years ago
QA Contact: claudius → cpratt
Summary: NECKO:stop button is not functional → [NECKO][DOGFOOD] Stop button is not functional

Comment 24

20 years ago
I've verified that this is broken on the 1999101908 and 1999102008 builds on NT
and 98. Changing self to QA contact.

Updated

20 years ago
Status: REOPENED → ASSIGNED

Comment 25

20 years ago
rick: would some of your changes (have affected/will affect) this? cc'ing you
for comments.
(Assignee)

Updated

20 years ago
Assignee: gagan → rpotts
Status: ASSIGNED → NEW
(Assignee)

Comment 26

20 years ago
hey gagan,

I'll take this one... I've got some changes to fix cancelling loadgroups...  And
I'm looking at the notifications all the way up the hierarchy...

-- rick

Comment 27

20 years ago
*** Bug 16851 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Blocks: 17743

Updated

20 years ago
Blocks: 17907

Updated

20 years ago
Blocks: 17976

Updated

20 years ago
QA Contact: cpratt → claudius
Target Milestone: M11 → M12

Comment 28

20 years ago
we decided via e-mail this was OK for M11. Still some problems with layout
continuing after stop is pressed. Changing to M12 to get off M11 radar, but this
can maybe be closed and new bugs reopened.

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED

Comment 29

20 years ago
marking fixed..

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 30

20 years ago
Okay, VERIFIED

Updated

19 years ago
No longer blocks: 17907
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.