Closed Bug 347607 Opened 14 years ago Closed 10 years ago

Landscape icon has wrong orientation in "Page Setup" dialog

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED INCOMPLETE
Firefox 3 alpha5

People

(Reporter: u88484, Assigned: dao)

References

Details

(Keywords: polish)

Attachments

(6 files)

The landscape icon that you can see in the 'Page Setup' dialog is an
horizontal page with a rotated "buddy".
The "buddy", instead, should remain vertical.

Was the same in winstripe (bug 311338) so I guess that's why the new themers done it that way, but it needs changed.
Just noticed it actually hasn't been checked in yet (but the old icon has same problem anyways). So here is where the attachment is (bug 345466) https://bugzilla.mozilla.org/attachment.cgi?id=230953
Worth fixing, but not a regression from the new theme.
No longer blocks: NewTheme
Since this won't be tracked by the meta bug, who should we CC from radiant core?
proposal
Attachment #232868 - Flags: review?
Attachment #232868 - Flags: review? → review?(mconnor)
Kurt, could you please set the target milestone to Firefox 2 beta2 and maybe request blocking? (At least I guess by "worth fixing" Mike C meant "for Fx2".)
I'll let one someone else like the module owner/drivers/beltzner set target because thats something to set if its wanted/needed for that release. I know they wouldn't block a release on this so not going to request it. 
(In reply to comment #6)
> I know they wouldn't block a release on this so not going to request it.

I agree, it doesn't really match the meaning of blocking. But on the other hand: "if you want something in beta2, nominate the bug as blocking-firefox2? or blocking1.8.1? and set the target milestone as Firefox 2 beta2 or mozilla1.8.1beta2; drivers to triage the list daily from here to beta2 release (note: no target milestone means that it's not blocking that target)"

I just wanna make sure this bug doesn't get lost, since it's not part of the new theme regressions bug anymore ...
I think this bug should be fixed before Firefox 2 ships and should be marked as "Blocking bug  347454".
(In reply to comment #8)
> I think this bug should be fixed before Firefox 2 ships and should be marked as
> "Blocking bug  347454".
> 

I second. Nominated for blocking-firefox2
Flags: blocking-firefox2?
(In reply to comment #9)
> (In reply to comment #8)
> > I think this bug should be fixed before Firefox 2 ships and should be marked as
> > "Blocking bug  347454".
> > 
> 
> I second. Nominated for blocking-firefox2
> 
Yeah, I can't exactly set the target milestone as I don't have the privs. Someone else can do it for me if they wish. Thanks.
It's not a regression from the new theme, see comment 1 and comment 2.
Flags: blocking-firefox2?
Attachment #232868 - Flags: review?(mconnor)
I third it & also vote for it. It should block FF 2.0 :)
Comment on attachment 232868 [details]
toolkit/themes/winstripe/global/icons/Landscape.png

Asking for review once again, since the flawed image has been checked in. Trying beltzner this time.

Guess: if this bug doesn't have the blocking-firefox2 flag, it's probably not going to happen.
Attachment #232868 - Flags: review?(beltzner)
this one was wrong, too.
Attachment #240071 - Flags: review?
Ahh maybe one day firefox print preview will have the right orientation for the page layout buttons. Third release now with the wrong orientation and for all three releases there were bugs and patches to fix it and it was never fixed.  Can someone put this polish bug on the radar for 2.0.0.1? It just looks silly that such a little bug is still present three releases later and two different themes having the same bug...especially when this time around it was pointed out 2 months before even the last RC was released.
Attachment #232868 - Flags: review?(beltzner) → ui-review?(beltzner)
Attachment #240071 - Flags: review? → ui-review?(beltzner)
This error is still present in Firefox 2.0 - where the black and white icon of the old theme has now been replaced by a carefully-coloured-in icon done by someone who didn't think about what they were doing. The colour icon for landscape pages has the person in the wrong orientation.

Good grief.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Flags: blocking-firefox3?
Target Milestone: --- → Firefox 3 beta1
Attachment #240071 - Flags: ui-review?(beltzner) → ui-review+
Attachment #232868 - Flags: ui-review?(beltzner) → ui-review+
Flags: blocking-firefox3? → blocking-firefox3+
Attachment #240071 - Attachment description: Print-preview.png → toolkit/themes/winstripe/global/icons/Print-preview.png
Whiteboard: [checkin needed]
Checking in Landscape.png;
/cvsroot/mozilla/toolkit/themes/winstripe/global/icons/Landscape.png,v  <--  Landscape.png
new revision: 1.3; previous revision: 1.2
done
Checking in Print-preview.png;
/cvsroot/mozilla/toolkit/themes/winstripe/global/icons/Print-preview.png,v  <-- Print-preview.png
new revision: 1.4; previous revision: 1.3
done
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: Firefox 3 beta1 → Firefox 3 alpha5
Version: 2.0 Branch → Trunk
Verified on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1 ID:2007110904
Status: RESOLVED → VERIFIED
This problem is still valid on Firefox 3.x. See attached screenshot. There should be two separate portrait and landscape icons, each in two rotations, not one icon rotated four times.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(In reply to comment #20)
> Created an attachment (id=433307) [details]
> Screenshot of print dialog showing that portrait icon isn't really a protrait
> page, just a rotation of the landscape page.

Not sure what you're trying to say with that screenshot of Acrobat Pro.
Status: REOPENED → RESOLVED
Closed: 13 years ago10 years ago
Resolution: --- → FIXED
Dao@21: oops, wrong file, for another bug, sorry. correct one attached.
Comment on attachment 433307 [details]
Screenshot of print dialog showing that portrait icon isn't really a protrait page, just a rotation of the landscape page.

Ignore this screenshot, I uploaded the wrong file. Next screenshot is the correct one.
Duplicate of this bug: 311338
The issue in general isn't resolved. See Bug 553261 for Gnomestripe and a current screenshot of a printer setup dialog with wrong landscape icons.
I've uploaded a couple of screenshots comparing page setup on Firefox 3.6.17 (linux) with Firefox 4.0.1 (windows). 3.6.17 comes off better. At first glance, this is a regression based on version number, but different themes are involved. So it's certainly a bug in whatever the Windows theme is, may also be present in other themes.

So, marking fix as 'incomplete'.
Resolution: FIXED → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.