Closed Bug 348411 Opened 16 years ago Closed 13 years ago

IMAP mail folder subscription does not work

Categories

(Thunderbird :: General, defect)

PowerPC
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: cjac, Unassigned)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Clicking on <b>File</b> -> <b>Subscribe...</b> puts the application into a state of blocking on the subscription window being "completed."

The window is not displayed, and thus can not be "completed."


Reproducible: Always

Steps to Reproduce:
1. Right-click on any IMAP folder
2. Select <b>Subscribe...</b> from the context widget
3. Click the <b>File</b> pull-down menu item
4. Note that all options are greyed out

Actual Results:  
Thunderbird goes into a blocking state

Expected Results:  
Window should pop up
I see this - IMAP subscribe dialog is modal - (on linux, latest branch), not sure if it's by design.

(You are supposed to finish the dialog before doing anything else, therefore the File menu is disabled.)

Severity: major → minor
OS: Mac OS X 10.4 → All
Hardware: Macintosh → All
Summary: IMAP mail folder subscription does not work. → IMAP subscribe dialog is modal
can't reproduce it
2.0.0.12
version 3.0a1pre (2008040903)
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
You can't reproduce that http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/mail/base/content/mailCommands.js&rev=1.42&mark=365#352 opens a modal dialog? That's... surprising.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Due to comment #1 and comment #3, confirming.

CC'ing Bryan.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #3)
> You can't reproduce that
> 
> opens a modal dialog? That's... surprising.
> 

It's opens modal dialog but I can't click on File menu, so I unable to lockup TB as described.
That's because you're not using a Mac (though you wouldn't be able to on trunk anyway, since now the menus are removed when a modal dialog is open).

Fourth re-reading of comment 0, though, I see where this got morphed: C.J. was reporting "subscribe tries to open a modal dialog, fails to actually open it ('The window is not displayed') so there's no way I can close it, but the app window still thinks it's showing a modal dialog, so the whole app is hosed" rather than "subscribe opens a modal dialog."

C.J.: still with us, using a nice current 2.0.0.x build? And if so, do you still see the same thing?
Assignee: mscott → nobody
Severity: minor → major
OS: All → Mac OS X
Hardware: All → Macintosh
Summary: IMAP subscribe dialog is modal → IMAP mail folder subscription does not work
Version: unspecified → 1.5
Blocks: 201332
any response? should we close this as incomplete?
Clsoing as INCOMPLETE due to the lack of answers to comment 6. If you feel this is an error - please reopen and reply to the question asked.
Status: NEW → RESOLVED
Closed: 14 years ago13 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.