Recently Closed Tabs in History menu is grayed out

RESOLVED FIXED in Firefox 2

Status

()

RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: jbecerra, Assigned: mconnor)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2
x86
Windows XP
fixed1.8.1
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

"Recently Closed Tabs" in History will be grayed out when you close tabs after doing a "clear private data"

To recreate:
1. Open four pages in four tabs.
2. Close one of the tabs.
3. Go to Tools menu and select "Clear Private Data"
4. Close one more tab.
5. Go to History menu

Expected: History menu should have the "Recently Close Tabs" enabled, and it should allow you to select the tab you closed in step 4.

Actual: It is grayed out.

Notice that if you right click one of the tabs you do have the option to open the recently closed tab.

Reproducible: Always
(Reporter)

Updated

13 years ago
Flags: blocking-firefox2?
This was probably caused by bug 343212 (assuming you cleared history in step 3). I think the bug is that you can use the context menu after clearing history.
Oh, nevermind, I misunderstood - you closed another tab after clearing. This might still be related to bug 343212, though.
Regression between 1.8.1b2_2006081712 and 1.8.1b2_2006081801. 
Ah, so likely a regression from bug 348016, then.
Hi Juan,

I can't reproduce this problem. I tried the latest nightlies on Mac and XP, as well as running from latest branch CVS code. Is there anything in your profile that might be different from mine? Did you test with a clean profile?
(Reporter)

Comment 6

13 years ago
I tested on a WinXP vm, using Parallels on a Macintel, with a clean profile, and I had added this on the prefs.js file:

user_pref("browser.sessionstore.max_tabs_undo", 2);

Also, one thing I noticed is that after step 5, if you right click on a tab and "Undo Close Tab", and then you go to the Hisotory menu, you will not see the problem.

I will try on a different machine.
(Reporter)

Comment 7

13 years ago
I meant to say: "...after step 4..."
--> blocking, let's get some solid STR or a WFM on this, please.
Assignee: nobody → dietrich
Flags: blocking-firefox2? → blocking-firefox2+
Target Milestone: Firefox 2 beta2 → Firefox 2
(Reporter)

Comment 9

13 years ago
I tried on a different vm, and I was able to recreate the problem. Then I tried on an intel box with WinXP and also an intel box with Windows2000, and I was NOT able to recreate the problem.

This is a problem with my VM's.
resolving invalid, as per comment #9
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
reproduced in XPsp2 with Firefox 2.0 beta 2 RC1 and with nightly (2006082403).
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Reproduced on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1b2) Gecko/20060824 BonEcho/2.0b2

One Note: "Recently Closed Tabs" is grey out, but what works is this "undo close tab" function, while right click on the other existing tab.
(Assignee)

Comment 13

13 years ago
Created attachment 235544 [details] [diff] [review]
move call before early return

This also fixes the inverse case, which was that if there were Recently Closed Tabs before, the menuitem doesn't disable until you mouse to it.

Kinda edgy, but worth fixing.

Low risk.
Assignee: dietrich → mconnor
Status: REOPENED → ASSIGNED
Attachment #235544 - Flags: review?(dietrich)
(Assignee)

Updated

13 years ago
Whiteboard: [has patch][needs review dietrich]
Attachment #235544 - Flags: review?(dietrich) → review+
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED

Comment 14

13 years ago
seems to be checked-in only on Trunk, not yet on Branch, so not "resolved/fixed" yet.
is this a bug on Branch, not on Trunk ?

please check-in on Branch ASAP.

and how about bug 345014 ?
(In reply to comment #14)
> seems to be checked-in only on Trunk, not yet on Branch, so not
> "resolved/fixed" yet.

RESOLVED FIXED means a bug was fixed on the trunk, so this bug is FIXED. The branch checkin will happen once it gets approval.
Whiteboard: [has patch][needs review dietrich] → [needs approval]
(Assignee)

Updated

13 years ago
Attachment #235544 - Flags: approval1.8.1?

Comment 16

13 years ago
Comment on attachment 235544 [details] [diff] [review]
move call before early return

a=schrep for drivers.
Attachment #235544 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Comment 17

13 years ago
landed on branch
Keywords: fixed1.8.1
Whiteboard: [needs approval]
You need to log in before you can comment on or make changes to this bug.