Closed Bug 350406 Opened 14 years ago Closed 13 years ago

Remove build system redundancy between Lightning and Sunbird

Categories

(Calendar :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Sunbird 0.5

People

(Reporter: mattwillis, Assigned: mattwillis)

References

Details

Attachments

(1 file, 1 obsolete file)

Over the past few months we've made significant progress in reducing duplication and complexity in the tree. (ex: calendar.xul vs. calendar.xul)

There are still some areas where we can remove redundancy, while simplifying the build, and still not executing a "move for moving's sake".

One area I'd like to address is Lightning's jar.mn.
Attached patch rev0 - Adds /m/cal/base/jar.mn (obsolete) — Splinter Review
Adds /mozilla/calendar/base/jar.mn and puts common items for Sb and Ln there.

I made the executive decision to include calendar-decorated-multiweek-view.xml in both distributions, for sanity.

If we can use a common themes directory at some point, even more can be shared.

Moving Lightning to making in locales will also reduce the redundancies in its jar.mn.
Attachment #235691 - Flags: second-review?(jminta)
Attachment #235691 - Flags: first-review?(ssitter)
Comment on attachment 235691 [details] [diff] [review]
rev0 - Adds /m/cal/base/jar.mn

For something like this, dmose is the right peer.
Attachment #235691 - Flags: second-review?(jminta) → second-review?(dmose)
What is the actual problem this bug tries to address?
I think that at this stage, we should focus on real, user-visible bugs, instead of build-system tweaks.
(In reply to comment #3)
> What is the actual problem this bug tries to address?
The fact that we need to add stuff to two places (lightning/jar.mn and sunbird/base/jar.mn or resources/jar.mn) to get .js or .xul inside base in both apps.

> I think that at this stage, we should focus on real, user-visible bugs,
> instead of build-system tweaks.
I'll assume "at this stage" means "this close to release".
I'm okay with this bug being pushed until after release if it's deemed too risky for 0.3.  I just ran into this stuff while working on some "real, user-visible bugs", and that's why I fixed it.
Status: NEW → ASSIGNED
Not going to make the 0.3 train.
Target Milestone: Sunbird 0.3 → Sunbird 0.4
Comment on attachment 235691 [details] [diff] [review]
rev0 - Adds /m/cal/base/jar.mn

bitrotted
Attachment #235691 - Attachment is obsolete: true
Attachment #235691 - Flags: second-review?(dmose)
Attachment #235691 - Flags: first-review?(ssitter)
Attachment #242224 - Flags: second-review?(dmose)
Attachment #242224 - Flags: first-review?(cmtalbert)
Comment on attachment 242224 [details] [diff] [review]
rev1 - unbitrotted

Performed a lightning build on windows with this patch. Looks good.
Attachment #242224 - Flags: first-review?(cmtalbert) → first-review+
Comment on attachment 242224 [details] [diff] [review]
rev1 - unbitrotted

Looks good; r2=dmose.
Attachment #242224 - Flags: second-review?(dmose) → second-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
*** Bug 296895 has been marked as a duplicate of this bug. ***
Depends on: 356722
You need to log in before you can comment on or make changes to this bug.