If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Approval Queue] Errors occur when a reviewer has an add-on of their own in the queue

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Developer Pages
VERIFIED FIXED
11 years ago
2 years ago

People

(Reporter: fligtar, Assigned: fligtar)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Submitting this bug on behalf of Trevor Roydhouse so that we can get this patch included with the current IT request if possible.

Trev's email:
Since I uploaded a new version of my AustLII Toolbar extension, any of
the other extensions which I review and approve/deny do not show up in
the "approval log" listing.

This evening while I was approving/denying extensions I noticed it
complained that there was an error approving my extension and exhorting
me to fill in the missing data. Of course, I couldn't do this even if I
wanted to :)

So, while my extenson is stuck in the queue, I guess I won't be able to
review any more extensions because it the results aren't making it to
the log, perhaps something else nasty is also happening ...

Reproducible: Always
(Assignee)

Updated

11 years ago
Assignee: nobody → fligtar
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

11 years ago
Created attachment 236279 [details] [diff] [review]
approval.php patch

This bug revealed two problems:

1) If a reviewer has an extension in the queue for review, the form fields are disabled so that they can't approve their own extension. It turns out that disabled form fields do not submit their post values, so because "" != "noaction", every queue process would attempt to review the reviewer's own extension, but would fail because they did not enter comments.

This patch removes the disabled form fields and just completely doesn't show the form for a reviewer's own extension. It also changes the process logic so that a review will only be processed if it is "YES" or "NO".

2) The second problem was with entries not showing up in the approval log. This was actually because today is the last day of the month and the approval queue queries entries between 2006-08-01 and 2006-08-31... not 2006-08-31 23:59:59.

This patch fixes that and the approval entries will show up now.
Attachment #236279 - Flags: first-review?(morgamic)
Comment on attachment 236279 [details] [diff] [review]
approval.php patch

This worked for me in khan.  Checking in and updating the prod tag.
Attachment #236279 - Flags: first-review?(morgamic) → first-review+
This should be pushed with the batch of updates that is sitting in the IT queue.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 4

11 years ago
<3 Fligtar
Status: RESOLVED → VERIFIED
OS: Windows XP → All
Hardware: PC → All
Summary: [Approval Queue] Errors occur when a reviewer has an extension of their own in the queue → [Approval Queue] Errors occur when a reviewer has an add-on of their own in the queue
Version: unspecified → 1.0
(Assignee)

Comment 5

11 years ago
*** Bug 342584 has been marked as a duplicate of this bug. ***
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.