Feed Viewer actions do nothing, give error "this._window has no properties"

VERIFIED DUPLICATE of bug 342991

Status

()

--
major
VERIFIED DUPLICATE of bug 342991
12 years ago
9 years ago

People

(Reporter: jmillikin, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060601 BonEcho/2.0b1 (Ubuntu-edgy)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060601 BonEcho/2.0b1 (Ubuntu-edgy)

When I use the Feed Viewer to preview a feed, neither the "Subscribe Now" button nor "Change Reader..." link work. Both give this error in the Error Console:

Error: this._window has no properties
Source File: file:///usr/lib/firefox/components/FeedWriter.js
Line: 370

In addition, the "Change Reader..." link gives this error:

Error: uncaught exception: [Exception... "'[JavaScript Error: "this._window has no properties" {file: "file:///usr/lib/firefox/components/FeedWriter.js" line: 370}]' when calling method: [nsIFeedWriter::changeOptions]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://browser/content/feeds/subscribe.js :: SH_changeOptions :: line 54"  data: yes]

And the "Subscribe Now" button gives this error:

Error: uncaught exception: [Exception... "'[JavaScript Error: "this._window has no properties" {file: "file:///usr/lib/firefox/components/FeedWriter.js" line: 370}]' when calling method: [nsIFeedWriter::subscribe]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://browser/content/feeds/subscribe.js :: FH_subscribe :: line 58"  data: yes]

Reproducible: Always

Steps to Reproduce:
1. Enter the feed's URL into your address bar
2. Try to click either the button or link
3. Nothing happens

Actual Results:  
Nothing

Expected Results:  
Presumably, a window will pop up with preferences or something. I don't know what it's supposed to do.

Comment 1

12 years ago
I'm assuming Ubuntu pulled from CVS before bug 342991 got fixed...

*** This bug has been marked as a duplicate of 342991 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 2.0 Branch
Verified Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.