Closed Bug 352636 Opened 14 years ago Closed 6 years ago

Ctrl+Enter on the message opens this message (same as just Enter); maybe change it to "Mark as read" as in Outlook Express?

Categories

(Thunderbird :: Message Reader UI, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: al_pavel, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [oe-parity])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0
Build Identifier: version 1.5.0.5 (20060719)

When pressing "Ctrl+ENTER" on the selected message(-s) in the Thunderbird main window, the messages will be opened in the separate windows: just the same action as "Enter without Ctrl". I have used Outlook Express a long time before (and many other people too) and this behaviour is very confusing for me (because in OE "Ctrl+Enter" just marks the selected messages as read). I know that in Thunderbird "M"-key is used for this action, but many yers of work in OE are not so simply to forget.

Reproducible: Always

Steps to Reproduce:
1. Start Thunderbird
2. Select message(-s)
3. Press Ctrl+Enter
4. Do the same in Outlook Express

Actual Results:  
Messages are opened in separate windows

Expected Results:  
Messages are marked as read

I think that changing the action for "Ctrl+Enter" will not confuse people who used MozillaMail/Thunderbird a lot of time; I don't think that everybody has used Ctrl+Enter in this program because it does actually the same as just Enter, but requires two keys to press, not only one :)
Assignee: mscott → nobody
Component: Mail Window Front End → Message Reader UI
QA Contact: front-end → message-reader
Whiteboard: [driver: WONTFIX?]
cc: clarkwb to evaluate
Whiteboard: [driver: WONTFIX?] → [driver: WONTFIX?][oe-parity]
Since there are 3 possible ways to open a message (new tab, new window, and in conversation), we could make each one of these map to a keyboard shortcut. For instance:

Enter: open in new tab
Shift+Enter: open in new window
Ctrl+Enter: open in conversation
We currently have Ctrl+Shift+O for: open in conversation

I would exepct Ctrl+Enter for: open a message in a new tab, but in the background so that I can continue to open other messages in background tabs in the same way. So in spite of general sympathy for this bug, I'd see a tendency for wontfix here, too. Ctrl+Enter is too important than to be used for "mark as read", for which the default is to "mark as read" after x seconds of viewing the msg, isn't it?
We have "M" keyboard shortcut for mark/unmark as read, which is also simple enough.
Jim's Comment 2 and my Comment 3 suggest two better uses for Ctrl+Enter.
It's too significant a shortcut to be used for "Mark as read" (which also happens automatically after a user-definable delay).
And we're not striving to copy each and every shortcut of Outlook, although external consistency is desirable where possible for some of the most used shortcuts.

No supportive voices or other signs of interest here, so I think this looks like wontfix.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Whiteboard: [driver: WONTFIX?][oe-parity] → [oe-parity]
You need to log in before you can comment on or make changes to this bug.