tab shoulders have a fixed height, which means the titles don't fit

RESOLVED DUPLICATE of bug 350194

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED DUPLICATE of bug 350194
11 years ago
11 years ago

People

(Reporter: db48x, Unassigned)

Tracking

Trunk
Firefox 3 alpha1
x86
Linux
Points:
---
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fx2 theme change])

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
I'll attach a screenshot, but the upshot is that the titles appear to break out of the tabs. This is a result of not using the native theming that used to be used.
(Reporter)

Comment 1

11 years ago
Created attachment 239627 [details]
Screenshot-27.png

see also http://db48x.net/temp/Screenshot-21.png
Component: Themes → Tabbed Browser
Product: Core → Firefox
QA Contact: themes → tabbed.browser
Target Milestone: --- → Firefox 3 alpha1
Blocks: 353673
If this is also an issue on the branch, this blocks bug 347454, not bug 353673.
Blocks: 347454
No longer blocks: 353673
(Reporter)

Updated

11 years ago
Flags: blocking-firefox2?
Its also a result of not having time to test flexible height tabs, we have the images in place already, just not the testing on the modded CSS required to make them work.

This is not critical by any criteria and certainly not a blocker (previously discussed).  Short of bumping DPI to something pretty high, or going to extremely large fonts (i.e. beyond Extra Large Fonts on Windows) you can't reproduce this.

We were planning to fix on trunk.
Severity: critical → minor
Flags: blocking-firefox2? → blocking-firefox2-
(Reporter)

Comment 4

11 years ago
My monitor is only 100dpi, and the font size I use is only 14px. Neither of those seem very extreme. 

Isn't this exactly the sort of accessibility problem we've been trying to fix on the web? Didn't we introduce real font zooming in order to allow people with less than perfect eyesight to actually read the webpages they visit? Don't we all cringe when we see a site that completely breaks under font zoom? Why should we repeat the same mistakes others have made?

As far as I know this doesn't actually affect the functionality of the browser, but it does make it ugly. On the other hand, what other hidden inflexibilities lurk in the new theme? If I make my font size a little larger, will the text be cut off? Do we have the time to test all of those possibilities with the new theme?

Comment 5

11 years ago
This was supposed to be fixed by 349038.

Comment 6

11 years ago
Not fixed as of 2006-09-28-1702 build: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060928 BonEcho/2.0 - Build ID: 2006092816.

Comment 7

11 years ago
Created attachment 240572 [details]
Screenshot showing tabs with bug.

Comment 8

11 years ago
(In reply to comment #5)
> This was supposed to be fixed by 349038.
> 
Bug 349038 only reduces the severity of the problem so that most systems would not be affected. 
is this a dup of bug #350194?

Comment 10

11 years ago
We need to make the whiteboard "[Fx2 theme change]" so it shows up in the devs'
queries and they'll make sure to hammer it down for a subsequent release.
Whiteboard: [Fx2 theme change]
No longer blocks: 347454
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 350194
You need to log in before you can comment on or make changes to this bug.