Omnibus ad-blocking bug for October

RESOLVED FIXED

Status

Camino Graveyard
Annoyance Blocking
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: Smokey Ardisson (offline for a while; not following bugs - do not email))

Tracking

({fixed1.8.1.1})

unspecified
PowerPC
Mac OS X
fixed1.8.1.1

Details

Attachments

(1 attachment)

 

Comment 1

11 years ago
An iframe for Amazon shows up on this page:

http://www.coinpage.com/terms.html


Here's the HTML snippet that generates it:

&#65279;<!-- ******************* start amazon content right margin ********************** -->
<td valign="top" width="20%"> 
<iframe marginwidth="0" marginheight="0" width="160" height="600" scrolling="no" frameborder="0" src="http://rcm.amazon.com/e/cm?t=thecoinpage-20&p=14&o=1&l=bn1&browse=5078&mode=books&bg1=FFFFFF&fc1=000000&lc1=082984&lt1=_blank&f=ifr">


<img src="http://rcm-images.amazon.com/images/G/01/rcm/160x600.gif" width="160" height="600" border="0" usemap="#boxmap-p14" alt="Shop at Amazon.com">
</iframe>
<td>

<!-- ********************* end right margin ************************ -->

Comment 2

11 years ago
There's a Flash ad that shows up here:

http://www.autoblog.com/2006/10/07/video-bicyclist-outruns-cops-in-high-speed-chase/


HTML that generates it:

<div id="aolautos">
<div id="GenCar-swf"></div>
<script type="text/javascript">
var so = new SWFObject("http://www.blogsmithmedia.com/www.autoblog.com/media/2006/09/gencar_205x140.swf", "gencar", "205", "140", "6", "#ffffff");
so.write("GenCar-swf");
</script>
<noscript>
<a href=http://autos.aol.com target="_blank"><img src="http://cdn.digitalcity.com/ch_autos/autoblogmodule205x140" alt="New Cars, Used Cars, Kelley Blue Book, Car Insurance & Auto Loans - AOL Autos" width="205" height="140" border="0" /></a>
</noscript>
</div>

Comment 3

11 years ago
Flash ad at the bottom of the story here:

http://www.tsn.ca/mlb/news_story/?ID=180127


HTML (actually pure JS this time) snippet:

<script type="text/javascript">
var FriskAdFO = { movie:"http://www.tsn.ca/flash/ads/friskBanner_bus_600x60_en.swf", width:"600", height:"60", majorversion:"7",
build:"0", xi:"true", ximovie:"http://www.tsn.ca/flash/ads/friskBanner_bus_600x60_en.swf", xioverlay:"false", xiwidth:"600", 
xiheight:"60"};
UFO.create(FriskAdFO, "FriskAd");
</script>
Blocks: 355901

Comment 4

11 years ago
Boing boing is showing a bunch of ads from http://static.fmpub.net/banners/

Comment 5

11 years ago
The Atlantic has ads on this page:

http://www.theatlantic.com/doc/200610u/lidle-crash-2/2


with this HTML generating them:

<tr>
   <td><a href="http://www.theatlantic.com/sam/click/408/0" target="_new"><img src="/sads/TAM/image.jpg" border="0" alt="Atlantic Ideas Tour"></a></td>
</tr>

Comment 6

11 years ago
Our ad-blocking is hiding images here:

http://www.gocomics.com/adamathome/

because the geniuses at that site have placed their images for that strip in this directory:

http://images.ucomics.com/comics/ad/

Perhaps we could whitelist images.ucomics.com, or some other string, to ensure this doesn't happen.

cl
> because the geniuses at that site have placed their images for that strip in
> this directory:
> 
> http://images.ucomics.com/comics/ad/

Heh, this happened before, and they changed it.  Apparently they thought it would be fun to go back to /ad/ :P

Comment 8

11 years ago
There's a 250x250 ad here:

http://www.winfieldcourier.com/main.asp?SectionID=1&SubSectionID=1&ArticleID=15748

(don't ask)

generated by this HTML:

<TABLE CELLPADDING="0" CELLSPACING="0" BORDER="0" ALIGN="CENTER"><TR VALIGN="TOP"><TD ALIGN="RIGHT"><IMG SRC="image/IAA_ADV.gif"></TD><TD WIDTH="25" ALIGN="CENTER"><IMG SRC="image/IAA_RULE.gif" WIDTH="25" HEIGHT="15"></TD><TD ALIGN="LEFT"><A HREF="#B2"><IMG SRC="image/IAA_JUMP.gif" BORDER="0"></A></TD></TR><TR VALIGN="TOP"><TD ALIGN="CENTER" COLSPAN="3" WIDTH="250"><a href="Redirect.asp?UID=1003097&SubSectionID=1&InArticleAdID=1&LinkURL=http://www.reedyford.com" target="_new"><IMG SRC="SiteImages/InArticleImages/1.gif" WIDTH="250" HEIGHT="250" border="0"></a><BR><BR></TD></TR></TABLE>

Comment 9

11 years ago
Saw http://content.cpxinteractive.com/atoms/90/c9/90c9fcfe1d79939ca59adaf5227a6139.gif and http://content.cpxinteractive.com/5115/6027/420688808434281ebcef7a.gif coming from http://content.cpxinteractive.com

Comment 10

11 years ago
(In reply to comment #9)
> Saw
> http://content.cpxinteractive.com/atoms/90/c9/90c9fcfe1d79939ca59adaf5227a6139.gif
> and http://content.cpxinteractive.com/5115/6027/420688808434281ebcef7a.gif
> coming from http://content.cpxinteractive.com
> 

Ryan, on what site/page did you see those ads?

cl

Comment 11

11 years ago
Annoying Flash ad spawned here:

http://www.theage.com.au/news/National/Thieves-steal-deadly-snake-in-Sydney/2006/10/18/1160850968820.html


Coming in via Javascript from ffxcam.theage.com.au.
(In reply to comment #11)
> Annoying Flash ad spawned here:
> 
http://www.theage.com.au/news/National/Thieves-steal-deadly-snake-in-Sydney/2006/10/18/1160850968820.html
> 
<iframe width="100" height="29" marginwidth="0" marginheight="0" frameborder="0" scrolling="no" src="http://ffxcam.fairfax.com.au/html.ng/site=age&amp;adspace=100x29"> and friends

Comment 13

11 years ago
I saw http://choosecars.com/kiss.gif with link http://sdsuccess.dtsecrets.hop.clickbank.net/ at http://www.amirtofangsazan.blogspot.com/

Comment 14

11 years ago
id="banner" is killing a legitimate flash banner on http://www.aja.com/index.html.

Comment 15

11 years ago
From feedback:

Hi there,
I'm running a nightly build of Camino 1.1 Alpha. I use Feedburner for  
my blog and enable their chicklets (little buttons that visitors can  
click to subscribe to a feed) on it. I've noticed that Feedburner's  
Google Reader button never seems to work in Camino. However, I think  
the culprit is the ad blocking feature. When I turn it off it seems  
to work fine.

This issue also occurs in 1.03.

Comment 16

11 years ago
The feedback correspondent got back to me with URLs.

From http://subtonic12.blogspot.com/ comes this HTML snippet:

<p><a href="http://fusion.google.com/add?feedurl=http://feeds.feedburner.com/BarbarismBeginsAtHome"><img width="104" style="border:0" alt="Add to Google" src="http://buttons.googlesyndication.com/fusion/add.gif" height="17"/></a></p>

I think we're blocking "googlesyndication.com" somewhere, although "add.gif" might be something too.

cl

Comment 17

11 years ago
There's also a horribly annoying set of GIF ads that shows up in the upper-left corner of

http://www.lightingandsoundamerica.com/

They're various images in the following directory:

http://www.lightingandsoundamerica.com/righthandads/

(from the same feedback correspondent)

cl
Assignee: nobody → alqahira
Blocks: 357818
Created attachment 244033 [details] [diff] [review]
October Omnibus Ads

I don't see any ads on the page in comment 3 (and in theory it should be blocked by the /ads/ rule for embeds).

I also don't see a good way to block comment 5 or comment 8, unfortunately.  All the rest should now be blocked, and I blocked an iframe that had been annoying me on VersionTracker (contextweb.com), too.

> There's also a horribly annoying set of GIF ads that shows up in the upper-left
> corner of http://www.lightingandsoundamerica.com/

I've blocked the ads, but they (and their grey backgrounds) appear in the upper-left corner because of bad UA sniffing :P

I backed out two problematic rules for comment 14 and bug 357818:
object[type="application/x-shockwave-flash"][id*="banner"],
div[id^="ad_"] 
(and the corresponding whitelisting of Gmail for the latter)
Attachment #244033 - Flags: superreview?(sfraser_bugs)

Comment 19

11 years ago
(In reply to comment #18)

> I also don't see a good way to block comment 5 or comment 8, unfortunately. 

Is "/sads/" too general (or too specific/likely to be broken)? That would take care of comment 5.

I think I might have mentioned this on IRC, but is 250x250 a common enough ad size that we can block it? (Comment 8)

cl

Comment 20

11 years ago
(In reply to comment #19)
> (In reply to comment #18)
> 
> > I also don't see a good way to block comment 5 or comment 8, unfortunately. 
> 
> Is "/sads/" too general (or too specific/likely to be broken)? That would take
> care of comment 5.
> 
> I think I might have mentioned this on IRC, but is 250x250 a common enough ad
> size that we can block it? (Comment 8)

I think both of those are too generic. I think we should strive to block ads supplied by the major ad providers, and not every little ad on random web sites.
> 
> cl
> 

Updated

11 years ago
Attachment #244033 - Flags: superreview?(sfraser_bugs) → superreview+
Status: NEW → ASSIGNED
Flags: camino1.0.4?
Whiteboard: [needs checkin]

Comment 21

11 years ago
Checked in on 1.8branch and trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1.1
Resolution: --- → FIXED
Whiteboard: [needs checkin]
*** Bug 360826 has been marked as a duplicate of this bug. ***
1.8.0 fix is in bug 359557
Flags: camino1.0.4? → camino1.0.4+
You need to log in before you can comment on or make changes to this bug.